Welcome to discussions

Quick Suggestions

  • Ubi-Keo
    Ubisoft Support Staff 2789 posts

    @timmy_p_jano I can confirm that this is a known issue and it is being investigated.

    I have merged your post with this megathread I have created for this issue.

    Official Response
  • Smrtiak.SVK
    171 posts

    @timmy_p_jano what is pretty weird it is happening only in Dublin, when I reload my manual save, I was able to be in all Ireland, but when I enter the Dublin and went into the centre of Dublin, this infinity loop starts again.... So not the whole Ireland is bugged, it is only about Dublin... I was also fast travel in Ireland, except Dublin, when I fast traveled to the Dublin, infinity loop starts again...

  • bielik01
    1283 posts

    @smrtiak-svk yeah, I was able to visit Reda in Dublin but immediately after I closed the dialogue, Eivor went sleeping.

  • Freestepper
    153 posts

    Just saying that i have the same problem. Just like everybody, i guess. Good to know it's being worked on.

  • nerex33
    9 posts
    After update 1.3.0 when I go to Ireland, Eivor goes to his bed there and the game gets in an endless loup that you can not exit anymore.

    Why does Ubisoft never test these updates!?!?!?!?

    I swear they don't test anymore. PS5 also has the bug. Its amazing, really. All platforms, same bug, no one knew before releasing it? Seriously. Amazing.

    *edit* Also, for some reason, after reloading and being back at Ravenshood, the shop keeper Yanli has different items every time. I've never seen that happen before.

  • Xadro_
    23 posts

    I have the same on PS5 but a streamer i watched could go to Ireland no trouble on XBOX Series X

  • Ryusennin
    124 posts


    Sorry but that excuse doesn't fly.

    Nobody -- and I mean nobody -- at Ubisoft ever tried to fast travel even once to Ireland, which is the latest DLC to date? I know internal and external testing is paid cheap these days, but a high budget game like Valhalla has had one of the poorest tech support in recent years.

  • Skald_Ger
    1 posts

    Same traveling problem here. Playing on PC.
    Tried it traveling via map and NPC but it´s always the same.
    In fact Ireland is not available atm.

  • Fafibo
    7 posts

    Everything runs smoothly on my XBox Series S. It's always strange that it doesn't affect everyone. Well actually there is nothing new anyway and the event will only start in 2 days. By then this error should be fixed. It would be bad if this error had occurred in the Paris DLC.

  • IronSoul27
    6 posts

    Well, that was interesting. Didn't know an update came out. Downloaded, started the game. My character was located in Ireland and now all it does is do the same cut scene over and over until I exit to the desktop. The cut scene is the character climbing into bed, waking up and then it immediately starts over again. Any actions to exit it automatically start it over. So ultimately there is zero way to exit this loop other than quit the game. Not sure if being in ireland makes a difference, but unfortunately it's where I was when the patch loaded.

  • kamooks
    1 posts

    I have this same issue. Travelled from England to Ireland after the 1.3 update and now i am getting out of bed and going back to bed in an infinite loop that i can't get out of. Talk about Groundhog Day the movie, AC style! If it is more than me, then it is alot of us. I am on PS4. Please fix before the festival starts Ubisoft!

  • Elhozzle843
    2 posts

    Since the update, anytime I load into the game (manual save or auto save) I am unable to control anything. My character just continuously goes to sleep in Dublin and when I press a button, it restarts the sleep sequence

  • Draiochta_Dajo
    1 posts

    @ironsoul27 Having the same issue in Dublin. Just was walking to the east, went to a scene where Eivor was heading to bed, wakes up, quick view of Dublin, and then starts over again.

  • mliddell9540
    2 posts

    I just killed Father Eogan and went through all the cut scenes and went back to Dublin. In Dublin I get up from a table and then my character contiues to go in and out of bed. The sleep cut scene happens everytime. I am in a loop and I cant get out of it. Please help.

  • LA_Frankie
    98 posts

    Traveled to Dublin to check on Reda and went to bed over and over and over and over. You get the idea.


  • xtar3000
    1 posts

    I have the same problem. Actually I can play few minutes after restart and then my character goes to sleep in Duplin, wake up, the sleep and it never ends and I cannot do anything, I have to exit from game and start from last save.

  • keremthns
    25 posts

    @ironsoul27 yes. I was at Ireland, when I fast travel to Dublin it starts sleeping and waking up loop infinitely!!!

  • Elhozzle843
    2 posts

    @xtar3000 I’ve loaded 5 different saves and the same thing happens every time. I can’t move or do anything. Completely broken.

  • d-warrior
    15 posts

    Same thing, all my recent saves were in Ireland and when I load it just puts me in the bed loop.

  • fasnes
    1 posts

    Also have the "bedbug" on ps5. Game is unplayable for me now. Giving it a rest until they fix this.

Suggested Topics