ubisoft discussions

Quick Suggestions

  • KevinRouleau
    2 posts

    Same here!!!

  • Exzult
    1 posts

    That's a lot of headshots.
    ... and yes I can't claim it too all my headshots don't register.

  • bielik01
    Original poster 1786 posts

    I think I know what may be the case... This challenge might have been released with latest Ubisoft Connect update: (https://forums.ubisoft.com/showthread.php/2358019-UBISOFT-CONNECT-MONTHLY-UPDATE-July-2021) and it might have proper counter implemented, but participation conditions seem impossible to fulfill.

  • mafuyu12
    1 posts

    @bielik01 I have the same problem

  • Hefeydd_
    27 posts

    Hi Chaps,

    I have an issue with the Egghead Challenge and I’m over 100,000 and yet is says my contribution is 0 and yet I am not alone here. I looked on Reddit and there are people complaining about this as well. So I am guessing this challenge is broken and I won’t get my bow. Please look at the screenshot of my iPad I outlined this. I didn’t know my contribution was 0 until I looked on my laptop because the IOS app doesn’t show your contribution only online does and I spent 1 and a half days using a bullseye bow and doing headshots and each time I done about 10 headshot I refreshed the page and it calculated my headshots XP but zero headshots so I am guessing the challenge is broken and we won’t get he bow.

    Thanks Ubi

    to be fair Ubisoft and I am a person who believes in honesty. Ubisoft Connect is a bit of disaster because the challenges don’t always calculate, for sample Assassinations complete 100 Assassins and it doesn’t always count you have to go to the game on Connect and then come back to challenges and hope your numbers are going up.

    Couldn’t upload a picture so I saved it to Google Drive for you please take a look you will see what I mean.

    https://drive.google.com/file/d/1XNWgdWJHkVbUsCoNGWhS1QbhrKDO0PBK/view?usp=drivesdk: (https://drive.google.com/file/d/1XNWgdWJHkVbUsCoNGWhS1QbhrKDO0PBK/view?usp=drivesdk)

  • RJEB94
    31 posts

    @joarragnar Ubisoft is already aware this problem and have been for about 3 days or so. The challenge is really broken for everyone and they are working on a fix for it. Ubisoft says if they can not find a fix for it everyone gets it for free regardless so there is that. Whether this is true or not who knows

  • Metallo75
    179 posts

    Not worry,they will fix this in time(as they done evething else before),only they need several weeks for it or few months,it will be fixed just in tim...........,,

  • gomcra94
    3 posts
    This post is deleted!
  • gomcra94
    3 posts

    @tyranusvader I was able to collect it now, must have just been an odd fluke.

  • jebus311304
    1 posts

    @bielik01 same. Tried every bow & every way of getting a head shot. Nothing works.

  • Blackwing2007
    3 posts

    @ubi-borealis I'm playing on xbox one x, and seeing the same issue. I have tried different types of bows, different tactics, missions and random guards, and no matter how many headshots I get, it doesn't acknowledge that I'm participating. But the count on the Time-Limited Community Challenge is over a million community headshots now. I've given it the weekend, and wanted to make sure you know that it's on this console edition too.

  • Vicious_Blaze
    1 posts

    Same boat as everyone else. Headshots not counting toward participation for the challenge.

  • bryanschnoor14
    1 posts

    Headshots not registering in Egghead community challenge. Is there any solution to this issue? I'm currently playing AC Valhalla on the PS4 and this is the first issue I've had with any of the community challenges. Where do I report this problem? Any help or guidance would be greatly appreciated.

  • Pinepyi
    20 posts

    I don't know anyone who has been able to claim it. Pc here.

  • LightmanN7
    11 posts

    Same issue for me...

  • IstelerI
    5 posts

    The same problem😠

  • vm4M9Tz4pB
    132 posts

    it required player to headshot kill only (without stating any amount, so 1 kill should be qualified), i didn't play it so long ago, but i just wonder it is a bug there, and i didn't find any official statement / notice of this issue.

  • DeathKing986
    1 posts

    Yeah, I can't get it either. I'm playing on Xbox 1 and I know I've hit several head shots, yet it won't let me get it.

  • Nightbladium
    1 posts

    Same for me, headshot are not registered on pc.

  • Ubi-Keo
    Ubisoft Support Staff 4276 posts
    This post is deleted!
    Official Response

Suggested Topics