ubisoft discussions

Quick Suggestions

  • victoruchiha82
    229 posts

    Question! Everybody else only got 1 daily appear since this update?

  • thesaurus2012
    11 posts

    @ubi-keo You don't know how to go forward either, we reported the two problems on the same date, and our colleague ubi borealis replied on the same day, you only solved the problem related to the “war effort” mission. The rest my dear sirs is a disaster, the support told me on Friday to wait 72 hours and after having reported the problem he replies that your teams are aware. But how? Can you solve a quest in less than 1 day and can't solve a server problem? Are there no testing phases before you publish something? "War effort" as it was designed is a disaster, there are people who will do it in your games, people who like the rpg genre of the saga. With Assassin’s Creed Valhalla you do not have accuracy in these things, I have always defended you I have always supported Ubisoft but lately you have been disappointing ... I have valhalla since launch and I do not know how many bugs I have found and when they were fixed I have always supported you! However, when there are bugs on opals or silver, run to solve them in less than a day, because of your damn microtransactions, to solve the silver bug you first had to publish a video on the connect "easy way to get silver" otherwise you won't you would never correct because you don't listen to the fans but only your partnerships! If you would have listened to your fans you would have paid more attention to details and possible bugs that could have occurred, but like every festival is a disaster, the first 2 were continuous crashes, the first (Yule) I couldn't even finish it because after an hour I get the word “festival finished” AFTER ONE HOUR that you have published it! Is this the free support you give, crashes and bugs they report to you but you don't care about?

  • Shangrial
    3 posts

    Same issue here. Just checked and did headshots in open world and river raid with predator and hunter bows. Confirmed headshot kills. Nothing doing on the challenge, doesn’t show any contribution. Total is over 1.1mil atm.

    playing on PS5.

  • Lorion2k3
    1 posts

    Same issue for me. Even started a new game and killed several enemies with headshots. Still not counting. All the other time-limited challenges seem to work.

  • Sammarok
    177 posts

    @victoruchiha82 No, but that is another issue that was reported before in a different post. Anyway, the issue is the level scaling, put it back to default and it will resolve the issue.

  • victoruchiha82
    229 posts

    @sammarok so you have the bow?

  • bielik01
    Original poster 1773 posts

    @victoruchiha82 don't go off topic, the issue has been reported already

  • victoruchiha82
    229 posts

    @bielik01 don’t want Ubisoft to get mad

  • GhostAgent14
    189 posts

    Same here about not being able to claim the Einherhar Bow, and I'm on Xbox One.

  • Tami1993
    8 posts

    Same here, I'm on PC and I also can't claim the Altair outfit which should be for free.
    I'm kind of glad that it's not only me...
    Also, I made sure to headshot a dozen of people. I even wanted to take a photo of one dead with an arrow in the head, but Synin was faster....

  • TyranusVader
    121 posts

    @tami1993 Regarding the Altair outfit, you already have it because you claimed it through the Godly Rewards promotion a few months back. Check your inventory. It should be there.

  • Mirmidonas74
    28 posts

    Honestly it becomes annoying. Why Ubi has to rush through the games and dlcs most of the times? I rather wait longer for the release to ensure that I ll enjoy it, rather than having an early broken or buggy or even unfinished game. Am I asking too much?

  • lynvingen.
    1 posts

    Unable to claim the Community Challenge reward even tho I've been scoring headshots since the very beginning of the challenge. Playing on PC - connected and online.

  • Midnight8771
    1 posts

    It's not counting headshots for me either. It doesn't matter if I'm in the river rage or out in the open world all I do is headshots and I don't get credit for it but like everyone says the number keeps going up but it keeps telling me to participate to claim my prize I'm also having trouble trying to connect to Ubisoft connect does anyone else have the same issue

  • Caveman_107
    1 posts

    Still unable to claim the Einherjar Bow from the Egghead Community challenge, total goes up for the community only, still says participate to unlock the reward, no matter how many headshots you make

  • WildHunt
    220 posts

    Any update on this? Less than 3 days to go and I don't trust Ubisoft to compensate us for this item once the time runs out.

    I am sure I speak for many when I ask why wasn't this tested? What is going on with QA? Nothing has changed from when you gave reassurances that QA would improve.

  • Deamonzslayer
    1 posts

    Been playing river raids, daily missions and just some freeroaming where i kill all kinds of enemies with headshots.
    Still can't unlock the bow (PC).

  • Vatandi
    10 posts

    @deamonzslayer In my opinion, they do nothing. We are unlikely to get a bow.

  • Jamezall
    1 posts

    Same here on PS4, still unable to claim Einherjar Bow on Egghead Challenge.
    I’ve tried various types of bow and different locations including river raids but it’s still telling me to participate to earn the reward. Hope a fix is managed soon 🙂

  • arag25
    16 posts

    @wildhunt Don't expect to receive anything.

Suggested Topics