Welcome to discussions

Quick Suggestions

  • bielik01
    823 posts

    I believe it's kinda related to Unable to complete "Trial of the Morrigan" in Connacht, but only Xbox players were affected. TU 1.3.0 fixed it for them, but now PS4&5 are suffering from similar bugs.
    @Ubi-WheelyDuck & @UbiSushiVamp I saw there people reporting inability to complete trial in Ulster, so that would need some posts to be moved here.
    And while we're at Trials of the Morrigan, can I ask you guys for a look in Unable to re-play Trials of the Morrigan / restore Trade Posts on second playthrough? It really is bothering me.

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts
    Best Answer

    Hello there!

    I apologise for the double post. Following the release of TU 1.3.1, a fix for the Trial of the Morrigan in Ulster has been deployed. This issue should now be resolved!

    If you are still unable to complete the Trial, please don't hesitate to update us within this thread so we can investigate further. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the bottom right-hand corner of the main game menu.
    • That you are unable to complete the Trial of the Morrigan in Ulster.


    I'd recommend uploading your video to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a shareable link within this thread.

    @jwheels1209 - Welcome to the forums 🙂 Just to confirm, have you been able to successfully complete the Trial following the release of TU 1.3.1? I'm sorry to hear that you've encountered issues when collecting amber shards as well. We have a dedicated Megathread for issues related to the amber shards, so I recommend that you share your report within this thread so we can take a closer look.

    Thanks! 😊

    Official Response
  • terrakim30
    1 posts

    I have the same problem as well. I played in PS4, and even though I've already killed all enemies, the trial didn't complete. I can repeat the trial with no limit.

  • MunchMe
    2 posts

    Cannot complete trial of morrigan in upper right of Ireland map, North East of Ardmel trade Post, allows me to kill everything but doesn't complete, just allows me to go again, as much fun as it is getting free xp wouldn't mind actually finishing it so can get the trophy for completing Ireland.

  • PapaRoc54
    1 posts

    @shalminoc I can't complete either 😕 Same place (Ulster) I beat them, the fog dissappear and I'm back at square one. As if I haven't done it. Begin the trial is still there.
    PS4 too. And with the 1.3.0 patch.

  • Randomeh
    1 posts

    I am having the same issue with the Trial of the Morrigan in Ulster, east of Ardmel. On PS4

  • lbpirard
    1 posts

    @busiestgem77 I'm having this exact issue myself on PS4.

  • McLovin42X
    2 posts

    I've encountered another bug now in the Trail of the Morrigan in northeastern Ulster, I finish the trail but it doesn't count towards completing the mystery, and it never ends. This is the only thing left for me to get 100% completion on the DLC. Please help fix this! I'm playing on PS4.

  • bat678man
    20 posts

    I can't even start any of them apart from the one to the east in the northernmost region. Unfortunately, the problem I have with that specific one is that I can't complete it. After I kill all the enemies the trial just resets.

  • PhantomVerity
    1 posts

    Same as everyone else, playing on PS4 and cannot complete the trial in Ulster. Would like to do this to complete the trophies in Ireland😖 😖

  • SiblingChris
    10 posts

    Can report issue is fixed for me since update 1.3, had to complete this last location and then it registered properly with the final achievement

  • jshm06
    1 posts

    I am unable to complete the Trial of the Morrigan in Ulster. The one above the Ardmel trade post, this is literally the last thing in the game I have to do and it's irritating that I can't do it, it just makes me replay it over and over and it is very annoying. This issue seriously needs to be fixed, I searched and searched trying to find a solution but I found nothing. This is seriously pathetic of Ubisoft.

  • MunchMe
    2 posts

    @busiestgem77 yes having exact same problem, last thing I need to complete ireland to....

  • Plaatvoet
    3 posts

    @ibrahimhq
    Got the same problem with a diffrent location. The Trial of the Morigan in Ulster, north-west of the Ardmel tradepost.
    Its the last thing I need to do for the Irish legend trophy.

  • Busiestgem77
    Original poster 7 posts

    @ubi-wheelyduck Sorry for the late reply, but like the other guy said, no matter how many times I complete the trial (aka kill all the enemies), the icon never goes away and it doesn't count towards Ulster being completed. Thanks for replying!

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there!

    I've merged together a couple of threads about being unable to complete the Trial of the Morrigan in Ulster following the release of TU 1.3.0. I apologise if any confusion has been caused by these merges.

    Thank you @keremthns for sharing a video with us! I've collected the reports that have been shared with us within this thread and passed them along to the development team so they can take a closer look at this issue.

    If we require any additional information from you regarding the Trial in Ulster, we will reach out within this thread.

    @bielik01 - A member of the player support team will reach out with an update within that thread about replaying the Trials of the Morrigan as soon as they are able to.

    Thanks! 😊

    Official Response
  • Boggle1996
    2 posts

    im having the same issue at Ulster trial on PS4 and I have the latest update.

  • Danikcus
    6 posts

    On PS4, Trial of Morrigan in Ulster resets upon completion. Although it gives XP, it does not give completion credit or reward Skill Point.

  • mns410
    1 posts

    Just dropping by to say I’m having the same issue. Playing on PS4, first play through of Wrath of the Druids, able to complete everything else except the trial with the werewolves out near Ardmel in Ulster. I’ve tried three times and defeated all the enemies, but it won’t mark as complete. I left the area and came back, exited and reloaded the game, and it’s still not completing. At this point I think I’m just destined to be one of the lucky ones who keeps getting bugs that prevent completion.

  • UbiStorm
    Ubisoft Support Staff 283 posts

    Hello everyone! The team investigating this issue would like to know a bit more information from everyone experiencing this issue! Did anyone complete these trials in a different playthrough of the game? Or were any of you in combat prior to interacting with the brazier?

    Official Response
  • UbiStorm
    Ubisoft Support Staff 283 posts

    @danikcus Hey there! Thank you so much for reaching out and posting this video! This is under investigation, and I do apologize for the frustration! There is a megathread about this issue located here! Would you answer the following questions on that thread for me?

    • Did you complete any of these trials on a previous playthrough?
    • Were you in combat prior to interacting with the brazier?


    Official Response

Suggested Topics

Community Details

144
Online
193.5k
Users
32.7k
Topics
163.4k
Posts