ubisoft discussions

Quick Suggestions

  • 5 Likes/256 Replies/18261 Views
    Ubi-TheBerry
    Ubisoft Support Staff 3348 posts

    Hey guys,

    Thank you for your updates!

    A fix was pushed last month which was supposed to resolve this.

    If Ubi-Froggard's steps don't help you, could you please also ensure you're running the latest version of the client?

    Please let us know if there's any changes so we can keep the team in the loop.

    Thank you!

    Official Response
  • VolveAlMenuBobo
    20 posts

    The latest Connect update has fixed the issue for me. I have not seen a password or authentication screen since then.

  • Ubi-Milky
    Ubisoft Support Staff 3015 posts

    Brilliant! Thanks for confirming this @elreydecasual

    If anything changes, please let us know in this forum thread, so we can continue to pass on reports to our Connect team.

    For anyone else who has experienced this issue, please make sure your Connect launcher is fully updated with the new patch installed, which should resolve this issue.

    Official Response
  • remijdio
    4 posts

    At this point in history 3 things will always remain true. Death, taxes, and ubisoft's launcher being awful. I enter my password multiple times a day. So much so I wrote an autohotkey script to do it for me (I know that's hella bad for security but jeez I shouldn't have to enter it multiple times a day! It's not my fregin bank!). I also have to do 2FA EVERY SINGLE DAY. I was working my way through some AC games but at this point I think I'm just gonna uninstall all of them so stupid Ubisoft connect isn't constantly berating me with "You were inactive for 5 minutes! We disconnected you!!"

    To Ubisoft support, your job must really suck having to field all these problems. I'm not mad at you though. I'm mad that the company you work for has been shrugging these issues off for years now.

  • MagicMuzhik
    1 posts

    The issue is still reproducible today 29-Nov-2021 with the latest Ubisoft Connect version (fully reinstalled as well).
    "Remember Me" check-box doesn't work and the user has to use MFA each time after "logged out due to inactivity" message several times a day. Device is marked as trusted each time by the user but it doesn't help.

    Windows 11
    Lenovo Legion 5 2021

  • Ded4n
    1 posts
    This post is deleted!
  • xrayspex_73
    167 posts

    @elreydecasual Give it time. It WILL prompt you eventually and then it will do it near daily. This is NOT fixed at all.

  • AntisociaII
    1 posts

    hello can you check how many days i have left till i can change my ubisoft name , my name is  AntisociaII and thats with 2 capital i's

  • Ubi-Viral
    2366 posts

    @antisociaii Hey! This is not something we can discuss over the forums.

    You can contact us via a private message on our social media channels here:
     
    Facebook
     
    Twitter
     
    Alternatively, you can reach out to us via a support ticket HERE or a live chat HERE.
     
    Thank you.

  • Ubi-Viral
    2366 posts

    @xrayspex_73 Hey! Thank you for letting us know, I will pass this report on to the Ubisoft Connect team.

    Thank you.

  • VolveAlMenuBobo
    20 posts

    It started asking me for authenticator code again. TF is wrong with this application?!

  • Ubi-Dino
    Ubisoft Support Staff 100 posts

    Thanks for reporting you're still being prompted @elreydecasual! Is it only for the code you're prompter to reenter, or does it also ask you to login again every time?

    Official Response
  • VolveAlMenuBobo
    20 posts

    @ubi-dino no login info, just authenticator code

  • xrayspex_73
    167 posts

    @ubi-theberry Your "fix" did nothing.

  • joedit88
    1 posts

    I have the same problem and it seems UBISOFT has gone soft on customer service. It is keeping me from buying Far Cry 6 or any other games.

  • VolveAlMenuBobo
    20 posts

    @xrayspex_73 you were right 😣

  • rackrazor73
    1 posts

    @ubi-milky

    I still get this. I purged the client from my computer and downloaded and ran the latest installer as admin and still have this issue. I will say I am running this on Windows 11 so I don't know if that makes a difference. I also use the Google Authenticator for the 2FA, but that shouldn't matter on a trusted computer. Niether check box seems to make any difference. Its annoying as hell. When Connect is minimized in the tray and you launch from another client like Steam, the game just doesn't load and its becuase you've been logged out again and don't see any warning message about it. This can happen several times a day.

  • Ubi-Dino
    Ubisoft Support Staff 100 posts

    Hey everyone!

    @xrayspex_73 & @ElReyDeCasual - I'm sorry to hear the previous suggested fixes aren't helping you out with this issue. When you exit Ubisoft Connect normally, do you leave it running in the background, or do you fully close out the application?

    @rackrazor73 - To clarify, are you being prompted to login again AND re-enter your 2FA code every time this happens to you?

    @joedit88 - I'm sorry this issue with the remember me function has been preventing you from buying other games you may be interested in. Have you always been prompted to do this even when setting up a trusted device, or did it start more recently for you? Also, please clarify if this is occurring for either a 2FA code, or your Ubisoft login, or both?

    Official Response
  • jk206
    1 posts

    Same. Launcher signs me out all the time and always asks for two factor and never remembers. Fix your stuff, not a good experience. No, uninstalling and reinstalling everything isn't a valid fix.

  • Ubi-Milky
    Ubisoft Support Staff 3015 posts

    Hello @jk206 thanks for letting us know of your experience of the 'remember me' tick box function not working correctly for you and for letting us know you reinstalled the Connect launcher, following these steps > https://www.ubisoft.com/en-us/help/connectivity-and-performance/article/installing-or-reinstalling-ubisoft-connect-pc/000063173

    Can I ask if you have also tested this whilst >

    1. Your computer is listed as a trusted device in your account management settings? > https://account.ubisoft.com/en-US/security-settings
    2. Your computer is not listed as a trusted device in your account settings?
    3. Have you tested this with 2-factor authentication disabled on your account?


    If you can let us know if this still occurs in all of the above instances, we will pass this information onto our Connect team, thank you.

    Official Response

Suggested Topics