ubisoft discussions


  • topic_unsolved Patch downgraded to 11, DLC is blocked again!

    2 likes/44 replies/2665 views
    ubisoft:x-posts, 3

    @manisc09, Great thanks! It did help and even my game is back!

  • RaadushS
    ubisoft:x-posts, 1

    Hi, I am confused. Is High life released? I see Anno 1800 - The High Life DLC is now available! post from yesterday in UbiConnect, the release date is August 31 on multiple sites, shop in UbiConnect says I own the dlc, yet no download was performed yesterday and when I run the game, the dlc is locked with message DLC is not yet available

  • jobro_06
    ubisoft:x-posts, 7

    Just an update. I shut down my PC earlier this morning and only just turned it on now. As soon as I turned it on, something started to download in the background. Now, I didn't know at first what was downloading but when I clicked on Ubisoft's app "UPlay" on my desktop, it asked me if it could make changes to my PC, which I accepted. As soon as it finished downloading, I launched the Anno 1800 and I was greeted with a pop-up message stating that High Life is now available as part of my Season 3 Pass collection.

    Anyway, this is my advice.

    1) Verify your Anno 1800 files.
    2) Turn off your PCs before turning them on again (restart) and click on your Ubisoft app or "UPlay" on your desktop to launch it. Your app should then notify you that it wants to make changes to your computer through a series of flashes on your desktop. Accept all of these and just wait because it should start to download High Life.
    3) If you have Google as your default browser, then you should see the green download bar grow on your taskbar. All this simply means is that the dlc is being downloaded.
    4) Once finished, simply launch Anno 1800 by clicking the "Play" button, and voila! You should now have High Life as part of your Season 3 Pass collection.

    If none of the above works, simply verify your Anno 1800 game files and repeat the above.

    PLEASE NOTE! Mods do affect content from being downloaded. So, please be aware of this as running mods at the same time with the main game is a preference and not a necessity. Ubisoft's liability also doesn't cover mods, which means they cannot help anyone running mods with the main game. Disable these mods first before seeking any further assistance.

  • Asterix201252
    ubisoft:x-posts, 522

    I have had this happen a couple of times before. I suddenly get random quests in a sandbox game that's been going at least tens of hours .from Aarhant and the daughter from the campaign (forgot her name). This happened before the High Life update, so I don't think it's directly related to the update. I just went along with the quests for a while, because they didn't seem to affect my real game, and eventually they just randomly stopped again.

  • Nicholas_Steel
    ubisoft:x-posts, 83

    @gschagas I can confirm your issue. I ran UPlay and was able to launch the game multiple times with it being GU 12. I've just now launched it again from the same instance of UPlay and it triggered a UAC prompt, a 466MB game update and then when the game loaded it was GU 11 and many UI elements were broken with missing text (I assume my settings are reset yet again as well since GU 11 and GU 12 have incompatible setting file formats).

    The game also popped up big windows showing images of each DLC (had to click the X several times to see that not only were those prompts missing text, but the main menu was missing text as well).

    Windows 10 21H1 x64

  • Asterix201252
    ubisoft:x-posts, 522

    I also had a very similar issue. The behaviour that I saw looks very similar to what Nicholas_ Steel describes. I think his/her post popped up while I was typing this.

    Yesterday evening (UK time) the game downloaded the High Life update (version 12), 1.96 GB. The game updated to Version 12 and I played several hours without any trouble. I saved and re-started the game a couple of times.

    I went back to the game just after lunch today. The first thing that happened was an update to Ubisoft Connect. Then there was an update to the game (about 500 MB). When the game launched, I first got a series of pictures with a blank text box near the bottom that seemd to be about each DLC. After that, I had the main menu, but all the text boxes (save game, load game etc) were missing. I used ESC to leave the game (text boxes on this were good). I verified the files, and I then restarted the game. This time, it said it was version 11. The main menu was normal, but all of the saves since the large update yesterday were missing from the LOAD GAME menu. I checked in my Widows folders, and they were all still there. The High Life icon was greyed out and it said that I didn't have the game loaded.
    Taking advice from earlier comments, I decided to re-boot my PC. The game then downloaded another 1.96 GB download. The game launched, and it was Version 12 again. The High Life icon was present and so were all of my saves from yesterday evening. It seems to be playing normally again.

    So it seems that the suggestion to re-start Ubisoft Connect may well work. I suggest people suffering this issue try that, and re-boot thei PC if that doesn't work.

  • Nicholas_Steel
    ubisoft:x-posts, 83
    The main menu was normal, but all of the saves since the large update yesterday were missing from the LOAD GAME menu.

    That's good, that means there is a Version Check being performed to prevent old copies of the game from loading files made in a newer version of the game, to prevent file corruption.

  • Nicholas_Steel
    ubisoft:x-posts, 83

    Restarting UPlay does seem to trigger the Game Update 12 to download again (1.96GB! Massive download!!!!!). I am going to pause this and wait until tomorrow, there is no point in wasting my time and download quota with an unknown risk of it downgrading again.

  • ineedtoplay
    ubisoft:x-posts, 11

    Yesterday I downloaded the update and all was ok.
    This morning when I want to continue playing there was another update downloading, after the download completed I started the game and when it got to the main screen all I could see was large screenshots, and at the bottom it said the game version was 11.1.1010647 - that was strange, I had to ctr alt delete to get out of the screen.
    I started the game again this time there was a download of 1.96 gb.
    After download complete I started the game and all was ok giving a version no. 12 etc.

    Now then, I exited the game for lunch but when I went to play the same thing happened again, I had to go through the 2 downloads to be able to play for a short time.

    Before I started the game up again into the settings of the Ubi Launch and unchecked the Automatic Game Update option, I went to start the game and it was ok.

    So why would want to be loaded the new update every time, a friend of mine in the US has not had this problem?

  • Tolstoyevsky
    ubisoft:x-posts, 2

    @ineedtoplay I have the same problem. My guess is that it has something to do with the free weekend.

  • Kajsa_Kavat
    ubisoft:x-posts, 7

    It's a bit of a roller coaster for me.
    This morning I got a 500mb update which reverted the game to update 11 and broke it (no text and all).
    Then I restarted Ubi Connect and got the 2gb update again, all settings were reverted to vanilla, but at least my saves were fine.
    Now after work I came home to another 500mb update, the rest is like before.
    Hope this helps in anyway, just don't close Ubi Connect for now. 😄

  • fox2196
    ubisoft:x-posts, 1

    Restarting the UPlay app works for me!

    Seems Ubisoft has pushed a free weekend patch(around 400MB) to everyone, which does not include the High Life DLC.
    Restarting the app makes the 2GB High Life DLC patch available again.

  • Isabel_Ringing
    ubisoft:x-posts, 10

    @ubistorm same issues here as the OP - already did what you suggested. There is a cycle that keeps happening, load the 2GB update, seems to work, shut down, reload ubiconnect, 400MB patch comes in and then no text issue, can't figure out what is being asked, exit the game, exit ubiconnect - next start and back to previous game update (11). restart cycle


  • ineedtoplay
    ubisoft:x-posts, 11


    It was happening to me.
    I unchecked the Automatic Game Update options in Uplay Settings, it solved the problem for now.

  • harold883
    ubisoft:x-posts, 1

    I have the same problem today but yesterday evening all was ok !

  • Isabel_Ringing
    ubisoft:x-posts, 10

    @ineedtoplay Thanks - I just un-checked that. it will be interesting to see what happens now.

  • Bexxi_Sadman
    ubisoft:x-posts, 2

    @ineedtoplay for me too actually, with it i have no buttons or text in menu or savegame

    Update: after unchecking the automatic updates i have the savegame without the dlc and progress in it

  • Bexxi_Sadman
    ubisoft:x-posts, 2

    @ubistorm the start itself was normal, but in the game menu were no buttons. i could just load the quick save file and then there missed the text from the citizen classes for example.

  • HIPE172
    ubisoft:x-posts, 18
  • Ubi-Nacho
    Ubisoft Support Staff ubisoft:x-posts, 1736

    Hi there all.

    Thank you all for the reports on being rolled back up version 11.

    This issue currently has a workaround, and we ask that players affected verify their game files. Once this has been done, restart Ubisoft Connect with admin rights, and re-download patch 12.0.

    Should the game roll back to 11.1 after this, please repeat the steps above. The team is aware of this issue and is currently working on a solution.

    Apologies for any inconvenience caused by this.


Suggested Topics