ubisoft discussions

Quick Suggestions

  • Mofalon
    8 posts

    @as1r0nimo, did you install the latest patch/update? I haven't yet, so I can't confirm anything, but it's possible that they resolved it.

  • A Former User
    0 posts

    Great.

    Problem is, I had blurry textures without the HD texture pack installed.

    Can anyone confirm whether or not this has been addressed as well?

    Many thanks!

  • Vilemos
    64 posts
    This post is deleted!
  • FriteuseBelge
    34 posts

    @mortilla_ I'm going to try asap, will let you know. I uninstalled the HD pack last month, tried yesterday with Nvidia Studio driver and blurry textures happened after 1 hour... Fingers crossed for this new update, but no big hopes. And to be honest, with all the existing issues, their patch notes is quite hilarious. It's been 2 months...

  • Umilton
    21 posts

    The HD textures are now better almost everywhere it seems including water surfaces, vegetation and others. I didn't take the patch notes seriously when it said HD textures have a fix for blurry textures. I'm on a Titan Rtx. If anyone can verity HD looks noticeably more detailed now on a 3090 or Titan Rtx. So I'll know it's not just in my head.

    Edit - I think what I'm trying to say here is in the process of fixing the really bad blurry HD textures they have improved the detail of most HD textures. But again I'll get nowhere with this claim unless 3090/Titan users notice the difference too.

  • RegZieeeX
    29 posts

    Just tried the game WITHOUT the texture pack installed, never used it before either but for the first time can confirm the textures are loading properly with this new patch. Only got to play for about an hour but so far so good. Shame this took 2 whole months to be fixed but hopefully this is it and no more buggy textures. I might actually play and finish the game now.

  • Mayjay
    4 posts

    @ubi-borealis Hi there, thanks for the update. Title update #3 seems to work for me, after having had the blurry texture issue since launch. I really tried getting blurry textures by loading an old savegame with lots of guns and armor sets, switching them, driving around, blowing things up and switching resolutions and graphics options. No issues so far.

    Although I've already finished the game with blurry textures, I'm now replaying it with the sharper ones. Far Cry 6 looks gorgeous (I wasn't able to see it in this state before, it makes a huge difference)! So if you don't mind, I'm going to have to brush up my Spanish and blow this island to smithereens again. 😁

    Thanks again!

  • A Former User
    0 posts

    @friteusebelge Thank you!

    Yeah, it's been kind of a mess with the blurry textures. I remember seeing the official Ubisoft Twitter handle posting screenshots of a blurred-out Guapo (the pet crocodile) to serve as digital marketing -- clearing indicating that this was a known issue, even in-house, yet it took them weeks to fully acknowledge it, and here we are 2 months later.

    But maybe it's finally fixed? If you can check that out then that would be much appreciated! 🐷

  • Mofalon
    8 posts

    I can confirm that after installing the latest patch + enabling the HD texture pack with an RTX 3080 at 1440p, I can now run the game without getting blurry textures, although it seems like the GPU is using more VRAM which is giving me less performance at certain points, like 60 FPS or more with DXR on, and about 72+ without them.

  • Nemanja_99
    23 posts

    It has finally been fixed, now I can say that I am satisfied with the game and that I can continue playing.
    Yes it took a while but at least that big problem has now been fixed.

    Every part for the patch.

  • FriteuseBelge
    34 posts

    @mortilla_ It's been fixed. No more blurry textures. Playing with a 3070 at 1440p without the HD texture pack for about 2 hours, everything is good. Stuttering is still there while looting, everytime the autosave appears, but they are aware of the issue, let's wait another 2 months maybe 🤡

  • FriteuseBelge
    34 posts

    @nemanja_99 Same, I started a new game, to finally enjoy the game... Of course there are still more little issues, but it's finally a better and normal experience.

  • As1r0nimo
    345 posts

    4gb Vram here (16gb ram)
    Can confirm that blurry textures are gone (at least for the start of the game). No HD pack even downloaded

  • lovegrudb
    6 posts

    I confirm, the problem has dissappeared. rx570 4 gb vram

  • Ubi-Thrupney
    Ubisoft Support Staff 2262 posts

    Hey everyone, thanks for coming back to the thread with these reports that the issue seems to be resolved, both for HD Texture Pack users, and those playing without it. I really appreciate these updates!

    For those who reported other issues (but who confirmed the blurry textures was fixed), I've moved your posts to new threads so I could more directly respond to your new issues - let me know if there was any confusion or questions!

    Official Response
  • mickharnas
    29 posts

    @lovegrudb

    On my GTX 1660 I've checked 10 minuts yesterday and textures looking good now, hope this issue is solved definitely.

  • Ubi-Borealis
    Ubisoft Support Staff 5646 posts

    Thanks for sharing an update with us, @mickharnas! I'm glad to hear that your textures are looking good 😄 If you encounter any further trouble, please don't hesitate to reach out to us 😊

    Official Response
  • MarcelDuchampo
    4 posts

    The latest patch has fixed this problem for me. No more blurry textures with or without the HD texture pack on a RTX 2070 8GB. Looks great now. Glad it got fixed, but it sure took a while. Don't know how this made it past testing. Oh well, seems to be good now. Thanks!

  • Daitan86
    60 posts

    Glad to see that the problem has been solved.

  • mickharnas
    29 posts

    @ubi-borealis

    After last patch textures are fixed but I've observed another problem. Start playing on my GTX 1660 on ultra settings + HD Textures with 60 FPS lock and my GPU is loaded between 85% to 100%. My card is not to much powerful but playing is smooth and satsfying for me but... playing further when I exit to menu, or game loading some cutscene my GPU load suspend to 100% and my FPS drops to 10-12 for a reason. Nothing helps, minimalize - maximalize, V-sync ON to OFF or OFF to ON, enable - disable FidelityFX, just I must exit to main menu and reload savepoint. Someone had same issues? I've try few times and problem is still appear. [censored]?

Suggested Topics