ubisoft discussions

Quick Suggestions

  • Graven.BROKEN
    4 posts
    I can confirm now that using the driver 471.96 is fixing the blurry textures! But... You need to turn OFF the RAY TRACING! For some reason, with this driver the RT is causing the blurry textures again. The latest driver (472.12) is making the textures blurry as hell RT On or Off. So to fix the blurry textures, download and install Nvidia driver 471.96 and disable RT, it should work! Ubisoft still needs to fix it definitely but this workaround seems to work!

    Did not work for me unfortunately.

  • Silver0Whisp
    1 posts

    Having the same issue on a 2080 Super with RTX off and no HD Pack. I've got custom settings where the only thing set to ultra is texture filtering. Even with the fidelity FX, it doesn't change it. Digital Foundry found this issue only affects Nvidia GPUs for some reason. It's like the game doesn't use its memory properly for Nvidia cards and even their 3080 showed just over 8gb of vram being used in MSI Afterburner. Their AMD card had no issue with this. This tells me, someone, either forgot to tell the game to use both cards to their fullest or it was deliberate in order to make AMD happy since the game seemed to be sponsored by them. So much for that whole 'dedicated PC team' stuff. I mean not many people have these new cards thanks to scalpers. This should've been caught.

  • eirevin
    7 posts

    @Silver0Whisp check my previous comments, the issue also occurs with AMD cards. This is not a Nvidia specific problem. I also "won the lotto" with an unfortunate waste of money way too soon.

  • ChangingSoda
    1 posts

    @Silver0Whisp AMD user here. Got the same problem. Stop believing everything you see on YouTube not everything is a scheme.
    My friend also has an amd card and is having the same problem.
    My gpu - gigabyte RX560.
    NO HD TEXTURE PACK INSTALLED EVER.

  • W724297681
    3 posts
    This post is deleted!
  • W724297681
    3 posts
    This post is deleted!
  • W724297681
    3 posts

    是的,我也遇到了类似问题!
    我的配置如下
    CPU:5950X
    GPU:RTX3080
    32GB
    2K 165hz
    已下载高清包,并且画质最高。
    游戏前面一段时间会出现枪械或地图模糊的问题,不过游玩20分钟后就会立即正常显示高清贴图。
    附上模糊问题截图。



    以下是游戏后20分钟正常截图



  • DJKeens
    3 posts

    I'll throw my two cents in. Guado, shirts, guns, and occasionally ground and foliage textures. Not sure if it's part of the problem but HDR is also N/A which gives me the impression that the game isn't recognizing my setup. I've played with tons of different options to try to find that magic bullet to no avail.

    I keep hearing "turn off HD textures" but I'm not using it. Let's move on from the HD pack please. That's not root of the problem. If it were, those of us that aren't using it wouldn't be here.

  • HASOONYF4
    26 posts

    I hope a fix release soon, i really want to play the game but the textures are really bad even with HD textures disabled, the first time i boot the game textures look clear, as soon as i enter a car and get out, everything becomes blurry

  • Lettucel
    3 posts

    Having the same issues on my RTX 3060m 6gb + AMD Integrated Graphics Card, 16gig DDR5 ram and AMD Ryzen 7 5800H CPU Laptop.
    No HD Textures Installed.

    I have no issues running the game above 60fps 1080p on Ultra, for the first 5 minutes the textures are sharp @ ~70-80 fps 99% (Lowest 50fps). Card temps stay at 50-70C. CPU temps in 80-90s Celsius.
    After running the game for 5-10 minutes the textures and LOD on hands/guns/NPCs gets blurry.
    It seems that the 3060m clock speed drops by about 200-300 (From 2000 MHz to 1700MHz in Alienware Command Center), keeping my CPU at 40% utilization (resource monitor).
    The 3060m chip does not get hotter than 70C in the most extraneous situations on ultra.

    It also seems that the game continues to render in the background as if you're 'actively playing' it when tabbed if un-paused;
    Try alt-tabbing and looking at your computers resources when un-paused, mines remain unchanged.

    Further, the VRAM in the menu seems off; Indicated 3.77g of vram used in the menu when actually is using about 4.2g on Ultra.

    I've tried replicating this using every setting available (low, medium, high, raytracing off, resolution 720p). I tried deleting FarCry6 from MyGames in Documents.
    Even on the lowest settings the textures substantially decrease in quality within 5-10 minutes of gameplay.

    I was thinking that this happens in my situation as more of the level is rendered.
    I was basing it off the camo on my rifle: As I run further down the road after turning loading first into the game, the camo goes from crispy to low quality.

    Interestingly enough this issue exists in Control: Ultimate Edition when using DirectX12 as well, where I believe the pooling of textures is setting itself to lowest resolution within a few minutes of runtime and is currently fixed only with a mod.
    This also was observed in Monster Hunter World and Fortnite DX12 (the trees would be rendered as if you were across the map, I believe it got fixed in Fortnite's case however).

    Maybe a bug with DirectX12 implementation?

    The fact that the issues exist on the 3080s indicates that something limits the game from loading textures when pushing hardware, or as hardware utilization ramps up. (Check @W724297681 Post for Screenshots on a 3080 RTX, I am not sure what they wrote lol, I believe they said that the game runs blurry for about 20 minutes before textures start loading properly or otherwise, but their computer is significantly high-end and still has this issue).















  • N0xy01
    1 posts

    same problem here with my 3070. Texture HD Pack doesnt work ! God !!! Do something !

  • zerotery
    7 posts

    I try for disable DXS (ray tracing) feature and disable HD texture it help for this problem.



  • ASUSSTRIX777
    2 posts

    @lettucel It sure doesn't have the same colours and sharpness Far cry 5 and new dawn had, seen that the same engine is being used. To me it look like like a 'Nvidia' forgotten code problem....

  • Mersaldir
    10 posts

    I'm joining the ranks here.

    The textures of the weapons and clothing are sometimes blurry and do not load/stream correctly. It doesn't matter if the HD-textures are enabled or not, although subjectively it happens more often when HD-textures are enabled.

    For me, it sometimes helps to switch to the options and go back into the game (e.g. switching DRX on/off). Sometimes it also helps to switch weapons until the textures are fully loaded.

    RTX 2080 Ti, 9900K

  • HASOONYF4
    26 posts

    @mersaldir same thing, switching weapons alot helps sometime

  • uplaysucksau
    6 posts

    Mark me down. 3080 & 9900k, on an SSD. Latest Nvidia drivers. Happened before I tried the HD pack, happened with the HD Pack, happened again after. Tried all the options menu I could think of, nothing works.

    Everything is blurry AF, it's so bad it's unplayable. Trees in particular look awful, and so do the weapons.

    I went back into FC5 which I have the HD pack for and I think it might have the same issue, especially with trees.

  • c4sK
    1 posts

    Hardware - RTX 3080, Ryzen 9 5900X.
    Resolution - 4k

    Everything is on Ultra apart from DXR. I am using 6.23GB of VRAM with HD Textures on. The textures are that bad that I have stopped playing for the meantime.

    Is there a patch inbound for this?



  • Ravnsmod
    13 posts

    @c4sk I would follow this post as it looks to be the biggest one on this issue. You are not alone 😉
    https://discussions.ubisoft.com/topic/111264/some-of-the-texture-mapping-in-the-game-is-blurry?lang=en-US&page=1

  • Zummwalt
    4 posts

    w11x64, 3700x, 3070, last driver
    hd or not - same thing: replaced weapon and appeared blurring - in game and menu

  • uplaysucksau
    6 posts

    @foulplayfox I got that when I tried to use sharpening from the Nvidia control panel.

Suggested Topics