ubisoft discussions

Quick Suggestions

  • CatherineCat93
    29 posts

    @sinnombre675 That really sucks, sorry to hear this is happening to you aswell. I think it might really be just an overly aggressive texture streaming buffer causing all these issues, just like some people previously mentioned. On a 3080 with 8GB for example, the game allocates 2GB as "safety buffer", leaving 6GB for OS, background apps and the game.

    Most people with a newer RTX gpu would obviously like to play at high resolutions and settings turned up to ultra, even with directx raytracing enabled perhaps.. but Far Cry 6 uses 5-6GB of Vram alone without the HD textures pack, at 4K resolution, without DXR at ultra settings.. which leaves no headroom for the higher res (non dlc) textures because Far Cry 6 keeps those 2GB locked away.. which could easily be used to avoid that problem i think. Now enable the HD texture pack (which increases Vram usage up to 9-12GB actual usage at native 4k) ontop of this and the game will suffer from low res textures everywhere because it now uses the much slower Ram to stream those.. just my thoughts.

    This was never an issue in other Far Cry games with HD texture packs..atleast not that i remember.

  • Kalitheman
    12 posts

    I can confirm the blurry textures are caused by VRAM attribution limitations in the game.
    Got a RTX 3070 8g vram. If I keep whatever video setup under 4,20g, regardless of what options are on or off, the high res textures are always on.
    If I add any option that raises VRAM over 4,20g, the texture problem comes in after a while or when changing environment, loading map,etc.
    The best quality options I have found is all Ultra, HD Textures OFF, Fidelity FX Super resolution ON at Ultra Quality, both DXR options OFF...
    Good luck !

  • UhOhIPooped
    20 posts

    Still no Fix over a week later.... Oh but they did do a hotfix patch for xbox for language issues....... this is a joke.

  • Bluefriend05
    2 posts

    Same problem for me, blurry textures in the distance and at objects at the sides of the screen (you can see it very well in the first island looking at the palm trees). I thought it was depht o field (FOV) enabled, but you can't disable it in the settings. I've a 2080ti, the problem occurs with both HD textures enabled and disabled. Unplayable for the moment 😠 Another weekend with a game bought and left there to gather dust.

  • kevinsyslo2
    51 posts

    @catherinecat93 I don't think it's locking 2GB away for a buffer. With a hardware monitoring program you can see window 10 is using 2GB just on the desktop with nothing else running.
    Far cry 6 is just reporting what it needs to run which is about 6.2GB for me. Add 2GB to that and it's at 8.2GB which is pretty close to what my hardware monitoring program shows it using for me at my settings. And if you open a web page or other windows it adds to this 2GB which gives the game even less to use.

  • CatherineCat93
    29 posts

    @kevinsyslo2 Wellp, whatever exact issue it is, it's not acceptable and it needs to be addressed, alongside other issues such as the autosaves locking people out of progress and requiring a new save. Just add manual saves and let people choose between auto and manual saving. But that's not for this topic.

  • gRzeHoO87
    10 posts

    @dameme_ranger your case is simple. Your game settings are WAAAAAAAAY above your GFXs 4 gig of VRAM. Medium is probably the highest settings you could try. People here have issues with 30xx 8GB+.

  • tcul1972
    8 posts

    @darrel_rf Correct no HD pack with a GTX 1080. I know the limitations of my system. Also the OP gives no indication if he is or isn't using the HD pack nor does he give any system specs. He just wants to rant and demand a fix for something that is probably lacking on his end.



  • CrailJast
    17 posts

    @grzehoo87
    This is not the issue. In dameme's defence, even if he had set the settings at a much lower mark, the texture issue would not go away. This bug does NOT only affect 8+gb cards. Its not a 30xx or above issue, its a issue along all possible lines of GPU's.

    Regardless of the size of your VRAM, the game systematically under-utilizes the available VRAM and instead forces placeholder graphics on you, even if you manage to get enough free VRAM to be able to load the textures. Also, these textures don't require that absurd amount of VRAM to render properly, as previous games in the series and other games have show. It shoudnt be this hard to render atleast a decently sharp image even if it is not 4K or high res.

    Currently the game is being outclassed graphically on PC by games that are 10 years older then it.

  • Akira1364
    159 posts

    @grzehoo87 If their actual performance in terms of framerate is fine at those settings though, why should they be forced to play at settings that look quite noticeably worse?

  • CrailJast
    17 posts

    @akira1364

    Exactly, performance wise (in say FPS and potential stuttering) the game runs fine on medium end hardware. Graphics shoudnt be impacted this much.

  • AMdizzy
    1 posts

    @darrel_rf didnt pay for the game. just payed for ubisfot +

    I try it. good game huge ammount of bugs. press E to pick up stuff buggy, blur texture, terrain is a joke. medium or ultra is the same., quality control is fired or never existed .

  • Bladerunner4077
    193 posts

    In its current state, even without the pack, the game needs at least 10GB of VRAM at 1080p and 1440p because the game will keep a buffer of 2GB and the default textures take up 6GB of VRAM. On all of you guys' NVIDIA graphic cards, they have only 8 gigs of RAM so after the buffer of 2GB, the game doesnt have the headroom to load all the textures so its showing low res assets.

    I am gonna go out on a limb here and say that nothing below the 3080 and 2080 Ti can run the game with the default textures at 1440p and 1080p. With the HD pack, only the 3090 can run it.

    You will not see similar complaints from the AMD users with RDNA 2 in this thread because all of them have RAM greater than 10GB

  • kevinsyslo2
    51 posts

    I just found three graphics settings in the gamer profile (found in This Pc > Documents > My Games > Far Cry 6) that do not get changed by the game settings, unless you use the graphics quality presets.
    One of them being PostFxQuality which I found turning it to low really improves performance and will allow you to run higher settings before you start to get blurry textures. If this could be completely turned off I think it might solve the blurry texture issue, but I don't know if you can turn it off.
    The other two settings are volumetric clouds (not fog) and ambient quality. But they don't seem to have near as big of an effect as PostFxQuality.
    To change these first go in game and use graphics preset and set eveything to low quality preset. Then raise each option back to what you think your pc can handle making sure you don't set them all to the same value (have to leave at least one at a different setting) or it will go back to a preset and raise PostFxQuality back up. After you have done this make sure it says custom beside graphics quality. This will allow you to go to the gamer profile (found in This Pc > Documents > My Games > Far Cry 6) and edit it with notepad++. If it's not on custom any changes you make in here will get reset the next time you start the game. You will find the graphics settings in here about halfway down in the line that says <quality EnvironmentQuality="ultrahigh" PostFxQuality="low" TextureQuality="ultrahigh" VolumetricFogQuality="high" VolumetricCloudsQuality="low" WaterQuality="ultrahigh" VegetationQuality="low" TerrainQuality="ultrahigh" GeometryQuality="ultrahigh" AmbientQuality="high" ShadowQuality="ultrahigh" ShadowCinematicQuality="cinematic_pc" ResolutionQuality="" VSyncQuality="" VSyncCinematicQuality="" id="custom" />.

    You can change any of these to low, medium, high, or ultrahigh. Just make sure to leave PostFxQuality on low.

    Also turn on fedelityfx super resolution. Even at ultra quality it will let you set your graphics a little higher before you get blurry textures. And there is not much difference in image quality.

  • Akira1364
    159 posts

    @darkrtx2080 My GTX 1660 Ti (6GB) mostly does not have the issue at all (though it has appeared on some things just a couple of times) at 1080P / Ultra without the HD texture pack enabled.

  • kevinsyslo2
    51 posts

    @akira1364 I think the frame rate is staying high because of the textures dropping out. If there not there they don't have to be rendered.

  • Akira1364
    159 posts

    @kevinsyslo2 High resolution textures don't normally impact framerate very much at all, anyways. They aren't "harder" to actually render once in memory than lower resolution ones.

  • kevinsyslo2
    51 posts

    @akira1364 There dropping out though and the gpu is rendering really low res textures. That's why the fps stays high.

  • sattium85
    107 posts

    it looks like the texture of this hat is like from 2001 even on consoles


  • Akira1364
    159 posts

    @kevinsyslo2 What I'm saying is that going from low-res to high-res textures does not actually impact framerate significantly at all in most cases even when working properly.

Suggested Topics