Welcome to discussions

Quick Suggestions

  • 26 Likes/881 Replies/43255 Views
    justtryingit123
    10 posts

    @zurtx01 Yeah absolutely! The game starts fine and runs very well, however the hard reset is bad for the PC.

  • assassinadmril
    15 posts

    I don't get a error message and farcry 6 crashes to desktop happen randomly. Tried turning down settings/ resolution frame rate is capped at 60 fps mostly playing at 4k I tried downscaling resolution as well. I tried running it as administrator and launching through desktop instead of connect. I tried disabling cloud save syncing and Ubisoft connect overlay.

    Disabling the latter allowed me to play for almost 30 minutes before crashing to Ubisoft connect client again. I tried disabling every other application I had running on windows also to no prevail. Anyone else crashing like this? Any solution?
    This use to happen to assassin's Creed Valhalla until I started launching from desktop. Temps are also fine. I also don't crash in any other game cyberpunk ect. Using windows 10 all drivers and graphic card drivers up to date.

    Specs: rtx 3080 xc3 ultra, 5800x processor 16gb 4000mhz cl16 ram, 1tb Samsung 970 Evo

  • K4smo
    3 posts

    My game was crashing randomly too...


    But I have a solution which working for me so far:

    Go to your game folder:

    ..:\Far Cry 6\bin

    and start the exe file using admin permissions (Run as Administrator).

  • FreelancePear87
    9 posts

    well [censored], i guess i messed up my save now. 20 hours in and my game freezes upon loading. there's no way in hell i'm going to start a new playthrough now that i got so far in the game.

  • Dragonheart1167
    2 posts

    Ich Frage mich wie lange das hier noch weiter geht, das das Spiel nicht startet. Ich hoffe es wird bald, in Ordnung gebracht. Grüsse Anton ✊ 😁

  • ALPAKY
    1 posts

    @assassinadmril I'm having the same issues. Game keeps crashing randomly to desktop. Tried all the things you mentioned and I even uninstalled the game, cleared all the files with CCleaner and installed it on a different driver and no luck...
    PC specs: i7 8700k, GTX 1080ti, 16 GB ram 3000MHZ, 1tb Samsung 870 QVO

  • RoterNovember13
    1 posts

    Hab das gleiche Problem - gestern lief noch alles einwandfrei

  • Kormac67
    950 posts

    Applications can't crash the OS.
    Looks more like a buggy driver or a bad PSU to me. Maybe the game is spiking CPU or GPU load and the PSU can't handle the sudden rise in required power.

  • Agent_Stormy
    17 posts

    Yep am still getting crashes all the time and then takes forever to reload the game since i get

    Failed to synchronize achievements.

    So many crashes today its unreal :(... Wouldn't be so bad if there was a manual save button, But its all autosave and all Ubisoft keep saying is "AM SORRY" your having issues with the game in every post -_-

  • MachtAG
    1 posts

    I got the same issue, every 10 minutes a Screen with "unable to Synch", thats very annoying

  • ShadeJH33
    1 posts

    Same, I can't play because of this "unable to synch".

  • Tipp3xx
    2 posts

    I have the same issue with I7 9700k 16Gb Ram RTX 3070 TI but my game works on Windows 11.
    but I see that you have the same problem in windows 10.

  • assassinadmril
    15 posts

    @alpaky I also think there is a Ubisoft bug as the only problems I have are with the Ubisoft connect games. Now assassin's Creed Valhalla doing the same thing with me. I can play cyberpunk 2077 maxed settings for 12 hours but the moment I try any Ubisoft connect games I get crashes within 30 minutes. It would help if Ubisoft gave a reason why my games are crashing and getting no info and it it for both games now. I subscribed a few days ago and looks like I'll be contacting support really soon to see what is causing my problems.

    I meet recommended specs that is for sure I tried verifying files for both of them this is sad... I was also able to play assassin's Creed Valhalla months ago when I beat it without the same problems.
    Now farcry 6 needs to be patched and it don't help that I solely purchased a sub to beat farcry 6...

  • CaosMasterGames
    5 posts

    Hello again! From what I read on twitter, it seems that it could directly be a problem with ubisoft connect, its servers and its communication, nothing to do with our pcs... There are many people who today are also having problems to even start ubisoft connect...

  • Reedee11
    1 posts

    I have this issue too. Nvidia 3070. Waiting for the patch. 😞

  • Doom...Slayer
    7 posts

    Ubisoft, Where do we begin?
    I guess the only thing I can say possitive at this point is, that at least FC6 is just about playable on Consoles, this is a worse launch than Cyberpunk 2077 for PC and I never thougth I would see a more broken game at launch.
    The game will crash for a lot of users when trying to launch the game, which makes the game obviously unplayable and broken, for myself I will play for a couple of minutes, game freeze, then moves into black screen and system reboots.
    I actually managed to play the game long enough to do the last mission of the first island, and this is where I gave up, see it black screened and crashed during the cut scene. I reload the game, and repeat black screen of death and reboot, and now it crashes so quickly I cant even skip the cut scene to see if the game will let me continue. Its a mess, a complete mess of a launch for pc players, ive tried it on windows 10, with a ryzen 9 3900X on a nvidia RTX 2060 Super, Itried it on windows 11 with a Ryzen 9 3900X RX 6700 XT all system updates all gpu drivers installed.

    Ubisoft, if players cant launch the game, or it conitues to constantly crash, it is not their systems fault, it means........ "YOUR GAME IS FUNDAMENTALLY BROKEN"!


  • koolcoly4
    1 posts

    I think a lot of us with high core counts are crashing and getting BSOD

  • Doom...Slayer
    7 posts

    @rodgeur82 unfortunately you definitely will not be able run this game with that gpu.

  • DomGalban1
    1 posts

    Game crashing every 15 minutes and sometimes cant run on. Nvidia drivers are new and WIN10 upadated. Playing with uplay+. Have someone this problem too? R5 3600x, rtx 2060,16GB RAM 3400Mhz

  • cklim77
    2 posts

    hi guys, I'm not sure if this solution works for you, but it solve my case, which is startup crash when loading the game after the warm-up PSO cache. I just disable one service call "Nahamic Service" in task manager (Background processes).

    How to disable:

    1. Press Windows + R to open Run dialog, type "services.msc" and press Enter.
    2. Look for "Nahimic service".
    3. Right-click it and select Properties.
    4. In the Nahimic Service Properties window, select Disabled in Startup type.


    I did try this method and able to launch the game successfully.

Suggested Topics