ubisoft discussions

Quick Suggestions

  • 26 Likes/881 Replies/49646 Views
    cim.oka
    9 posts

    @yarok63 The BSOD is a bug in the game, the solutions provided on this thread is mostly for luncher and crash to desktop. The bsod remains and people who think that it is fixed after changing few setting is just not correct at all. The BSOD does not happen always which leads to think that the user is fixed it. Sometimes it happens after 4 hours play, sometimes 30 minutes, it changes. A game fix/update required by the developers. I have created a thread for the developers with the memory dump, they can fix it if they read it of course. Check this thread https://discussions.ubisoft.com/topic/112537/far-cry-6-bsod-pc-restarts-memory-dump-for-developers?lang=en-US

  • Purebeaux
    3 posts

    @jezagooner AMENDING MY PREVIOUS REPLY

    This fix allows me to play for approximately 2-2.5 hours. I just experienced another crash to desktop after roughly 2.5 hours of playtime.

    Back to the drawing board.

  • DCDUHDUDE
    1 posts

    @samsedk i have a Samsung 980 Pro and mine is BSOD. Don't think it's the drive.

  • JezaGooner
    3 posts


    My situation now is I am having an Issue with Far Cry 6, the splash screen shows, then launches the game, the loading icon stops in the bottom right and the game crashes back to desktop.

    Windows is up to date and I have installed the game on a different SDD and tried with HD pack installed and not installed and also allowed the exe through the windows defender wall, set the game to run as admin and reset nvidia settings to default and no resolution. 

    (Cant even submit a support ticket as there isnt an submit form option now). Been trying to play for 2/3 days havent even got past this loading screen 😞

  • kampi71
    9 posts

    Sorry to say, but at this point I decided to stop playing the game because of this constant crashing and well, it's hard crashing for me lately. System stops with a total freeze. (I9 10900K - Asus ROG RTX 3090 OC - 32GB RAM - Win10Pro - 1300W Seasonic) I tried everything that was suggested but nothing seems to work and stop this extremely annoying behavior. It's unbearable, because sometimes the game works for quite some time and then bammm. No other game that I'm currently playing is giving me crashes. You know, I'm playing for over 35 years and there are always games with technical issues and yes also some crashing issues, but I'm very sorry to say that Far Cry 6 takes my personal "crown" in terms of crashing. Ubi SERIOUSLY has to come up with a solution ASAP. So far my bucks seems wasted and I hope it'll change soon, because so far the game was fun.

  • ITbites
    8 posts

    @kampi71 Same here, played these game since Half Life (1998) and these sort of mysterious crashes occurs but this time we're facing something really annoying. I have wasted hours to modify ALL "fixes" and nothing works - sometimes I manage to play 45 min, another time 5 min...

    What is especially fkd up : AUTOSAVES disappears after these freezes/crashes! - like 90% completed out of some mission, crash and back to beginning. ARGH!

  • Askirinos
    11 posts

    @r1-fast Great ! =D

  • Moosemingemaul
    1 posts

    Yep, i'm an old school gamer, played all the far cry games, as well as a multitude of others and to this day. What is going on in this day and age. I understand we all are under pressure and we have to make deadlines but i wouldn't sell a half cooked loaf of bread or a car with no engine.. seriously guys, i know your probably working on this issue and yeah we appreciate it, but never ever had an issue like this even back in the old wing commander days, you could always get it running. I have tried everything to get this game to start with no luck, what a shame. I watch my son play it on PS4 with no issues as he laughs at me... The old PC gamers still exist and we want to play.. put in some overtime guys and get it sorted soon please !

  • juhanieminen
    8 posts

    I got my game work.I chance Nvidia drivers 472,12 to 461,40

  • fragnetic_
    6 posts

    @lima-delta62 Yes newest 472.12

  • justtryingit123
    10 posts

    @dogfoodface Yeah it`s not going to go away anytime soon , still no updates from the devs.

  • MiniOverKill
    1 posts

    I have the same issue, everything up to date.
    Unfortunately this is a classic Ubisoft issue, releasing buggy games and then not fixing them for months.
    I´m glad I got my copy at no cost.

  • FronzillaAU
    1 posts

    @sl4d3 i had some degenerate support worker tell me theres no bugs caushing this and that its on my end linked him threads where is happening to heaps of people and just dug his heels in kinda disgusting that you cant get refunds for these kinds of technical issues

  • RokkStone
    3 posts

    Not sure if this is the same issue reported here but I was playing cross progression between GFN, PC and Google Stadia without any problems but just recently I found that when loading in a cloud save from Stadia to GFN, the game would continue to launch and then bomb out. I'm now finding this with the PC version too (no problems with Stadia). So, I upload my save to the Ubisoft Connect servers, launch the game on PC/GFN, wait for the screen where you choose whether to continue or to play from a cloud save, choose the latest uploaded save, the game shows the launch graphic of Anton and Diego in the car - seconds later it disappears and returns to desktop.

  • Griffinous
    2 posts

    I can categorically say that I can only reproduce this crashing issue when playing Farcry 6.

    So Farcry 6, when it behaves, gets me 70fps at 4K on ultra settings and HD textures. However, this will only last so long as something will suddenly trigger one of two things to happen. Either the PC will reboot itself, or the FPS will suddenly drop to 8-12fps, effectively making the game a slide show. Even when only outputting 12fps, my GPU utilisation is still running >90%

    I appear to sometimes be able to reproduce this issue by entering the game menu, or alt-tabbing from the game. It seems that any action that changes the PC from being under load to not being under load (changing to the in-game menu or Windows desktop) causes the PC to either restart or causes the FPS to drop to unplayable levels.

    I have been monitoring my hardware whilst playing games, including utilisation, temperatures, and power draw from the PSU. When playing any game on Ultra settings, including Farcry 6, total usage of my PSU gets to around 550w and temperatures of both the CPU and GPU are well within the threshold.

    The difference is, when playing any other games on the highest possible settings, such as Shadow of the Tomb Raider or Cyberpunk, or even just a stress-test application like MSI Kombustor, my PC behaves normally. No crashes, just simple gaming like I have always been able to do. I can alt+tab to my heart's content without problems.

    As Farcry 6 is just a software application, it can't cause this crash by itself. But it is my guess that its use of the system drivers is ultimately causing system instability, resulting in these crashes.

    My Specs -

    AMD Ryzen 9 5900X
    MSI x570 MEG Ace
    32gb DDR4
    MSI RTX 3080 Ti Suprim
    Corsair RM850i PSU

  • eViLoZzy
    9 posts

    @but00040004 I have had enough of this pathetic help desk and requested a refund. I was refused immediately and now waiting for that same help desk to respond. I have researched this company and they are being watched closely by Australia's ACCC, the same consumer rights association that have successfully sued many companies for refusing refunds in Australia eg. Valve(Steam $3.5mil) and Sony Entertainment(Games) and ZeniMax Media Inc(Fallout 76). If the next email from them is "we have stolen your money and we don't care" then I will open a complaint with the ACCC and already have that form bookmarked.

    This help desk just informed me that the game won't launch on my 32bit OS LOL they said it's in my msconfig!(I can't even find the line stating this 😕 ) I haven't used a 32bit OS for decades... Currently using Win10 pro 64bit v21H1.

    They also said that there is an issue with a program called 'Armory Crate' and my jaw dropped! This is 'non-negotiable' ASUS motherboard software(Z490) for both ROG and Tuff Gaming.

    And finally I use a higher DPI for my old eyes, so turned it all off and had to put my glasses on to even see the screen lol, launched the game and ta-da.... Crash!

    I have changed NOTHING in my computer, or software to warrant this pathetic response from them, and all other hi-end games work flawlessly on my A$6000 rig!

    So I GIVE UP Ubisoft, not one more cent from this 15 year customer, never again will I do business with you.

  • Sl4d3
    16 posts

    @fronzillaau Same, disgusting support from ubisoft as usual. Never had a BSoD since i got this rig (december 2020), but the issue is on my side, got a 1k game steam library, been playing almost every single day, multiple games, no BSoD. Playing FC6 for 1 hour, having BSoD, but the issue is on my side...
    Nice work ubisoft, they should quit making their s-h_i-tty Dunia 3D engine. It has to be FC6 or Ubisoft connect


  • A Former User
    0 posts

    Well... The game is starting to crash for me again.

    I've disabled the Ubisoft overlay and cloud synchronization to no avail.

    It just boots me off and a yellow error message in the Ubi client appears saying: "While you continue playing, we'll restore the connection to a service..."

    My internet connection is stable, so it must be on your end.

  • ITbites
    8 posts

    @juhanieminen

    Juha, Thanks, So far so good - I played like an hour with 461,40 without crash!

    Please other, try this to be sure?

  • KATUSeu
    1 posts

    I have same problem. Trying to play FC6 and got instant reset after few seconds of gameplay.
    My PC spec is Ryzen 9 5900X + 2x8GB RAM 3800MHz CL14 + RTX 3080 Ti and PSU is Corsair HX1200. Game is installed on Samsung 980 Pro 1TB.

    Its the only one game with such problems. Also I can push my system in some synthethic benchmarks and get full load of CPU&GPU and it works fine. I have no idea what is wrong with Far Cry 6.

Suggested Topics