ubisoft discussions

Quick Suggestions

  • 26 Likes/881 Replies/51330 Views
    Zurtx01
    10 posts

    @flybyme I did too ... BSOD after 10ish minutes.

  • DarKSeeD.
    1 posts

    @ftkanizawa Thanks man this fixed it for me had the game running for hours with this (running the executable in the game's bin_plus folder in administrative mode)

  • cim.oka
    9 posts

    @ftkanizawa I did try your method, I do run the game from the bin_plus with admin mode and it still crashes to desktop, sometimes after 30 mins and sometimes after 3 hours of play.

    To all people who get BSOD, I was able to fix the BSOD, actually I was able to change it to a crash to desktop instead of complete bsod and pc restart.

    Here is what I did:
    The game was installed in c drive under the c:program files (x86). I uninstalled the ubi connect first from the windows uninstall programs screen, then I uninstalled the game from the Epic Games Launcher, click 3 dots near the game and choose uninstall. Then uninstalled the Epic Games Launcher itself from the windows programs screen.

    Then I installed Epic Games Launcher to the second mk2 disk I have, which is disk d: and installed the game with Epic Games Launcher to d: drive under the Epic Games Launcher folder.

    So short answer is I just uninstalled everything including ubiconnect and I installed everything including game to the second disk d:. This is fixed BSOD for me, it is now crashing to desktop instead of BSOD at least and tested it for 3 days, I confirm my bsods are turned to crash to desktop this way.

  • x1TinTin1x
    2 posts

    Posting this here because it might help someone hopefully to get their game running.

    I've have two PC's:

    PC1:
    Ryzen 3600
    16GB RAM
    MSI B450M Mortar Max
    Nvidia RTX 3060
    Win 10 x64

    PC2:
    Ryzen 5900X
    32GB RAM
    MSI MAG B550M Mortar
    Nvidia GTX 1060
    Win 10 x64

    On first downloading Far Cry 6 onto both PC's I noticed that it was only running on one machine.
    On the machine it wasn't running on it was opening to splash screen and immediately exiting.
    It was not getting as far as the "Warm PSO Cache" message. Splash screen popped up and within 2 seconds it was gone.

    After trying absolutely every fix on the broken PC I decided why not change the install drive from M2 SSD to SATA SSD.
    This immediately fixed the issue. Splash screen went straight to "Warm PSO cache" and then the game has run fine without any issue for me for 6 hours so far.

    To confirm this wasn't an isolated issue / machine issue I have tested this on the previously working PC (which was installed to SATA SSD originally).
    To do this I uninstalled the game and re-installed it on the different M2 drive in this machine.
    Immediately this machine suffers from the same problem. Splash screen pops up and immediately game exits.

    So my advice to any users with the same problem would be to change the install drive from M2 to SATA SSD / HDD to see if this fixes your issue.
    Admittedly not a great fix if you only have M2 / one drive.

    For additional reference in one of the rigs the M2 drive is the OS Drive in the other its a non-OS Drive so that didn't seem to have any impact for me the game simply seems to hate M2 drives. Which may be an MSI only issue or an AMD Ryzen only issue. Either way the issue is exclusive for me to Far Cry 6 and has not occurred in any other games I've played recently.

  • x1TinTin1x
    2 posts

    @tawapah11 @smesd @shoosh @Dunarii I fixed this issue for myself by ensuring the game wasn't installed on an M2 drive. When installed on a SATA SSD it worked for me.
    I hadn't found this suggestion anywhere else so worth trying.

    I confirmed both my Ryzen rigs won't load the game when installed on M2 but will from SATA SSD.
    Not tried SATA HDD so can't comment on that I'm afraid.


  • kampi71
    9 posts

    @fragnetic_ Hi there. Well, I'm not on Windows 11, it's still W10pro for me. Anyway, until now (fingers crossed) the game has not crashed on me again. Just played for another hour yesterday. I mean there are many factors involved, but atm and at least for me, it could be the faulty game profile that was introduced with 472.12. The previous driver without that specific profile did not crash again so far. Btw, I'm playing without all the dxr and fidelity stuff, which made no difference in terms of crashing with the 472.12, because with or without it the game crashed. Anyway, the devs have to come up with a patch and that maybe includes NVIDIA in terms of a new game profile. Will report back if the crashing returns. In general it's a pretty bad thing that you play a game and always in the back of your mind you're asking yourself "Will it crash again?".

  • But00040004
    Original poster 16 posts

    things i have tried. cmos reset. bios update. driver roll back. windows reset windows full wipe (delete partitions) buying a 3080 (yes really) yep still crashes. this is dumb. i wont support the company further. goodbye ubi

  • flybyme
    213 posts

    @but00040004 Your kind of comment makes me laugh. Do you think Ubi care?

  • But00040004
    Original poster 16 posts

    @flybyme ur on the forum. so you do too.

  • fragnetic_
    6 posts

    @itbites1976
    can you post a link for me?
    I think Windows 11 Support starts on 472.xx

  • Tyemael
    3 posts

    Alright, it worked so far with some minimal crashes. But after I updated the AMD Graphics driver to the 21.10.2 the game is not starting.

    It has the perpetual spinning wheel showing. No progress at all.

    I7-8700K
    AMD 6800XT
    Windows 11

    Before that update I played around 37 hours with said minor issues, but after removing the HD textures it worked fine.(THESE ARE BROKEN - lol 11GB)

    Going to get back to the previous drivers and look if it starts.

    [EDIT] Reverted back to 21.8.2. Starts and works, so @ubisoft your game doesn't like the new AMD drivers. maybe you want to check with AMD???

    [EDIT2] I like how Ubisoft is trolling -.- Now in Ubisoft Connect, I get the message that my drivers are outdated Oo.... Are you kidding me?


  • LoLorideur8
    5 posts

    I am in the menu of far cry 6 I launch a new game and in the loading it crashes and it takes me out of the game

  • A Former User
    0 posts

    I can confirm that by turning off my antivirus program (bitdefender) I no longer experience these DC's.

    For some reason, my antivirus program does not like whatever it is Far Cry 6 is doing.

    It's worth a try! :]

  • djxarko1978
    1 posts

    @lollylion This happened to me also, could not start my pc again. So the only option i had was to leave my pc to service. Thx alot @ubisoft!!!
    My specs:
    Asus rog maximus xi hero (wi-fi) z390 gaming
    I9900K
    32 GB ram
    Asus Rtx 3080

  • tawapah11
    7 posts

    @x1tintin1x Well found! I only have an M.2 SSD, so guess I have to wait.

    So there seems to be at least two reasons that prevent the game from starting:

    • Using an M.2 interface rather than SATA for an SSD
    • Using the latest AMD/NVIDIA drivers


    @Ubi-Caliburn @Ubi-Borealis @ubi-mark @UBI-VIRAL @Ubi-Alien
    @Ubi-Cuddles @Ubi-Deta @Ubi-Akatsirin @Ubi-AJ @Ubi-Daffodil @Ubi-Doh
    Have Ubisoft been testing this game with an M.2 SSD or the newest graphics drivers?

    Also it seems the game can be damaging as few are reporting their PC cannot boot again after crashing!
    @lollylion and @djxarko1978

  • ComicThrone2737
    1 posts

    A week into playing and now I can't continue my game anymore. It will open the menu and let me hit the Continue Game button and go to a loading screen, but it crashes after a few seconds. I have uninstalled and reinstalled the game, I have sent in crash reports.

  • TigerAlen410
    7 posts

    Shame on ubisoft, so many people keep getting crashes its insane, how can you not make a game that won't crash for so many users, I bought the game for what? To not be able to play?

  • Drifted_Jukes
    2 posts

    @kampi71 how do you get rid of specific profile?

  • madgooner2810
    2 posts

    My game crashes completely to desktop (with crash report send button and sync) when I complete some activity and open the map within a certain window. For example I collect a crate near a mountain top near one of the first missions after the prologue and I open the map as soon as the collect animation fades out and my game freezes then crashes.

    I have tried a full reinstall, updated my drivers, used DDU to wipe and reinstall drivers, disabled XMP and am basically short of reinstalling windows

    5600x not OC
    3080 not OC
    32 GB RAM XMP and non XMP
    Game is on a M.2 NVME SSD
    Running Windows 11 latest public release
    Also running the 11GB HD textures (lol)

    I do not think this is a driver or hardware issue as this has happened on 496.13 and the version before (game ready driver). Could be windows 11 related but seems unlikely. Game is unplayable in current state.

    Ubisoft needs to patch their broken [censored] PC port....

  • Stingrayroy
    1 posts

    Downloaded for PC. Shows the splash screen then crashes. Everything is up to date. My brother downloaded the same game from Epic also and is having no issues. Any ideas?

Suggested Topics