ubisoft discussions

Quick Suggestions

  • 26 Likes/881 Replies/50676 Views
    flybyme
    212 posts

    @er36po Do you ever visit any other game forums and see what people who have a new game that won't work they same a similar story yawn to yours but the developers are still going.

  • er36po
    17 posts

    @flybyme Look man, damned far cry 6 was very busy when it first came out... It didn't work, I thought my latest hardware (Rampage IV Black Edition/ i7 4930K/ 2x GTX Titan) didn't support it. Then a moderator in this help group said they could help me...
    I contacted Facebook, the incompetent moderator on Facebook directed me here again after taking my time for 1 week. I sent dxdag and system imfo files here, no response yet. Help doesn't seem to be coming.

    Only 40 pages of the same complaint has been created in this forum, are you still asking if there are people who have problems like me?
    I have more than 100 up-to-date, old games on my system and I can play them all at about ultra settings, but for some reason, my system cannot even open far cry 6 (it crashes before it even starts) let alone playing.
    I tried many ways including formatting the PC but no, this cursed game crashes before it starts.

  • er36po
    17 posts

    @flybyme It is also worth mentioning that... Ubisoft is an irresponsible and problematic company: The best example of this is far cry 1...
    You can try it yourself; Far Cry 1 from Steam works fine, but Far Cry 1 you purchased from Ubisoft does not work properly. (They have serious problems, especially in coatings)
    That's why I buy my games on Steam as much as possible...
    Think about it, I buy the games released by Ubisoft from Steam, and naturally I endure the installation and opening of these 2 applications in order to open a game.

  • TigerAlen410
    7 posts

    @er36po

    I understand your frustration, but its exactly because of people like YOU that ubisoft doesn't give a c***, they sell TONS and TONS of their games to people, even people like you buy them over and over again even if they are bugged and don't work properly.
    Do you think if people like you boycot their games they would not notice and maybe try to improve things? But you don't, all you do is complain on a forum but you still bought the game, so why should ubisoft care, they got their money, who cares if it doesn't work for you lol... they have a long track record of bugged releases and yet people still keep preordering games and buying games...
    Think about it from a logical perspective, why would they care?

  • er36po
    17 posts

    @tigeralen410 You are right, it is impossible not to agree with you. However, I've never had such an outrageous, unsolvable problem so far. That's why I kept buying Ubisoft games. However, after that, UPISOFT is finished for me. So from now on, I will pirate the Ubisift games that I can love. After all, Ubisoft doesn't pay attention to our complaints, and no one will pay attention to ubisoft's pirate complaints from now on.

  • tchNL
    1 posts

    Also unable to start the game since the update as it crashes on launch, after displaying the yellow loading logo in the right bottom for ~10sec.
    Have tried to verify the gamefiles several times, removed the Documents folder for FarCry6 and restored Nvidia settings to default, nothing worked.

  • SidheVicious
    10 posts

    It has now been well over a month.

    The game still crashes on the splash screen, and remains unplayable.

  • flybyme
    212 posts

    @sidhevicious Open up Windows Event Viewer and see what that says as it may give you a clue to what is happening. On another forum for another game, a person was having the same problem so they updated all their drivers that needed updating even the motherboard chipset drivers and after that, the game worked. Go to your motherboard manufacturers page and see if you have the latest chipset drivers.

  • SidheVicious
    10 posts

    @flybyme

    No logs regarding the game in the event viewer, and motherboard is already fully up-to-date.

  • Eleson_Tan84
    3 posts

    @sidhevicious If your is like it load the game but doesn't load to main menu and ctd(Crash to desktop) then you could try my solution which is uninstalling the game, go delete the game folder manually and install again or use windows 10 recovery and reset your pc, choose to keep your files option, download and install ubisoft connect again and follow the previous step I just mentioned.
    That's how I fixed mine.

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hello there,

    I'm sorry to hear that you are experiencing crashes / freezing whilst playing Far Cry 6. Thank you for continuing to share your reports with us within this thread. If you haven't already, we would recommend that you try these basic PC troubleshooting steps. These steps help to tackle a number of common causes behind technical issues, such as crashes. In particular, I would recommend that you verify your game files, as this has helped to resolve a black-screen crash issue for several players.

    Some players have also been able to resolve their crashing issues by trying the following:


    We are aware of a couple of similar issues that could be causing your crashes to occur, so please take the time to check out the following investigations:

    • We are also aware of an issue wherein players were experiencing a crash, alongside the pop-up message "Oh no, it crashed!" A hot fix for this issue has been deployed. If you have encountered this issue, please can you fully close down Ubisoft Connect before restarting the client. This should allow you to launch your game successfully without this pop-up occuring.



    • If you are encountering a blue screen when crashing, or have seen a BSOD error, we have created a separate Megathread for this issue. We have had some reports that rolling back to a previous driver version can help alleviate this issue. If you encountering a BSOD specifically, I'd recommend checking out the linked Megathread.


    • We have also received reports of players who's game loads endlessly or crashes when clicking the Ubisoft Connect button in the main menu when Overlay is disabled. The development team has been made aware of this issue and they are currently investigating further. Once we have any new updates to share, these will be posted within the News & Announcements forum once they are available.


    If you are still experiencing crashes / freezes after trying these troubleshooting steps, please don't hesitate to update us within this thread so we can assist in opening a support ticket for you. Opening a support ticket will allow us to collect your unique system files for further troubleshooting, and will help us to investigate the issue further.

    I've opened up support tickets for the following individuals: @DiabIoBlooD, @Rot_Fuxx, @RanceJustice, @er36po, @tchNL

    You can find your support ticket by logging into your account via the Ubisoft Support website and by selecting "See All Cases" on your homepage. I have also sent you an email with additional steps that will help us to investigate your issue further.

    @se13av - Thanks for sharing an update with us and for letting us know that verifying your game files resolved the issue for you 😄

    @dbag_johnson - I'm sorry to hear that you aren't happy with the support you have received so far. I've taken a look at your support ticket and I can see that the team has asked you to try disabling some background applications that could be conflicting with the game files. If you've tried this and the crashes still persist, I'd recommend updating your support ticket so our team can investigate further.

    @mikerowland92, @And345dsa, @Nico_Pico11, @ScreamingWasp, @fourtyxxxseven, @jennymauzi, @theadman2184, @morbility & @SidheVicious - Can you let us know if you have tried all of the suggested troubleshooting steps, to see if this helps to resolve the crash issues you're experiencing? If you have already tried these steps, please don't hesitate to update us within this thread so we can assist in opening a support ticket for you.

    @bob3027 - Are you still experiencing crashes after re-downloading Far Cry 6?

    @Arabyslasher - Thanks for sharing an update with us. Just to confirm, after you verified your game files, you were able to launch Far Cry 6 successfully? Or are you still experiencing crashes after verifying your game files?

    @eViLoZzy - Thanks for sharing that updating your Windows 10 with the QoL update (21H1) resolved the crashes you were experiencing. I'm glad to hear that the issue has been resolved for you 😄

    @GrabbenD - Thank you for letting us know that you've been able to resolve your crash-on-launch issue! I'm glad to hear that your issue has been resolved 😄 I'll share your experience below so others can check if removing the Speech API from their Windows installation may be causing their crashes:

    I found the reason why my Farcry 6 was crashing on start!
    The game wont work if you remove Speech API from your Windows installation


    @zzzzYeti2012 - Thank you for sharing your experience and feedback with us. I'm glad to hear that you've been able to find troubleshooting within this thread that has helped you to resolve the crashing issues you have encountered. This thread has been shared within the "Reported Issue Megathread List," which you can find pinned at the top of the Player Support forums. We recommend that all players check out this thread prior to reporting an issue within the forums to see if there is already an ongoing investigation.

    @tikumo99 - Thank you for providing updates within this thread. Can you let us know if your crashes were resolved after verifying your game files, or if this issue still persists?

    @Eleson_Tan84 - Thank you for providing us with updates within this thread, and for letting us know that you were able to resolve your crashing issue by fully reinstalling Far Cry 6.

    @Malemortius - Thanks for sharing that installing the game in another folder (in this case, on your C:Drive) resolved the crashes you were experiencing!

    Thanks! 😊

    Official Response
  • soundtuner31
    3 posts

    i have bought the game at launch played 90% tru the game on windows 10 , then i updated to windows 11 ... and all hell broke lose

    the game first started with had to install update 12 gb download that needed 50gb of free space , no clue about the math about that one but fk it issue of counting that is ongoing with ubisoft and other developers
    after the update i get to splash screen and warming up the shaders once this completes game crashes to desktop without even one error message

    all drivers up to date ,game up to date so i am very curious about this issue farcry 6 has with windows 11
    read tru some of the posts here and have seen the indication that ubisoft refers windows 10 being the official supported os for the game , can we vieuw this as windows 11 users can suck it and eat the loss of the game ?? no support going to be made for windows 11 and this stupid issue will continue , love to get a official response to this so we can burn the game and move on to others

  • soundtuner31
    3 posts

    @soundtuner31 last chance for this game in my eyes after a 12 gb update , i tried a last verification of game files ,resulting in another 7.28 gb file download , this is just getting ridiculous after a fresh game instal and fully updating the game im now had to redownload almost 20gb of files again . if this keeps up i will put my account online again as a free account and be done with everything ubisoft , farcry 4 was a dissaster and i had to get a pirated version to play due to cpu core problems that ubisoft was not able to fix . hawx was crashing more times then my cpu had treads working on ,it really shows to me ubisoft while it was a good stable development team in the past with prine of persia games and others in the last decade it really dropped the ball on creating stable and worth while games .. if this does not work now i will turn to a pirated version of farcry 6 in the hope the community has fixed these issues with windows 11

    im already down 5 hours in trying to get this game started again and im getting tired of dealing with this
    edit fixed

  • soundtuner31
    3 posts

    @soundtuner31 ok how i fixed it for windows 11
    reinstalled game fresh -
    removed hd textures ( this was deu to space restrictions for next steps ,no clue if it was madatory but it was a step in my solution so i will list it )
    installed update
    verified files -installed 12 gb of corrupted files
    finisched the update
    verified files again - installed 7gb worth of files
    finisched that update
    it reinstalled the visual basic files
    then the game would go past the splash screen and i have been able to enter the game again
    nothing yet on stabilty playing since for the 3rd day i wanted to play it im getting short on time to even play

    this is on a ryzen 3950x 2080 super and 32gb of ddr4 installed on a ssd stick hope it helps someone ,to my gut feeling keep verifying game files until it works verify start game if it does not work repeat the verification and try again 😞 even if it is a fresh install

  • flybyme
    212 posts

    I have posted this before so in case some of you missed it try this if you haven't already done so. I have over 100 Hrs in this game and for about the first 30 I had constant CTDs. Anyway, I run a free program from Asus called Tweak GPU 3 which has quite a few settings in it for overclocking your GPU etc. This program works on both Nvidia and AMD cards. One of the settings is called silent mode so after putting the program in that setting I have played for the last 70 odd hours with no CTD. I'm running an Intel i5 10600K CPU and an Asus GTX 1060 6 GB card. You can get it from here. GPU TWEAK III (asus.com): (https://www.asus.com/campaign/GPU-Tweak-III/)

  • WilliamTan66
    1 posts

    I have been playing for 7+ hours without any problem until at a point my laptop crashed and exited to desktop when I was trying to open up the map to navigate. Then the game will just keep on crashing while loading up the "Continued Game Save".

    Then I tried to play around with the graphic card, downgarde from Windows 11 to 10, verifying the files, uninstall/reinstall the game (and UbiConnect), tweaking the graphic card settings... none of the above work. I even upload my error logs and wrote to the UBI support for some guidance but the replies I got was that it's probably my game save file was corrupted and wasn't very helpful for troubleshooting.

    As this point and after so many attempts, the game was so messed up that I reached to a point I can't even get to the main screen, it would just simply crashed and exit to desktop after loading PSO cache. But I'm pretty sure it's not a corrupted game save file issue because I didn't even get that far, so if I could play just fine before, then it must be a hardware/driver/configuration related issue.

    Then I found this youtube link (

    ) which stated very clearly for each step you should take to solve this problem, so I decided to follow every step of the instructions since it couldn't get any worse.

    Miraculously, I managed to the main screen, so the first thing I did was to reset the video setting to default, and then lower all quality to "Low" and set resolution to 1280X720. Then I tried to load up the save file by clicking the "Continute Game" button with my fingers crossed.

    It didn't work. It still crashed and exited to desktop, but Hey, at least we're back in the game!

    Now my next attempt was to launch the game one more time, but instead of "Continuing" my saved game, I choose to start a new game. BOOM! It worked! I get to see the cut scene from the very beginning so it means the worse thing for me is to repeat the previous game play. Now, with my highly boosted confidence level, I've decided to try and load out my "corrupted" game save file one more time, and guess what? IT ALSO WORKED!!!

    As soon as I got into the game, I opend up the map and fast travel to some random location because I remember seeing a post somewhere that this method worked for someone and help them getting by without further crashes.

    This is my true story and hope it can help you too!

  • Nerdherder
    1 posts

    Won't launch after latest update.

  • AntonioSolary
    1 posts

    When you click on the shortcut, a picture of the launch appears, but then nothing happens.

  • Skulldozer.
    3 posts

    After starting the game, Far Cry 6 will crash on the first loading screen for me. The loading symbol at the bottom right spins for a little bit and then it crashes with no crash message. I have already reinstalled the game, verified my files, and updated my drivers, nor is my game modified at all. It's been like this for over 2 weeks, is anyone else having this issue?

  • UbiStorm
    Ubisoft Support Staff 694 posts

    @skulldozer Hey there! I'm so sorry to hear that the game just won't load properly for you! I do appreciate you sharing with me the steps you've already completed in an attempt to resolve this. After having tried those various steps, I recommend running through the rest of this guide listing out some basic troubleshooting steps. If you still can't get the game to load without crashing after those steps have been done, grab some copies of your MsInfo and DxDiag files and submit them via a ticket on our support site so that our support team can get a better look at what exactly is going on.

    Official Response

Suggested Topics