ubisoft discussions

Quick Suggestions

  • 26 Likes/881 Replies/48623 Views
    CaosMasterGames
    5 posts

    This is not a solution, just a workaround that I have weighed to be able to play this and other titles in the absence of solutions from Ubisoft.

    Since I have Google Stadia, I have subscribed to ubisoft + to link it to Stadia. From here I can play without problems.

    If I had known all this from the beginning, I would have bought the game directly on Stadia and forget about graphics, hard drives, drivers and all this crap...

    Of course to say that I would love to see a solution to this problem that so many users face AND THAT NOT ONLY THE USERS THEMSELVES PROVIDE SOLUTIONS OR ATTEMPTED SOLUTIONS, let the ubisoft staff stand up.

  • Kakalambalala
    3 posts

    Game crashes on launch. I do not get to any kind of menu screen.

    GeForce GTX 670
    A10-7890K
    16 GB RAm

  • CaosMasterGames
    5 posts

    @kakalambalala Welcome to the club of ignored users jejejeje

  • bobzzy
    1 posts

    I've got exactly the same problem, and funny thing it started 3-4 days I've been playing the game without any issues before this started. Overall the game runs smooth as butter, however occasionally when I open the map (and only when I open the map) - it freezes with a grey or dark red screen and 5-10 sec later is simply closes. It starts feeling annoying because I lose progress each time.
    I've searched the Windows event logs, however nothing in there, it seems the game does not generate any errors while closing like that.

  • Glennvs_
    3 posts

    My game crashed/shut down every 15-20mins randomly without any message or warning.
    But i think i fixed this, didnt crash anymore after changing this.
    Go to options, 3rd party and change MSI mystic light to off. This was default on.

  • Glennvs_
    3 posts

    @purebeaux My game crashed/shut down every 15-20mins randomly without any message or warning.
    But i think i fixed this, didnt crash anymore after changing this.
    Go to options, 3rd party and change MSI mystic light to off. This was default on.

  • Glennvs_
    3 posts

    My game crashed/shut down every 15-20mins randomly without any message or warning.
    But i think i fixed it, didnt crash anymore after changing this.
    Go to options, 3rd party and change MSI mystic light to off. This was default on.

  • UbiStorm
    Ubisoft Support Staff 631 posts

    @Glennvs_ I'm so glad to hear that you're no longer experiencing this issue. Thank you as well for providing that workaround. It's much appreciated!

    @bobzzy ,@Alkesh92 @RoumenSp ,@Duckers_Mcquack and @bushmandan2008 Thank you as well for providing your specs and the details behind what's happening with these crashes! If you haven't already, I do recommend running through these basic troubleshooting steps to see if these crashes resolve for you. If not, try the workaround suggested by @Glennvs_ . If you've already done those steps, or you find that they aren't working, grab a copy of your MsInfo and DxDiag files and submit them via a ticket on our Support Site. That way, we can look for a root cause of these crashes, and possibly see a pattern.

    Official Response
  • DoktorGonzoPL
    2 posts

    I have had constant crashes after about 17 minutes into the game on Windows 10 that I only use for games. So I gave it a try last Friday and ran the game on a different Windows 10 - the one I work with. The game ran fine with no crashes - I could play as long as 7 hours for a couple of days with no problems. Today, the same thing started happening while running Windows for work. FC6 crashes to desktop ~17 minutes after starting the game.
    The thing is I haven't changed anything to make the crashes come back. Windows (for work) has been fully updated before trying the game. I haven't installed anything, I haven't updated anything.
    Some of you guys have exactly the same problem: the game ran fine and now it crashes after 15 minutes or half an hour.
    Can someone clever figure it out?
    P.S. I am using Uplay+

  • TigerAlen410
    7 posts

    @glennvs_

    Im glad it worked for you, I tried it and it does not seem to work for me, I still get crashes every 15-20 minutes, no message or anything.

  • Alkesh92
    4 posts

    @ubistorm in windows event log warning about graphic drivers not responding that's all

    none of the tips works

    it's defenitly a windows and nvidia drivers version that is incompatible with FC6

  • AustinGamers176
    6 posts

    i guess i'm not the only one gladly

  • GrazyJos
    1 posts

    Anyone with a GTX 770 that can run the game?
    Unable to launch the game here.
    I'm able to run the exe, then it shows the splash screen and the splash screen just goes away without any crash report or whatever.

    Specs:
    I7-3770k
    GTX 770 2GB
    8 GB DDR3 RAM

    ^^ Yup, i know it doesn't meet the minimum requirements

  • Loewenm8
    1 posts

    @ubi-karl is... is this a joke to you, does steps are just a F*ck you smile from you, you are from the support, how can you make this as a "support", this remindes me more of the Battelfield Supporter who thinks he is the main show, no you are here to help and dont do the same as the dev., because they say f*ck you to us with this inhuman treatment of players, its a wonder how we are so stupid and still buy the games.

  • Caelthegamer456
    1 posts

    @grazyjos same i have a 780 and the game doesn't launch

  • DoktorGonzoPL
    2 posts

    To you all: Can you please write whether you are using Ubisoft+ or have bought the game?
    I'm using Uplay+

  • muffy2
    3 posts

    @but00040004 760 4gb 10600k 16gb ddr4 Splash screen crash. Every other far cry game works perfectly. Its not us

  • Kakalambalala
    3 posts
    @but00040004 760 4gb 10600k 16gb ddr4 Splash screen crash. Every other far cry game works perfectly. Its not us

    Not just every other Far Cry game, but every other game, period.

  • SidheVicious
    10 posts

    Crashes to desktop with no error message immediately after splash screen.

    Running as administrator does nothing.

    PC exceeds minimum specs, all drivers (Nvidia) are up to date, the program is trusted by the antivirus. Microsoft C++ was uninstalled and reinstalled and windows updated to the latest version.

    Still. Doesn't. Work.

    It's been almost two weeks. I'm deeply regretting blowing sixty dollars on this junk.

  • juhanieminen
    8 posts

    @sidhevicious Try chance Nvidia drivers older ones. I get my game working,when i install 461,40 version

Suggested Topics