ubisoft discussions

Quick Suggestions

  • craftercis
    60 posts

    @ubi-borealis

    sorry for my behavior in my previous (deleted) post. I'm glad you're taking 1 Stutter seriously now. hopefully the others will follow soon. I'm now starting a new game without HD texture pack. and hopefully this will go smoother. If there's anything I can help with testing new updates, I'd love to hear it.

  • BattleMaster23
    28 posts

    @ubi-borealis One thing I have noticed that does help reduce stuttering is turning Environment Detail down from Ultra to High in the graphics options. Obviously since most here run very good systems (myself included) we don't want to do this, but if for those that this helps and they don't mind doing it, I thought i'd mention it.

    In my experience, the stuttering is only in certain locations, like large buildings that are enterable and where there's a lot of enemy NPC's. Auto Saving does cause stuttering as well. Hopefully there will be fix in the works for these problems. Thanks.


    PC Specs: CPU: i9 9900K / GPU: Sapphire RX 6900XT / RAM: 32GB DDR4 / PSU: EVGA Supernova 1000W / SSD: Samsung 970 Evo / Windows 10

  • Tomas_Jari
    7 posts

    Any news about autosave stutter?

  • olalaquebien
    Original poster 69 posts

    @ubi-borealis Keep ignoring the main issue with the drivers and Dunia for not preloading shaders in a dedicated file, causing the situational micro-shuttering that has been plaguing your bad PC port since FC3 everytime the game loads stuff as you avance through the map. That's the shutter this topic was about.

    And the second in importance shuttering, the cpu related one due to much load in one single core, keep ignoring that one too!!

    Keep doing it man!

    And oh Christ you're gonna fix the auto-save shutter?, and how are you gonna do this man?, by not auto-saving everytime we grab an item like the Resistance mod did for FC5 because you were that lazy?, what a fix!!, genius!!!

    Seriously now this is a joke. We're losing our precious time here as you obviously don't seem to acknowledge the true issue this topic was about before you changed the topic tittle.

  • Ubi-Thrupney
    Ubisoft Support Staff 2446 posts

    @revankin , thanks so much for getting those files uploaded to your support ticket, and for describing the further troubleshooting steps you've tried. Can you answer the questions below, so I can add your experiences to our ongoing investigation into this?

    • Are you using the HD texture pack? If so, have you tried disabling this to see if the stuttering improves?
    • Does the stuttering only occur when carrying out certain actions (such as picking up items), or in certain locations? Or is it all the time?
    • If you have any videos which shows the stuttering happening in-game, these will be helpful for further investigation.
    • What are your in-game settings? If you can provide a video or images showing these, that would be very helpful.


    For videos on PC, the Xbox Game Bar is a great choice, since you probably already have it installed. The resulting footage can be uploaded to the third party video hosting site of your choice, and links included as answers to the questions above 🙂 Thanks so much for your help with this report!

    Hey @Mr-Gepardas , thanks for coming back to us about this. I understand from you hadn't been able to create a support ticket previously, so I've gone ahead and done that now. Please see this support article, which describes the two files we're looking for, and log in here to find the support ticket. Let me know once those files are uploaded to the ticket 🙂 Let me know if I can clarify that at all, and thanks for your report 🙂

    @Tomas_Jari , thanks for asking about this! We don't have any news to share at the moment, but we'll be sure to make a post here in the forum thread, or announce it on News & Announcements, as soon as we have an update 🙂

    @olalaquebien , I appreciate you voicing your concerns about our posts - we're happy to receive your feedback, both on the game and on how we report on issues. We've been sharing all the reports we've received with our internal teams, who are in a better position to diagnose the issues than us support agents are. Although we're pretty tech savvy too, our internal teams actually working on these issue are specialists. We're not always in a position to report on exactly what their findings are, but I'm confident they'll have come to correct conclusions with the available data.

    @BattleMaster23 , thanks for sharing this additional insight about the Environment Detail setting, and specifying when you've found the issue most prevalent. I've gone ahead and opened a support ticket for you - can you follow the same steps I've shared with @RevanKin , above? Thanks!

    Thanks for the continued reports and updates on this, everyone.

    Official Response
  • Sammarok
    177 posts
    @Sammarok - Thank you for sharing your ticket number with us. I've taken a look at your case, and I understand that you're encountering stuttering when picking up items and whenever the game autosaves. Is this correct? As mentioned earlier in this message, the development team will be deploying a fix for the stuttering caused whenever picking up an item in a future update. Once we have more information to share regarding this fix, such as an ETA for its release, we will let you know within this forums, so please keep an eye out for more details. To clarify, does the autosave stutter only occur when picking up items, or does it occur when the game autosaves even if you haven't picked up any items?

    @Ubi-Borealis Hi, Thank you very much for your answer. Yes that is correct, but also the stutter happens when the autosave shows up, picking up items or not.

  • olalaquebien
    Original poster 69 posts

    @ubi-thrupney "our internal teams actually working on these issue are specialists. We're not always in a position to report on exactly what their findings are, but I'm confident they'll have come to correct conclusions with the available data."
    ______________________________________________________________

    Given your curriculum on your PC ports since the days of FC3, everything seems to point exactly in the opposite direction on your confidence about getting things fixed.

    The situational micro shutter when the game loads stuff as you advance through the map is an eight years old issue already that you never fixed in the past FC entries for PC, so sharing your confidence on your team of "specialists" being able to get this sorted out at long last pretty much seems to me like some masochist act of faith, faith which is pretty much misplaced given their chances to fix this issue up to zero in a scale of ten.

    You know this cannot be fixed so long you don't add a shader cache file that needs to be preloaded only once before playing the game (or anytime you change your gpu drivers), which would mean updating Dunya to todays standards in order for your PC ports to function properly in comparison to its console counterpart, which hey what a miracle, never suffered from this issue. Why?, because shaders and everything are designed to communicate perfectly fine with the console gpus, but then when this has to happen with PC, the issue becomes real with gpu drivers communicating with the engine.

    And then the other issue about terrible CPU work spread, forcing almost everything on one of the cores. You know what to do but still too lazy to get it sorted, right?, but hey keep asking us about handing you dumb stuff over, so you can concentrate on fixing nothing, as usual.

    Lol, and what can one say about the fix for the auto-save micro-shutter you are rolling our on a forthcoming patch. All you're gonna do is, precisely, not to save anytime we grab stuff, rofl, like the Resistance mod for FC5 did way before. Yeah now that's some "specialists" you got over there right?, genius!

    Furthermore, and to continue to discourage your PC customers in your usual ways, (you continue to treat us all as pirates, remember?), you keep ignoring this issue instalment after instalment, treating us as idiots with your absurd requests of "provide us with this and with that", when your team of "specialists" know very well what the issue is about.

    And then you don't even remove Denuvo one year after release or when the game gets bypassed, protection that contributes to the overal instability of the game regardless what you and many bots around say otherwise (look at the ultimate case with this with Resident Evil 8, where it got absolutely out of control), let alone won't remove such intrusive drm even when one of the two situations aforementioned complies. That's how you like to treat legal PC customers. Your disrespect towards us is absolute.

    I'm afraid that our confidence on you, support team, and your "specialists" borderlines on none-existent for the time being, at least concerning PC support. It's been so many years already, and we know perfectly well what you're about when it comes to PC versions of your games.

  • Mr.Gepardas
    7 posts

    @ubi-thrupney uploaded the files to the ticket. Also since today's update the game no longer launches at all, it just shows the splash-screen, where usually you would see PSO Cache being warmed up, but now the text is no longer there and the game just closes. Already tried verifying the files, running as admin etc. nothing resolved this issue.

  • craftercis
    60 posts

    @mr-gepardas try to close the launcher and run from the .exe file

  • craftercis
    60 posts
    This post is deleted!
  • jotarodazpa
    46 posts
    I just recorded a gameplay video without the HD texture pack + ULTRA settings. From this, I see that I have much fewer stutters than before. There is only one big stutter at 3:22. V-sync and frame limit are turned on because I have a G-sync compatible monitor.
    I really hope this will be fixed soon as I would like to play with HD textures. Re-size bar is also turned on

    PS: Sorry for 1:29 🙂

    Gameplay video:


    Graphs:

    HD ON:


    HD OFF:


    You can clearly see when the HD texture pack is on. I have set the framerate lock to 70 to help prevent stuttering.



    @craftercis

    Great post/feedback, that is 100% like me on a 3080 16gb vram.

    But is not news, we already talked and confirmed that the game runs almost perfect with hd texture pack OFF.

    Your feedback and mine feedback, contradicts ubisoft "theory" that the hd texture pack runs fine on gpus with 16 GB VRAM or more... that is not TRUE

    @Ubi-Borealis send this post to ubisoft workers...

  • Mr.Gepardas
    7 posts

    @craftercis That unfortunately does not help, exiting the launcher and then launching the game exe from bin or bin_plus folder just launches Ubi launcher anyways and then does the same thing: Splash-screen for 3 seconds and then the game turns off

  • Bladerunner4077
    193 posts

    Just an interesting observation for everyone here. I was having a 9900K coupled with a 3080 Ti and having stutters with the HD Pack same as you guys. I have since upgraded to an i7 12700K and the stuttering is almost majorly resolved. It seems to me the game's streaming just demands an absurd amount of single threaded performance which only the very best chips on the market today can provide

  • craftercis
    60 posts

    @bladerunner4077

    We all have the recommended specs suggested by Ubisoft. So buying new gear is not necessary.

  • jotarodazpa
    46 posts
    Just an interesting observation for everyone here. I was having a 9900K coupled with a 3080 Ti and having stutters with the HD Pack same as you guys. I have since upgraded to an i7 12700K and the stuttering is almost majorly resolved. It seems to me the game's streaming just demands an absurd amount of single threaded performance which only the very best chips on the market today can provide


    @Bladerunner4077

    That is prove that is ubisoft bad optimization and nothing else.

    How does a PS5 and Series X can run the game with hd texture pack with a weak CPU?

    Here is one with a graph




    @craftercis

    Can you do one more video like that ? max settings + hd pack, with graph showing the stutters?

    Just drive around, or go to big places (city), shooting, or go to new places, but driving usually shows the stutters.


  • olalaquebien
    Original poster 69 posts

    @jotarodazpa It is most obvious FC6 is, as of now, worst FC port on to PC.

    Tney continue to treat us as pirates ten years after those infamous words.

    Inevitable moral is, do not buy Ubi games on PC. Period.

    And they're also bordering on ridiculousness with their wokeness as well, to the point I wonder whether they will go for a full female enemy army next game lol, you know for maximum realism.

    It is pathetic indeed.

  • DHO_N1
    3 posts

    @hastro163x
    Ясно. Я с Управленческого.

  • Bladerunner4077
    193 posts

    @craftercis what cpu are you using?

  • craftercis
    60 posts

    @bladerunner4077

    i9-9900K

  • Bladerunner4077
    193 posts

    @craftercis If possible, can you post a video but with your VRAM monitoring enabled? Just open msi afterburner settings, go in monitoring tab, there will be a button with 3 dots "...". Click that and enable GPU.DLL. Then click OK. Now enable GPU Dedicated Memory Usage / process.

    I want to check if the stutter has to do with VRAM usage on per process basis.

Suggested Topics