ubisoft discussions

Quick Suggestions

  • Ubi-Mark.
    Ubisoft Support Staff 2768 posts

    Hello @foolhardyalarm9,

    Thank you for sharing this report with us and I'm really sorry to hear about your experience.

    As you mentioned that you reinstalled your game a few times already, can you please confirm what type of internet connection are you currently using? Have you tried disabling it/switching it to mobile, by any chance in order to test if the issue still persists?

    Secondly, can you please perform all of the troubleshooting steps listed in this article? This will ensure that your connection to our services is optimal.

    Many thanks and if you have any additional questions, please let us know.

    Official Response
  • dadofeandz
    1 posts

    I’m stuck on this too. I play on Xbox series S. it worked fine until the latest update. The only way I can get past the screen is to go offline. Otherwise it’s impossible to play the game. Nat type is open, reinstalled etc etc, no difference. What is the solution please Ubisoft?

  • Ubi-LadyBlue
    Ubisoft Support Staff 523 posts

    Hey @dadofeandz! Welcome to our Discussions!

    I'm sorry that you're encountering this issue as well and thanks for providing the troubleshooting you've already done on your own.

    Please try these steps as well as the ones that my colleague suggested above and let me know if it's still not getting past that add-on screen.

    Official Response
  • chin-chu
    8 posts

    Like you see im not the only one getting stuck on the loadingscreen checking for add ons, can you please fix the problem instead of always telling us the problem lies with us. The game always worked perfectly and then suddenly it didnt because it always happens after a patch so the problems lies on your end not ours

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hello there @chin-chu,

    I'm sorry to hear that you've been experiencing crashes on the "Checking for Add-Ons" screen. As there can be multiple causes behind a crash, it can be tricky to identify the specific cause and provide a fix for this. This is why we ask players to try additional troubleshooting steps first, as this helps to eliminate other potential causes behind the crash.

    Thank you for letting us know that you've tried a clean installation of the game, and that you've also verified your game files. I'm sorry to hear that the issue continues to persist after trying these steps.

    When you reinstalled Assassin's Creed Valhalla, did you just install the base game? Or did you also install any expansions/additional content you owned prior to re-launching the game to see if the issue persisted?

    Have you also been able to try the other steps suggested by my colleague @Ubi-Froggard, such as creating a new Windows Admin account? You can find these steps below:

    Please could you try uninstall the game and Ubisoft Connect, then create a new Windows Admin account on your computer. Once you have done this, log in on that new account and reinstall Ubisoft Connect and the game. If you can try installing them on a different drive to before, please also try doing this. Let us know if you still have the error when launching the game again. 

    I also recommend that you try the other steps provided on this basic PC troubleshooting article, as these steps also help to combat a number of common causes behind technical issues in-game. In particular, I recommend ensuring that all updates - both game and system updates - have been installed.

    I would also suggest trying to play the game offline to see if this allows you to bypass the Add-ons screen. If you're able to bypass the screen whilst playing offline, this information will be helpful as we look into this issue further.

    If you're still having trouble getting past the Add-ons screen after trying these steps, please don't hesitate to update us within this thread so we can continue the investigation.

    Thanks! 😊

    Official Response
  • chin-chu
    8 posts

    @ubi-borealis i did what you told me and made a new windows account with uninstalling and reinstalling everything and it worked i can play again. The question is now how does it come it wont work on my main account. Is there anything i can do so it works again on my main account because i find it so stupid have to switch all the time.

  • Lexx67x
    3 posts

    @ubi-borealis Good afternoon. I have the same problem only on the xbox series, sometimes it takes an hour to check the content. And additionally, the progress in Assassin's creed Valhalla is not updated, trophies do not come

  • Ubi-Thrupney
    Ubisoft Support Staff 2865 posts

    Hey there @chin-chu , thanks for letting us know that a new Windows user account seemed to resolve the issue. I understand you've found that your main Windows account still gets stuck on 'Checking for Add-ons' - that sounds most frustrating, and I'm glad you've come back to let me know.

    Please make sure you'd also had a look at our troubleshooting guide, and perform those steps while you are logged into your main account. In particular, make sure you've been running the game with admin rights, and you've fully updated your Windows install, Please also make sure you've checked for background programs that might be conflicting - this last step is particularly important, since the other user account might potentially not have had specific programs running that your main one does, and I'd recommend going straight for the Clean Boot process for this.

    Come back to me if it still doesn't work even after those steps - I'll have some further ideas we can try.

    Howdy @Lexx67x , thanks for reaching out as well. I understand you've faced a similar issue with Valhalla getting stuck on this step for up to an hour, and progress not updating in your stats and achievements.

    This suggests a connectivity issue, so I'd recommend starting with our connectivity guide. In particular, from that article, please remember to reset your network hardware, switch to a wired connection (if possible, and if you aren't already), and check for software conflicts that might be causing interference (such as downloaders on any computers on your network, for example).

    Let me know if the issue persists after those steps! I'll keep an eye out for your response 🙂

    Official Response
  • idledae
    1 posts

    @ubi-thrupney Hi, I'm having the same issues on Xbox Series X and have tried all the steps in your guide with no success. Is there any other solution you can offer or is there a way to escalate this issue? TIA

  • Ubi-Froggard
    Ubisoft Support Staff 2973 posts

    Hey @idledae

    I'm sorry to hear you have the issue on Xbox too. Can you check your additional content on the Xbox and see if there's anything else available to install?

    If not, can you let us know if you bought the game and any content on your Xbox account or if you have shared it from another one that made the purchase? Also, if you have played the game on any other devices that may have had any other additional content installed on it?

    Official Response
  • Sakaliet
    4 posts

    i have the same problem on pc
    tried everything with no luck
    offline mode and deleted my local savegame and still nothing worked !

    i already have completed the game to 100% so my save game is really important, plz fix this ubisoft !

  • Sakaliet
    4 posts

    i have fixed my problem .. thought i share my fix with you guys maybe it helps some of you

    remove folder dlc_146 and run the game ..it worked for me !

  • Ubi-LadyBlue
    Ubisoft Support Staff 523 posts

    Hey @sakalie!

    I'm sorry to see you ran into the same issue on PC but thank you so much for sharing how you fixed it. 💙

    Don't hesitate to reach out if I can help with anything.

    Official Response
  • Pendraeg
    3 posts

    What did you break now?

    "Checking for Addons" takes forever.

    Quit screwing with stuff or else let me play offline so I don't have to deal with your server-side crap.

  • Ubi-Verse
    Ubisoft Support Staff 953 posts

    @Pendraeg Hi there! Sorry to read that you are also having this issue. What platform are you playing on?

    Official Response
  • ShaneG20
    1 posts

    @Ubi-Verse nothing in this post helps i have done all of it and nothing is helping i sit there for over a hour waiting. i play on pc. my computer is fine. literally nothing in this post is helping. can you please just fix your game issue?

Suggested Topics