ubisoft discussions

Quick Suggestions

  • FcAc-No-Moe
    1137 posts

    I don't know whether this has been mentioned or ask before and I was not going to read 440 posts in the thread so here it is.

    Vahndaar, Chris or anyone around that wants to help. OK, I was going to start installing the Mod (well, trying anyways) but I am running through some small issues/details that are not in the How To and I don't know what to do nor want to screw this up, let alone bust my whole rig so, I was thinking I am going to write down what this thing is asking me to do and then one of you guys will tell me whether I screwed up, I did it right or if I need a new PC because mine will self destruct in 5 seconds after I am done. 😵 🤠

    1.- I installed the cheat engine. I am not going to lie, I was a tad apprehensive and anxious to say the least.
    2.- Then I ran the CT file from the folder where I had downloaded the Zip file of the Mod (GRB-v0.33.CT) but here is when all sorts of little things started to get in the way and truthfully, it was hard to read because words get intertwined with each other(it could be because I am using a 55" TV/monitor and the install doesn't like it). Anyways.
    2a.- The How To says it will ask me whether I want DX12 or Vulkan but mine does this: The first pop up says: Execute this Lua script? "Always", "Only when Signed, else ask", "Always ask" or "Never" and I chose "Always ask" as I thought it was the safe bet.
    2b.- Then it asks me something else and of course I started to freak out and I just tried to X-it out of there w/o causing to much havoc and also of course, it isn't asking me now.
    2c.- When I click on the highlighted box to open a selected process, I get a window open with a whole bunch of process list including one that is already highlighted that says 00005BA0-Cheat Engine 7.3 but nothing remotely close to saying DX12 or Vulkan and if I click on the "Open" button I go back to the same page I was before. Oh but if I click on the "Advance options" at the bottom, another small window opens with this list and that is where I am stuck now. And as you can see, it is an extensive list not easy nor simple to chose from.



    If I miss the post where this was explained, I apologize and ask nicely to be pointed in the right direction please. I am ready to give this mod a swirl but I am stumped as you can see.

  • FcAc-No-Moe
    1137 posts

    I also want to add that I watched GmoneyMozart 13mins video of the mod but his files are not the same as the files I downloaded myself from the Nexus page, which are below his image and files, in smaller size in hopes that we can see they are different.


  • Flanker1Six
    228 posts

    Oooookkkkkk............................When I installed CE 7.3 on my comp; I installed it to the main GRB folder. Not sure just what all it installed, but I noticed 2 CE 7.3.exes right away. One is for DX 12 and the other for Vulkan. I play GRB in DX 12 so I copied and pasted the CE 7.3.exe for DX 12 to my desktop (just for convenience as I'm sure you can run it directly from the GRB main folder).

    I start GRB in DX 12; I immediately get a prompt asking if I want to install Battleye (which I've uninstalled per the Spartan Mod instructions); I click cancel; I let GRB run through the Ubisoft and AMD splash screens until the game gets to the page where I can select one of my 3 Nomad characters.

    I Alt Tab the game to minimize it; then double click on the CE 7.3.exe on my desk top. Once CE 7.3 is up; I click on the icon (looks like a magnifying glass) directly under the File tab in the upper L hand corner of the CE 7.3 window. A list pops open with a bunch of icons and their file paths. I highlight the GRB icon that says 00001108-GRB.exe (the last four digits will be different each time you start CE 7.3 and go to highlight the GRB icon). I click on the "open" button below that icon/file path. A prompt asking if I want to keep the current somethingorother list comes up. I select yes.

    Then I check the box in the CE 7.3 window that says: Enable Spartan Mod. It takes a couple of seconds; then highlights green with a red X in the check box. The mods "command lines and their mod parameters" (not sure if that's the correct term for them or not) appear as a list below the highlighted Enable Spartan Mod. If you want to edit any of vaandahrs mod parameters......................this is where it's done. It's the numerical values to the right of each line. If you're satisfied with vaandahr's parameters DON'T DO ANYTHING WITH THEM.

    Minimize the CE 7.3 window (you don't have to; you could just leave it up on your desk top). Bring the GRB character page back up; select your character to start GRB with the Spartan Mod enabled.

    Hope this helped!




  • FcAc-No-Moe
    1137 posts

    I think that I have learn and being spoiled too well from the studio and not make any type of effort reading the .txt and also the .docx, hence, why I have ran into such issue that I have at the moment. I say this because reading what FlankerSix have typed and listening to the Gmoney's video, I forgot to read all the way to the end of those files.

    In my defense though, I was just trying to install the cheatengine file when I got those questions that you see in 2a, b & c and maybe or maybe not the answer is at the bottom of the instruction files.

    I'll know more tomorrow when I try again if I am not too busy, which I hope I will be.

  • FcAc-No-Moe
    1137 posts

    Ok, here we go, from scratch... I have downloaded the latest version from Nexus as explained above.

    I have also followed the instructions fully & 100%


    ***********************
    How to install:
    ***********************

    Install cheat engine, download from here : https://www.cheatengine.org/downloads.php: (https://cheatengine.org/downloads.php) ----- CHECK!

    Make an exception if antivirus complains, it's completely safe ----- CHECK!

    Copy zipped files to your game folder ----- CHECK!

    Go to the BattlEye folder and run Uninstall_BattlEye.bat ----- CHECK!

    Edit BELauncher.ini and set SilentInstall=0 ----- CHECK!

    In the Ubi Connect Launcher add these arguments under Parameters > Game Launch Arguments : /belaunch -be ----- It took some doing but also CHECK!

    Launch the game from Ubi Connect ----- CHECK!

    Click cancel when the BattlEye installer pops up. Optionally tick the box to not be reminded again. ----- CHECK! & CHECK!

    Ok, so the next steps is where I am failing and I am sure it is because of me, totally my fault but in my defense, I have never, ever used a cheatengine before. Don't want to sound like a Hero, not at all, I have cheated using cheat codes before for an amount of different reasons but not this so I am not familiar with it AT ALL.



    ***********************
    How to run:
    ***********************

    Launch the game from Ubi Connect ----- CHECK!

    Let the game boot up to the main menu ----- CHECK! Just to verify, the main menu is where you choose the slot you want to play with, correct? if so, again ... CHECK!

    Alt+Tab to flip to the desktop ----- CHECK!

    Double click the cheat table ----- I am assuming that the Cheat Table is GRB-V0.33.CT and CT is short for Cheat Table? if so ----- CHECK!

    OK, perhaps the instruction skipped a step or two because when I double click to open this file, this is the part where I get a Pop-up, FIRST from Windows 10 asking me if I want to allow it, then a SECOND pop-up asking me the following:
    Execute this lua script? Below this it says:
    Future reference:
    When a table has a lua script, execute it:
    Always
    Only when signed, else ask
    Always ask
    Never
    Default answer is Only when signed, else ask so I click on the YES button at this point
    Yet another pop-up asking me if I want to try the tutorial and I said NO. The reason I said NO is because twice I have said Yes and it is giving me a whole Mambo Jambo that I do not understand. If I screwed up then let me know, I'll uninstall and run it again saying YES.


    Hook the game process using the 'Select a process to open' button and selecting the GRB process ----- I imagine this is where I am going to choose 00002A34-Ghost Recon Breakpoint from all of those processes in the list? if so CHECK!

    Click the box next to Enable Spartan Mod (a red x should appear if all is working)

    Alt+Tab back to the game

    You're good to go!

    Ok, so far so good, I guess all of the new options not in the instructions that I choose were the correct ones.

    Now, I have started the game and I am now moving towards the 2nd Helo crash and I don't think I have felt any changes from the Vanilla Game since the first two were easy to take with the handgun and the next two I thought would give me a bit of an issue but nope, I shot the first one, I tried to a lateral movement but I was blocked by a rock I had not seen and I had no LoS on the 2nd bad guy so it took me a few seconds to reacquire him and he was just there, nonchalant, waiting for me to fire.

    I am guessing, the whole Mod activates after Erewhom? I vaguely remember reading something of that fact? or perhaps not and I have not done it correctly even though, the "X" on the mod shows follow by a whole bunch of process below it

    EDIT:
    Ok, no... Nevermind, now I am starting to feel hunted and if you don't have LoS on the enemy but you can hear them in the distance, the bad feeling in the pit of your stomach is even more enhanced.

    Now, I don't know if that is a good thing or not, the hearing issue I mean because even if you can see them, hearing them is another aspect a good Quiet Operator has to be have fine tuned and the game having the sound all over the place is not an asset but a glitch or a bug but, hey! ... at this point, I'll take it.

  • Flanker1Six
    228 posts

    Sounds like you're good to go! 👍

    You can double check that the mod is working by editing one of the mod's ammo amounts (down at the bottom of the mod's parameter list). e.g. Spartan Mod default 9mm amount is 120 (that's 120 spare rounds + the magazine in whatever 9mm pistol/submachine gun you have equipped in game). L click on that line; press enter; then type in the amount of spare ammo you want.

    Pick your Nomad character to start the game. Once you materialize in game; check your pistol/submachine spare ammo amount. If it's the amount you edited that value to-----the mod is working!

  • FcAc-No-Moe
    1137 posts

    Oh no, I am definitely ON

    Freaking Mod left me with no ammo, and I mean ZERO and I only had 1 dude left to deal with. Man, I was on fire (but because of how upset I was LOL).

    Look, I do hate the fact that the enemy can see you w/o LoS, meaning their heads are turned the other way and they LoS-o-Meter is buzzing and that is super annoying but, that is NOT the fault of the Mod.

    You know you are playing with the Mod when it takes you a good hour (perhaps even 2? I really wasn't gauging time until I got to Erewhom) and change to get from the first helo to Erewhom. Sure, you are testing the waters, you are pushing boundaries but still, I already see that I am not going to be able to go Ramboning nor Gun-Ho as a 1 man Army.

    Still dumbfounded how a studio that allegedly cares about the community has not come to say anything and stood quiet. If that doesn't show people how much they DON'T care, I don't know what will and it does show that some people just follow behind in fear.

    Vahndaar... I have only began to test this Mod but I would like to tip my hat to you Sir while I dump on those people who have insulted me and my intelligence.

    EDIT:

    Imagine if you will, half the Island only but with more grounded & mature missions, full briefings, leave the overcrowded points of exploration and rewards for those who like that sort of thing, although, with this mod in place, feeling hunted, I doubt people would be worried about exploring like they do now. Imagine if the game had the full support of the Studio? Imagine how much mtx they could have sold afterwards with this kind of game? Just... imagine!

    It is going to take a while for me to change my tactics and strategy, I am still drugged out & spoiled with holding hand options that it is hard for me to wrap myself around the idea that I can't shot an enemy inside a base with an ASR (and I did hear Gmoney talking about it last night on his video). Hell, even with a pistol is almost an attempt to botch the mission for doing so. Being said that, today I have played for well over 4 to 5 hours in a session, something I had not done in months. I am tired, and yet, I can't seem to let myself go watch TV or do something else because I can't allow this mod to hunt me all night long, I have to be able to take a base wholesale and clean.

    Dammit Vahndaar, I hate you now 😁



    😂

  • Hugo-FOU
    174 posts
    @steven527 I went back to story mode and then went into liberty. What a different experience with the mod. I didn't even need the tactician guy. Additional sentinel troops kept joining in the fight getting sucked in by the unsuppressed fire of other sentinel troops. Drones gone, additional bullet sponge enemies gone and an escalating firefight. Having to be aware of sniper positions as now they can see much further. Nice.


    That sounds great. I really hope Ubi are paying attention to this. It can only be good for them if they add in these features.

  • Evilducky2
    27 posts

    A few things I've been trying to figure out and I dont know what controls stuff or how to add new things since im not the best at this.

    I've been playing as a "rebel" and wanted to limit the number of gadgets I could carry. For example, I want to lower how many rockets I can carry to one and the number of grenades to 2.

    Another thing I've been trying to figure out is what controls magazine sizes to adjust some of the rifles mag sizes.

    I know there is more but I cannot think of the other things I was looking for over the time playing. Thanks over all for the great mod though. Its definitely been a blast playing with these settings.

  • Virtual-Chris
    Original poster 798 posts

    @evilducky2 there’s no way to limit gadgets currently. You will need to police that yourself. Or use them up (intentionally waste the excess) when you leave Bivoac so you only have what you want to carry. Mag sizes for guns are limited for most but can be changed in gunsmith.

  • Steven527
    372 posts

    @virtual-chris That's what I've been doing. Never did get why I had Mk 2 and 3 of stuff. Haven't yet decided what should be a standard but I'm figuring a couple frags and flashbangs unless i have a specific mission requirement.

  • FcAc-No-Moe
    1137 posts

    Guys, wouldn't be good if we open up another post where we could state things that we may want changed and the guys who know how to manipulate the CT can give us a hand?

    I can always proceed with the questions here if that is what we want as well. I am just trying not to open multiple posts about the same thing so it doesn't get hard to find stuff but at the same time, this one is getting hard long lol.

    Anyways, I am still not sure how I want to set the question up so I won't do anything yet.

  • Evilducky2
    27 posts

    @virtual-chris Thats what I was kinda guessing but im just not good enough with cheat engine to understand. I found some values that correspond to the gadget count but I dont know how to go about manipulating that or where to find the max amounts.

  • Lolt6
    86 posts

    I see any of Ubi employee not responding to this thread so far.
    Be it good or bad, it remains to be seen.

  • LoneSpymaster
    13 posts

    Really interesting mod, wish similar options would come to consoles, as Im playing on xbox lol
    Anyway....what do you mean by this?
    "I would avoid using stealth perks as those increase enemy reaction time."

    So lets say that I want to increasy enemy reaction time, should I use then whatever stealth perk I want? Like sixth sense or sensor hack?
    Im all for that, if thats the case.

  • Virtual-Chris
    Original poster 798 posts

    @lonespymaster … I know it’s a bit confusing… If you want faster detection, don’t use stealth perks, use higher difficulties (and use the mod) - all of those decrease reaction time (they react faster). If you want slower enemy response, use lower difficulty and/or stealth buffs. That increases reaction time (they react slower).

  • FcAc-No-Moe
    1137 posts

    My apologies if this has been posted before. I do believe seeing something but can't remember which page.

    Some of the values like " NEW Enemy Engagement Distance Multiplier " has a value of 3 and I just changed it to 2 (for testing purposes) but I was wondering if I use something like 2.75 if that does something or no decimals allowed in the value?

    Also, this is the part where I don't know what this means. I do have an idea but not 100% sure if that is what it does. Is the Active Description above means the distance at what the enemy will start having line of sight on the player?

    I am going to go read some of the initial pages to see if I can put 2 and 2 together in hopes I come up with 4

  • vahndaar
    129 posts

    Hey folks, happy new year everyone. Been taking time out so apologies haven't been as active recently.

    You can use fractions, for most variables apart from integers such as ammo counts.

    For enemy engagement distance, generally keeping it with the visual detection distance ensures visual detection and engagement works in sync.

    Haven't looked at gadgets, generally the ammo pickup amounts are a factor of max ammo. In the base game, strangely enough ammo pickup amounts are a factor of the restock levels which is a little odd but I suppose it leads to more ammo being dropped when ammo held is low.

    That's more of a trend in games these days, giving the player more of what they need when they need it.




  • MikeWeeks
    251 posts

    Did the mod change unsuppressed detection distance from the vanilla game as shown in the Readme file?

  • Virtual-Chris
    Original poster 798 posts

    @mikeweeks Yes, it should do.

Suggested Topics