ubisoft discussions

Quick Suggestions

  • Senhor-T-
    1 posts

    I have the same problem.

  • IndiGan06
    8 posts

    I also have the problem with a DualShock 4 while playing through Nvidia GeForce Now

  • MapleBaconQBG
    4 posts


    Not the point- i'm reporting a bug. Thanks ^^

  • Ubi-Karl
    Ubisoft Support Staff 1534 posts

    All good, any time! 🙂

    Official Response
  • ElHighPriest
    1 posts

    Also having this issue.

    I'm using a Nacon Revolution Pro 2 controller

  • WhyDoUEatBrains
    1 posts

    I had the same problem on PC (xbox 360 wired controller, holding left trigger to aim and trying to fire would cancel the aim). I solved it by:

    1. Adding Far Cry 6 to Steam as a non-steam game
    2. Checking the box in steam settings for Xbox Configuration Support and generic controller configuration support.
    3. Launched the game through steam and everything works.

  • Mr_ALLroy
    3 posts

    @nemesis42a I did try this fix but it didn't work. My gun would go out of "aim" as soon as I pressed RT. So far my fix above works like a charm but not ideal in the long term.

  • MapleBaconQBG
    4 posts

    @ubi-karl I'm not far enough into the game to have a 4th weapon, so I can't swap the gun into the 1st or 2nd slot. I will update with further information as soon as I get to that point in the game.

  • MapleBaconQBG
    4 posts


    Okay, as a further update. I cannot fire the sniper rifle with the PS4 controller when the weapon is in *any* slot. Slot 1, 2 or 3 all fail to function. And it's specifically sniper rifles, as all other weapon types function as expected.

  • nEMESIS42a
    5 posts

    @mr_allroy unfortunately I am unable to test that fix since I am using GeForce Now. The game automatically boots up through Ubisoft Connect and there is no way to boot through Steam like that.

    Interesting discovery also is it seems that Slot 3 weapons will not fire at all. Under Options > Controller I simply switched the aim method from HOLD to TOGGLE and I am able to fire by pressing L2 once, then R2. For Slot 3 though that doesn't work for some reason.

  • le_chouille
    21 posts

    Same problem with a Shield gamepad. Shame !

  • Reznik112
    1 posts

    Same problem with Logitech F710. Will try to install Steam as this seems to be the only fix, odd one though... Never had this problem in New Dawn so I doubt this will work for me.

    edit: Steam didn't help for me, for F710 it's apparently much simpler: just switch from X-input to D, sensitivity still seems ok. Now I remember I DID have the same issue with New Dawn.

    1 posts

    @ubi-karl Hello! I have the same problem with my Razer Raiju Tournament Edition on PC-version. I try to remap triggers (turn left-handed option), but nothing changed.
    When I tried to disable the "hold" mode for aiming, the following happened - the character entered the sight by pressing the left trigger. by clicking on the right trigger, the character exits the sight and makes a shot, when you click on the right trigger again, he enters the sight and makes a shot.
    I also tried to turn on the game mode with one hand (right hand). Then after pressing the right trigger, the character use the phone. If you remove the phone by clicking on the left trigger, the character will already be in sight.
    At the same time, aiming with the mouse works correctly. Also, I connected Dualshock 4 to a PC, aiming also works correctly with it.

  • Diego_the_best
    9 posts

    Ubisoft we are still waiting...

    Far Cry 5 works perfectly with the same controller (DualSense).

  • s10cameo
    13 posts

    I can not fire my sniper rifle on PS4. I pull R2 with full ammo aiming down sights and nothing happens the sniper rifles are useless.

  • Doc_Gonzo_MD
    2 posts

    @usuisan778 im having this same frustrating issue with geforce now on the nvidia shield with the nvidia controller as well as the Dualshock 4. very annoying and the game is unplayable!

  • scotini69
    2 posts

    Using nvidia shield with GeForce now with official nvidia shield controller and I cannot aim and fire.
    Absolute waste of money. Waited years for this game and can't even play it. When will a patch fix this???

  • Oregon9581
    1 posts

    The sobek special sniper weapon doesn't work it won't let me fire it I restarted the game and it still doesn't fire I'm playing on the PS4

  • Nandiman
    14 posts

    @oregon9581 I just got that rifle. I'm going to test it.

    Edit: Sorry, I got the rifles mixed, I got the Double Clutch, the next one in the list. Don't have the Sobek yet.

  • The_Iron_Paw
    1 posts

    @ubi-nacho Im having the same issue when playing Far Cry 6 through Geforce Now on the Nvidia Shield TV unit. It happens to both the Nvidia shield controller and also the xbox one x controller. The Left Trigger is registering as the right trigger for both units. When playing it on my PC however (installed on the PC) I have no issues using the xbox one x controller at all

Suggested Topics