ubisoft discussions

Quick Suggestions

  • 12 Likes/279 Replies/11850 Views
    DrWest644
    15 posts

    They've done something to it?...But they haven't fixed it...FFS!!!

  • CostaBunny
    10 posts

    @ubi-milky erm; That sounds like corporate bs to me! So many players here, with all levels of hardware and all started getting the awful performance following the exact same update and you are seriously asking us to believe that its OUR fault somehow? Please tell me you don’t actually buy that for a second?

    I think enough is enough and I would like you to please reply to us mugs in this thread how to get a refund on this now broken and rather shoddy product that is simply not performing up to it’s expected standards.

    Thank you

  • TheLastElite
    29 posts

    Turning off HD textures fixed this issue for me.

  • Alex_ShKID
    14 posts

    Update 1.4.1. Problem not fixed. Ubisoft money back!

  • Ubi-Keo
    Ubisoft Support Staff 4744 posts

    Hi @emerald267 @mickharnas apologies for the late response.

    Thank you for the video and information provided.

    @emerald267 Can try disabling the Ubisoft Connect overlay if it is enabled then play the game for a while to see if you still experience the FPS drops.

    @mickharnas Can you please confirm if you notice the FPS drop whilst in 3rd person view and can you also try the following if you haven't already done so:

    • Disable the HD textures if there are enabled then play the game for a while to see if you still experience FPS drops
    • Then can you disable the Ubisoft Connect overlay if it is enabled then play the game for a while to see if you still experience the FPS drops


    @altenbach @Dave3d07 @CostaBunny @Eddyleon21 @shawn_dougherty @DrWest644 @Mipala @Alex_ShKID I can understand your frustration, however to investigate this issue further we would need to ensure that you have done all of the PC troubleshooting and to provide a video demonstrating the FPS drops in-game along with your system information. If you could also try those two steps that I have mentioned above to see if that makes any difference.

    Official Response
  • angelnieto07
    3 posts

    @ubi-keo Please, when you stop laughing at us !!! The solutions that already gives us previously tested (in other posts of this forum about FPS fall and more than three months ago they gave us these advice and have not worked). Between ordering videos of the ruling and giving us as a solution to follow the same tips that do not work since December without being able to play correctly to the game. The problem is since I installed the December patch and do not seem to know how to fix it. Give a valid solution or return money and do not play more with us. For my part I do not intend to buy again, never a Ubisoft game, slabs always come out with failures and bugs, this is the drop that has filled the glass. To all those who ask me that such is the game, I respond that they do not buy it and tell them the case. I can assure you that no friend of mine has bought the game after telling you my experience. As I already told them: goodbye ubisoft.

  • CostaBunny
    10 posts

    @ubi-keo OK so you want me to disable stuff that worked fine up to the December patch, as you think it might be my system? Nah thats just side-stepping the issue. As so many here have the same issue then it obvious there is a problem with the game introduced in December by you. If my system somehow downgraded itself while I wasn't looking, then it doesn’t seem to have affected any other title including the mighty Cyberpunk 2077!

    Please stop insulting us with these first line tech support questionnaires and get us some proper Dev support in here, I just want to continue playing my campaign, but your shoddy software won’t behave.

    For the record I don’t use the overlay and tried the HD Texture. No change

  • altenbach
    71 posts

    @ubi-keo I just upgraded to 6.1.4.1 and was able to play without experiencing any slowdown. Did all insurgency checkpoints, air-defenses and bases on the map (red). In previous versions it took at least two restarts to get that far! (not done the special ops and final mission, will try tomorrow). Could it be it is solved? Fingers crossed!


    Edit: No, the slowdown happened again, but clearly seem to take significantly longer now... (anecdotal evidence)

  • TheLastElite
    29 posts

    For me, this issue starts when I turn on HD textures and only this setting, am I the only one?

  • apz-s
    2 posts
    This post is deleted!
  • altenbach
    71 posts

    @thelastelite Its not really HD textures, but poor VRAM management. If you have a graphics card that can support HD textures (>11GB VRAM!!) and then don't use most of it, it might take days of playing until the glaring memory leak gobbles it all up. Users with less VRAM (e.g. 4GB) just experience it much quicker.

  • Kondor6666
    3 posts
    the problem is not fixed. Ubisoft IT are bad


  • TheLastElite
    29 posts

    Ok good to know, I just hope they don't come back saying I need more VRAM because the game runs great with HD textures on with the amount of VRAM I have.

    I guess the ball is in ubis court to figure this out and I hope they do because the HD textures look good and make up for the old engine the game is using.

  • TheLastElite
    29 posts

    @altenbach Yea I noticed it was better and if it dropped it recovered pretty quickly but it's still not fully fixed.

  • DrWest644
    15 posts

    @thelastelite 3 Months now and Admin have barely responded...Just keep asking for specs/video's and don't even comment again...Shocking!

  • mickharnas
    29 posts

    @altenbach

    I've decided to buy RTX 3060 with 12GB VRAM. Problem is solved now. Game runs perfectly with HD Texture Pack... So... still my opinion is negative about supporting in Far Cry 6, required minimum 11GB VRAM for HDTP is completly misunderstanding...

  • TheLastElite
    29 posts

    @mickharnas You bought a new graphics card to fix a bug in one game?

  • mickharnas
    29 posts

    @thelastelite

    Not exactly, for also Cyberpunk with RTX and DLSS for Polish new game Dying Light 2. My GTX 1660 I bought 2 and half years ago and I decided this is good time to upgrade my GPU. That's all, does not change the fact that I stay massive dissapointed UBI help desk and the matter of fact the HDTP needs sick 11Gb VRAM requirment. This is embarrassing.

  • JigSaw941605
    2 posts

    Please don't tell me is a hardware problem, stop saying jokes like this, with 16gb ram, AMD Ryzen 5 5600H and 3050Ti and also I DON'T even have HD Textures ON, after a 20 minutes absolutly perfect playing, game just suddently didn't like anymore the hardware, c'mon, really ? 🤣

    I wouldn't say anything if the game would start working very lagging at first second, but when the game work perfectly fine 20 minutes or maybe even more sometimes, and then from nowhere FPS drop drastically, that's defenetly not an hardware issue.

Suggested Topics