ubisoft discussions

Quick Suggestions

  • 12 Likes/279 Replies/11803 Views
    1 posts

    Hey guys, been experiencing the same issue as everybody here. So frustrating, happens randomly within a few minutes of gameplay. Can be from menus, fast travel or cutscenes. Makes the game borderline unplayable, having to restart every couple of minutes. This really needs to be on Ubisofts radar, I want to play the game I payed for. Can confirm the hotfix did not solve this problem. Here are some videos to demonstrate

    https://streamable.com/toc72a: (https://streamable.com/toc72a)
    https://streamable.com/zuqhl8: (https://streamable.com/zuqhl8)

    My specs are:
    Ryzen 5 3600
    1650 Super 4gb VRAM
    16GB Ram

  • mickharnas
    29 posts


    Unbelieveable how broken is that game. Ubisoft go quickly to the work... We payed for game and want play!

  • JudgeHazzard
    2 posts

    I'm experiencing the same issue as everyone else. I was getting 50 to 60 FPS on ultra at 1080p, sometimes a dip to 40 or 45 but would quickly go back up, but then it starts frame dropping to an extreme degree within 15 to 20 minutes, and can sometimes seemingly initiate when going through menus. Not only is does the VRAM usage vary seemingly per visit to the settings, but they are abnormally high. The explanation above about textures seems plausible. Would like it to be fixed so I can play more than 20 minutes before inevitably having to restart the entire game.

  • CinejuMisu
    13 posts
    This post is deleted!
  • CinejuMisu
    13 posts

    I have the same problem. I'm also experiening this strange LAG bug.
    Before the update everything was perfect except the blurry textures. Now the blurry textures problem is solved and now this problem...
    (everything on my system is up to date)
    After 30 - 40 minutes of gameplay the FPS drops from ultra 55 - 60fps to 5 - 10 - 15 fps.
    I tried adjusting the video quality settings but that did not resolve the problem. This happens even if I play with the lowest quality settings.
    If I restart the game the problem goes away BUT only for another 20 minutes, after that the FPS drop again.
    There were times when the FPS dropped even after 5 - 10 minutes of gameplay, for example at the start of certain missions or cutscenes or in different areas of the map and there were times when accesing the map or the arsenal would cause the FPS to drop to 10 - 15 fps after that.

    I'm sure it's not the hardware because this is happening even with the lowest quality settings and on ultra I can run the game at 55 - 60 fps.
    (I'd like to mention that the GPU temperature never goes above 59°C in full load.. I thought that maybe overheating is causing the problem but it is not the case! The moment when the stuttering/fps drop occure the GPU locks at 100% usage until I exit the game.).

    Hope this will be fixed with the next update!

  • FerociousRhyme9
    18 posts

    I gave up. If you try to run benchmark a few times you get back again 2 fps and no matter what you change. It looks awful, fidelity turned on as well and you get a few more FPS, but that's it. This game is broken, unplayable and I am huge disappointed. I am with Ubi for so many years and buying the best versions possible, but I am done with you. Cannot fix your games, cannot test them by yourself, you release alfa version and hope that with patches you will get it fixed after 3 years maybe. I will buy your games only when they will be on sale and hopefully by that time you will get it fixed. It was OK on Ultra!!! A few issues! Now this. Facepalm! Better to watch empty wall. Bye have fun with your alfa version 0.1

  • mickharnas
    29 posts


    Hey man 100% for sure this is not hardware issue, I have all same symptoms like you include 100% GPU usage, point by point. Game is seriously broken, I cannot believe that anyone from UBI still not comment our issues in this thread.

  • mickharnas
    29 posts


    Yes, this is massive disappointment, first Far Cry I'd ever seen which is terrible [censored]... The question is how much time UBI need to fix your shoddy work. Unbelieveable.

  • CinejuMisu
    13 posts

    @mr_miki_1 hei man, same problem here. I hope they will fix it soon. It seems that there are a lot of people who are experiencing this issue. The game is unplayable after 20 minutes of gameplay, frame rate drops from ultra 60 fps to 15 fps until the game is restarted. After restarting the game you don't get to play another 20 minutes and the problem is back. Messed with all qraphics settings and nothing helps.

  • CinejuMisu
    13 posts

    @mickharnas yeah, I really hope they will fix it soon. It seems there are a lot of players who are experiencing this issue after TU3.

  • CinejuMisu
    13 posts

    @josh_0000 hey man, I can confirm that I have the exact same problem with the exact same symptoms like a lot of other players after installing TU3. Restarting the gamw would only fix the problem for another 15 minutes then FPS drops again. Hope they will fix it soon! The game is unplayable

  • altenbach
    71 posts

    Yes, they fixed a few things (e.g. the wildly changing VRAM requirements every time you go to the settings), but the problem is definitely NOT fixed!

    In my last session I was able to do the Trejo mission and the new special ops at good frame rate. Then I went to the workbench to look at the new dashboard thingy and everything was again slow as molasses in winter. (4-7fps). There is no specific action that triggers the permanent slowdown. It just happens out of the blue after a random amount of gameplay, requiring a restart.

    There has to be an easy fix! No other Ubisoft game has that problem. Somebody messed up! Unplayable!

  • mihaidanciu
    2 posts

    Over 2 weeks have passed since the faulty UPGRADE where the game freezes after a few minutes of playing, and yet not being provided with a goog Upgrade!

    This is not OK!

    For the developers, please resolve the issue.

    I have the following system:

    AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx   2.30 GHz
    16GB RAM

  • Ubi-Oxavo
    805 posts

    Hello @issi5, thanks for providing the new link to the files and apologies for not getting back to you sooner. I understand this is frustrating experience, however I would kindly ask you to avoid using a bad language as we are here to help.

    Could you please check and confirm that issue has not been resolved following the December 15th hotfix and you are still experiencing a massive FPS drop? If the answer is "Yes", please let us know so we can create a support case for you as we'll need to get some system files (DX Diag and MSINFO) from you to look into this further. You can also follow @Bladerunner4077's advice and post a video link here.

    @scottnet5 and @snuggles1911 could you please confirm if the issue remains in place after the recent patch?

    @rizz768 we appreciate your input. Thanks for going ahead and asking all the questions.

     Feel free to get back in touch if you need us.

  • datahouse1968
    3 posts

    The only way i find is stop the mission, return to desktop (principal menu in FC6) load the savegame and the normal fps returns... for some minutes. In general the drop for me is in missions with a lot of soldiers (ex, take a base) or when i return to a central base (Finca Montero, etc). In version 1.0 the game was a pleasure, fine perfomance. Now, im gaming for second time as male Dani Rojas and, after they got Danny Trejo's missions in (the december upgrade), performance went to hell.
    My PC: I5 9400f, RX 550 4GB, 16 GB Ram, playing high / ultra to 28 fps (but with this, the fps drops to 12!)

    8 posts

    still no help for the massive fps drop to 10 fps or less guys no solution for this game i want to money back i guess at this point ubisoft sleeping a until 2022...

  • altenbach
    71 posts

    Still runs great for a short while, then becomes unplayable (<10fps!). This weeks insurgence took me 4 exits to the desktop to bring the speed back to normal for a while.

    • Session one: One checkpoint at great speed, one base at great speed, slow again, restart.
    • Session two: the other checkpoint at great speed, the other base at great speed, slow gain, restart.
    • Session three: the special ops at great speed. slow again, restart
    • Session four: final base at great speed. Slow gain. quit and in no mood to go back. Tedious!

    Come on, Ubisoft! Fire some of the rookies and get an experienced programmer team together to track this down. It's not rocket science!

  • Supertraxx25
    7 posts

    @ferociousrhyme9 I have written multiple times concerning this issue and just applied yet another update hoping they would address the issue, but they have not. Still getting the same low frame rate errors and even sometimes the VRam readings are reading 8.79333 instead of 8.79 like it was doing and it does this inadvertently at varying times. I have noticed that if you go to the maps and click over to the journal quickly, provided you have the fps up and running as I do, you can see the fps go from 13 fps to 144 fps. If you go back to the game, it will drop down to 30-70 fps but drops back into the teens after a short period of time. This is not a hardware problem and happened after the update in early December as it ran fine before that. For some reason, UBI is not answering these threads nor do they seem to be interested in fixing and addressing this issue. I will no longer be purchasing any game from theme until this is fixed or they refund my money.

  • mickharnas
    29 posts


    Everybody report same issue, UBISOFT what are you waiting for??? Where is the FIXXXXXXXXXXXXX??? Game after several minuts is completly unplayable with or without enabled HD Texture pack over and over and over again... VRAM looks like leak, GPU suspends at max power, game hangs on 12-13 FPS - what the hell is going on after the last update? UBI answear me or give me back my money...


  • datahouse1968
    3 posts

    hahaha! Ubisoft support returns in January... meanwhile we continue with the unbearable lag...

Suggested Topics