ubisoft discussions

Quick Suggestions

  • UNSOLVED Bug: Glitchy/blocky shadows when Additional Field Of Vision is set to 25 and Shadow Quality on Very High

    2 Likes/15 Replies/2340 Views
    Dextor41
    Original poster 6 posts

    Hi. I've been having this bug ever since I've started playing this game in 2019. When I set Additional Field Of Vision to anything above 5 (I use 25 because otherwise the game gives me a headache) and Shadow Quality to Very High, I get corrupted sun shadows. Not all sun shadows are glitchy, only some shadows of trees, buildings and vehicles. Once I reduce Shadow Quality to High, problem is gone (but I don't like shadows on High - too low shadow map resolution). The lower I set Additional Field Of Vision to, the less glitchy the shadows are. The problem is entirely gone when Additional Field Of Vision is set to 5 or less (but I just cannot play the game with such a low FOV, it gives me a headache). The game also freezes and crashes from time to time (about every 2 hours of playtime), but that is a different topic.

    Screenshots of glitchy shadows: https://imgur.com/a/BGz729H

    This has been happening on several PC's I've owned and on several clean Windows 10/11 and game installations. Also it does not matter if I run the game on DX11 or 12. Resolution I use: 2560x1440, 165 Hz

    Current PC: Ryzen 7 5800X, RTX 3080 Ti, 32GB RAM, Windows 11 (previously Windows 10)
    This was happening on all my previous PC's with following hardware: Radeon RX 6800 XT, RTX 3070, RTX 2080 Ti, RTX 2080, GTX 1080, Core i7-8700K, Core i9-9900K

    I do not have anything overclocked, do not have any overclocking or RGB-related software installed. Have all the latest Windows updates and the latest graphics drivers.
    The buggy shadows are much worse when sprinting.

  • Contrary to popular belief, Lorem Ipsum is not simply random text. It has roots in a piece of classical Latin literature from 45 BC, making it over 2000 years old. Richard McClintock, a Latin professor at Hampden-Sydney College in Virginia, looked up one of the more obscure Latin words, consectetur, from a Lorem Ipsum passage, and going through the cites of the word in classical literature, discovered the undoubtable source. Lorem Ipsum comes from sections 1.10.32 and 1.10.33 of "de Finibus Bonorum et Malorum" (The Extremes of Good and Evil) by Cicero, written in 45 BC. This book is a treatise on the theory of ethics, very popular during the Renaissance. The first line of Lorem Ipsum, "Lorem ipsum dolor sit amet..", comes from a line in section 1.10.32.

    Contrary to popular belief, Lorem Ipsum is not simply random text. It has roots in a piece of classical Latin literature from 45 BC, making it over 2000 years old. Richard McClintock, a Latin professor at Hampden-Sydney College in Virginia, looked up one of the more obscure Latin words, consectetur, from a Lorem Ipsum passage, and going through the cites of the word in classical literature, discovered the undoubtable source. Lorem Ipsum comes from sections 1.10.32 and 1.10.33 of "de Finibus Bonorum et Malorum" (The Extremes of Good and Evil) by Cicero, written in 45 BC. This book is a treatise on the theory of ethics, very popular during the Renaissance. The first line of Lorem Ipsum, "Lorem ipsum dolor sit amet..", comes from a line in section 1.10.32.

    Contrary to popular belief, Lorem Ipsum is not simply random text. It has roots in a piece of classical Latin literature from 45 BC, making it over 2000 years old. Richard McClintock, a Latin professor at Hampden-Sydney College in Virginia, looked up one of the more obscure Latin words, consectetur, from a Lorem Ipsum passage, and going through the cites of the word in classical literature, discovered the undoubtable source. Lorem Ipsum comes from sections 1.10.32 and 1.10.33 of "de Finibus Bonorum et Malorum" (The Extremes of Good and Evil) by Cicero, written in 45 BC. This book is a treatise on the theory of ethics, very popular during the Renaissance. The first line of Lorem Ipsum, "Lorem ipsum dolor sit amet..", comes from a line in section 1.10.32.

  • Adrian-11
    866 posts

    @dextor41

    Delete the two shader caches in Documents/My Games/Division 2 folder.

  • Dextor41
    Original poster 6 posts

    @adrian-11 Tried that, it did not help.

  • RAGE_THERAPY
    69 posts

    @dextor41 I don't adjust the defaults for the FOV and I also experience this blockiness issue in-game. And this is with ULTRA settings across the board. Add buggy shadows to the list of game engine issues. I have a feeling that it comes and goes based on the game build and changes via the weekly maintenance and/or title updates. (or a driver issue if the fault is with the Nvidia or AMD GPU driver)

  • Ubi-Viral
    Ubisoft Support Staff 2298 posts

    @dextor41 @RAGE_THERAPY Hey! Sorry to hear that you are both experiencing this issue with the shadows.

    Thank you for providing your system specs @Dextor41 and thank you for the images and troubleshooting that you have done.

    Do you both have Screen Space Reflection Quality set to on?

    Additionally please try verifying your game files by following this guide here.

    If this does not work, please let us know.

    Thank you.

    Official Response
  • RAGE_THERAPY
    69 posts

    @ubi-viral SSR is NOT an option in the Divison 2 graphic settings. As I said I run everything on ULTRA. And NOTHING works from the guide. I have 3 different systems that have all been wiped with clean installs across the board. This is simply an issue unaddressed by the Dev team that remains at Massive Entertainment, along with the freeze/crash to desktop issues captured in 37 forums pages.

  • Dextor41
    Original poster 6 posts

    @ubi-viral Hi! If by screen space reflection you mean "Local Reflection Quality", I have that on Very High. Then there is "Reflection Quality", which I've had on High and now on Medium, occasional shadow corruption is present with both settings (not sure why shadows would be affected by reflection quality but I am no videogame graphics expert). And yes, I have tried verifying the game files several times, along with several clean installs of the game, even a few complete drive formats and clean Windows + games installs, on different SSD's. Nothing helped.

  • Ubi-Viral
    Ubisoft Support Staff 2298 posts

    @rage_therapy Thank you for your reply, apologies I did mean Local Reflection Quality as pointed out by @Dextor41

    In regard to the crashing issue this is a known issue and is being looked into.

    @Dextor41 are you able to set the Local Reflection Quality to off or even on the lowest? Does it make a difference?

    Official Response
  • Dextor41
    Original poster 6 posts

    @ubi-viral Hi, just tested setting Local Reflection Quality to both "off" and "low" and it did not help, glitchy shadows were still present.

  • Dextor41
    Original poster 6 posts

    Hi, is anyone looking into this? Here is a video I recorded showing the glitch. Also it shows how it is 99% fixed by lowering shadow quality to High: '>


  • Ubi_Plush
    Ubisoft Support Staff 364 posts

    @dextor41 Thank you for the video. This issue is being investigated, and I'd like to get a bit more information to help. Would you confirm that the graphic issue is reproduced when all nonessential programs are disabled? I recommend a clean boot: (https://ubi.li/aHpuK) to test this.

    In addition, the shadow rendering has no noticeable difference among Windows 10 or 11?

    Official Response
  • ch3stbreaker
    3 posts

    Hi all,

    similar to @RAGE_THERAPY I just wanted to chime in that I also recently noticed strange behavior regarding shadows that I didn't notice before.

    Using the DX12 renderer, Ultra (unmodified) settings on an 1080Ti. Latest (497.29) nVidia drivers, as well as some older (466.11) drivers based on some wild goose chase from a reddit thread.

    https://imgur.com/a/SxnPYOL

    Also got bad Shadow Acne in Manny Ortegas office on the Desk Lamp. Didn't have that previously either.

    Just thought I leave this here and hope someone gets around fixing this.

    Best regards.

  • Ubi-Milky
    Ubisoft Support Staff 2313 posts

    Hey RAGE_THERAPY thanks for contributing.

    I can see how the shadows do not appear correct on the desk, thank you for illustrating this with your screenshot.

    If you have any more examples of this, do feel free to post them in this thread - I will pass this on to our team investigating visual glitches with shadows. Thank you for sharing some of your settings with us and set up, this is very helpful.

    Official Response
  • Dextor41
    Original poster 6 posts

    @ubi_plush Hi! I have tried running a clean boot - disabled all startup programs and non-Microsoft services as per the guide you provided - but the issue is still present, some sun shadows still appear blocky and glitchy, no change. As for Win10/11 difference: there is no difference, the glitch is the same on Windows 11 as it was on Windows 10.

  • Ubi-TheBerry
    Ubisoft Support Staff 2385 posts

    Thanks for getting back to us @dextor41 , appreciate it.

    We'll note this to the team.

    We don't have any updates just yet, but will keep you in the loop as and when we hear more.

    Thank you for your help with this and your patience!

    Official Response

Suggested Topics