ubisoft discussions

Quick Suggestions

  • SpirantCrayon22
    2528 posts

    I tried a couple of things. A scroll just gives a mastery point (one more test there but it is not going to work). Assigning points as soon as they're avaiable does not work. The power cap needs to be reset.

    Curious that there's more Raven skills than Bear or Wolf.

  • WildHunt
    234 posts


    I have everything on the skill tree unlocked apart from one skill (see screenshot). I should be able to gain 1 more skill point when I level up so I can get that last skill, but when I do level up I am only able to get mastery points. I've tried to refund a few skills and buy other skills, then level up, but I always end up in the same situation where I have 1 skill left locked and I never gain a skill point to unlock the skill tree 100%, it always goes to mastery points. I've verified my files, the problem persists.

  • Hern_the_Hunter
    32 posts

    I experienced a missing skill this evening. On Tuesday evening I decided to get the Valhalla quests out of the way, while avoiding the crossover quest. My plan was to play the Odyssey crossover first. However last night I also wanted to get the Valhalla daily and weekly quests out of the way.

    While in Glowecestre I go up a level, so I make a beeline for the shop to buy a Scroll of Knowledge, adding all 3 skill points to the 3 new Raven skills. I spent this afternoon playing Odyssey, but this evening I went back to Valhalla to do the 2 weekly quests going up another level, again in Glowecestre.

    Both skill points were added to the 2 new skills in the Wolf tree. Eventually I end up in Lincoln where I go up yet another level. However instead of gaining 2 skill points, I'm rewarded with 1 Mastery Level point instead. I go to the Skill Tree only to discover that I've got 1 skill point added in as well. I added it to the Hammer in the Bear tree, but that still leaves a shortfall of 1 skill point for the Dane axe skill. Not to mention 1 point short of the new potential max Power Level.

  • bradcuster
    14 posts

    @avenger237 same thing is happening to me. I’m stuck at 475 skill points and my last 2 level ups have rewarded mastery points and I can’t unlock the last node. I’m on PS5.

  • YazX_
    193 posts

    Yep, you start getting mastery points instead, i believe its a bug on all platforms not only PC.

  • HddnDrgn0321
    6 posts

    @ubi-auron I started getting Mastery points and then they added the new update which opened up seven new skill point spots. However, the game then gave me six skill points and then started giving me mastery points again so I cannot get the last skill point spot which is for the Dane Axe. Rather frustrating.

  • Silent_Strike16
    1 posts

    @hern_the_hunter I have the same glitch on PS4. I was in Glowecestrescire when this happened as well. I'm stuck at power level 475 (one short) with 18 mastery points.

  • Hern_the_Hunter
    32 posts

    @silent_strike SNAP😀 I also play the game on a PS4. On top of that I'm also stuck on power level 475. I even have 18 currently unassigned mastery points as well.

  • KalleKa1a
    37 posts

    I'm missing one too and I'm playing on Xbox Series X. Could this have something to do by getting those extra two experience points from the Saint Dennis Tomb which couldn't be used at anything? I'v had those since playing through the Siege of Paris and having all the skill points before I found the tomb and read the Isu text?

  • RCDeschene
    169 posts

    Yep, same here. 475 and missing just one more point for the third new Raven Skill.

  • Raziel335
    6 posts

    I have the same problem playing on ps5

  • bielik01
    1822 posts

    @Ubi-Auron or @Ubi-Supportski
    I guess it's high time to create mega thread for that issue.

  • Robertsonland
    6 posts

    PC here and stuck at 475 and only get Mastery Points going forward.

  • Telefr0g
    1 posts

    Same for me. Maxed out the skill points and now I'm one short for the tree.

  • GhostAgent14
    203 posts

    Same here. At 475 and getting Mastery points. On Xbox Series X.

  • JamesLogan491
    140 posts

    Same on PS4. Not even the scrolls you can buy fixes this. Got to wait for Ubisoft to fix the level cap.

  • ChrisL782020
    3 posts

    Same for me stuck on 475 with one remaining but can only collect Mastery Points.

  • Sammarok
    177 posts

    Same issue here, missing 1 skill point.

  • Yarirong
    4 posts

    This dagger and sickle skill is an existing skill, not a new skill, but it seems to have been reset with this patch 1.4.1.

    Therefore, when resetting all skills, 1 point is not recovered and the base power becomes 2.

    There is a phenomenon that one remaining skill cannot be used even with 475 power.

  • bielik01
    1822 posts

    @yarirong that one point must be somewhere else. But we all are unable to gain that extra skill point to fill the whole tree.

Suggested Topics