ubisoft discussions

Quick Suggestions

  • VegasHeart
    104 posts

    @ubi-borealis I dont met this issue more then months,but currently I have a different one,but when i spoke with support using chat they said that problem are releated to this one,because its similiar.They also recommended me this topic for posting.
    After entering my password and login ubisoft launcher show me message:Intializing download and thats it.After that it stuck forever and nothing happens,game wont launch.That a 3rd day when I cant enter a game.
    Im not sure if that related or not,but that possibly could be for Ukraine only,since there was added ENG subs/menu.Probably some conflict between different game versions,because previously it was RUS subs/menu only.
    This problem also noticed with Rainbow Six Extraction,game also wont launch,but there you dont have message:Intializing download,but it also stuck with neverending loading.
    Ubisoft knows about this and nothing was fixed.I also informed Nvidia about that,but they also did nothing.That a shame guys,such inactivity from both support teams.

  • asm0dium
    17 posts

    @vegasheart Are you still having this issue? I had it too and I believe it was because Nvidia didn't update game on their servers so Ubisoft Connect client was updating the game every time when you tried to launch it. I haven't this issue for two days, after some update on GeForce Now site - probably they updated the game on servers.

    Also, I can confirm that issue from topic is resolved, I just played 6th or 7th session during last 24 hours.

  • damontor
    1 posts

    I am wondering why this is marked as resolved.

    I Just bought Valhalla today on Epic Games and I wanted to launch it via Geforce Now. I receive the following error: An epic games services is currently not available, please try again later. I tried again later, and later, but no difference 🙂

    So launching Assasins Creed Valhalla via Geforce Now seems not to work and therefore I cannot play the game. Please fix. I love action rpgs and i never tried Assassins Creed and wanted to give it a try. But it seems that this issue is ongoing since some month now...
    When will the issue been solved?

    I have now 14 days left in which I can hand back the game to the reseller.

    Best regards

  • Ubi-Mushy
    Ubisoft Support Staff 835 posts

    @vegasheart Sorry to hear about the continued issues. Since @asm0dium mentioned the issue went away for them, can you confirm whether you're still unable to open either game?

    @damontor Welcome to Discussions! It sounds like you may be running into a different issue, as you're receiving a different error message. Can you make sure that your Ubisoft and Epic accounts are linked, then try launching the game once more?

    Official Response
  • adkauth
    1 posts

    @ubi-borealis I still have this issue. Impossible to launch, it crashes as soon as the loading screen starts.

    I see this is marked as resolved but what's the solution?

  • Ubi-SpaceCats
    Ubisoft Support Staff 938 posts

    Greetings @adkauth and I do apologize for the frustration this has caused. Our teams are currently working on resolving this issue. When there is an update to this, it will be posted here on our News & Announcements page as well as the Assassin's Creed Twitter.

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 6041 posts

    Hello there!

    The dedicated teams have confirmed that this error encountered when launching Assassin's Creed Valhalla via GeForce Now should now be resolved. We will now be locking this thread.

    If you are having any trouble launching your game via GeForce Now, please don't hesitate to create a new thread so we can look into this further. Please include any error messages you may have encountered, as well as what troubleshooting steps you have tried yourself, as this will be helpful for further investigation.

    Thanks! 😊

    Official Response

Suggested Topics