ubisoft discussions

Quick Suggestions

  • 6 Likes/340 Replies/14429 Views
    Moon.Hawk
    16 posts

    @juuzousuzuya01 I'm having the same problem. I spent 3 days trying to figure out where to find a one-handed sword to begin with. I saw a list of where to find them. So I did the Discovery Tour specifically for the short sword reward. Once I got it, I went to a random part of the map and killed a handful of enemies with it. It didn't register. I tried a few more place, and a quest. Still no luck. So tonight, I bit the bullet and spent the 100 coins to get the sword in the rewards section. Killed a few more enemies. No luck, either.

    I loaded my old game from last April, the one with which I finished the game.... Equipped the 2 short swords. Went to Ubretch and killed everyone in sight along with a few wolves on the way. Still not counting in my stats as sword kills!

    I saved and closed the game. Close the Ubisoft Connect app from background in task manager... reloaded the app, reloaded the game. You'd think it might do the trick, but nope, it didn't.

    I give up. I like the look of curved swords, which is the only reason I even tried that hard in the first place, lol. But I've had enough for one day. ^^; Maybe it will update the count overnight. I hope.

  • UbiStorm
    Ubisoft Support Staff 690 posts

    Hello everyone. I'm sorry to hear that you're all encountering this issue with the Basim Challenge, as well as all challenges. Aside from @Moon-Hawk , has this only begun to happen for everyone else today?

    Would everyone also try running the launcher with administrative settings to see if this helps? If not, could you send over some screenshots or video clips of these challenges not progressing?

    Official Response
  • bielik01
    1797 posts

    @ubistorm this counter has been like this for at least an hour now.

  • ArcticWolves85
    9 posts

    @ubistorm are you being serious? A video to show you that we are killing a whole bunch of enemies and it's not even registering after the first kill like it said it should. Or even better we recruit another players jomsviking and it doesn't count. We really need to show you a video of that?

    How does that not make any sense from our words that it needs to be backed up by video evidence. Makes me think you think we are making this stuff up or lying. We explained it to you properly. Right now the ubisoft connect challenges are not working or registering ANYTHING we are doing in the game.

    I am on Xbox Series X. I have tried loading from an older save still nothing. I have tried going to norway and then back still nothing. I can't complete any of the challenges no matter how hard I try the system is not for some reason registering.

  • EpicLazor
    13 posts

    Same on PS5, also Division 2 challenges aren't registering so it seems to be a Ubisoft Connect issue, not a game issue.

  • HolySiegfried
    1 posts

    For me is now Basims Challenge not working.
    I am killing enemys with valravns claw, but nothing happens. The counter dont change.
    Plattform: XBOX Series X


    Edit:
    After 12h it fixed by it self. I was able to collect the sword.

  • KurganNazzir
    4 posts

    I'm on PS4 and my challenges are also not advancing. I assassinated two enemies and the challenge did not advance. I've killed multiple enemies with a 1H sword, which I've been using for over a month anyway, and neither of the kill challenges advanced. I don't know if this started today because I didn't play yesterday due to Reda's shop being down (i.e. no contracts, which is what I got on to do).

  • lemmie88
    299 posts

    Can confirm. I just poisoned some guys and it didn't register with Eitr's Challenge.

  • czarek90w
    6 posts

    I'm on PC using Ubisoft Connect launcher, already made one topic about it (well, about single challenge that stopped counting), but it seems to be for all challenges, so this stuff is on Ubisoft side not us players, and as you may also know now it happens in like all games from Ubisoft, reported by many players so why any evidence videos needed, that will not tell you anything.

    Also this, happens at the same time, so must be related:

  • JuuzouSuzuya01
    25 posts

    @ubistorm I'm on Xbox one and I'm not sure if it only started today for people because it's been a couple of weeks since I last played

  • Pickl420Rick
    5 posts

    @epiclazor I am also encountering this issue

  • Pickl420Rick
    5 posts

    I have tried more then once with a 1h sword I used the skofnung to kill more then one enemy and It still says i have not contributed to the challenge.

  • MunsterXIII
    7 posts

    I'm on PC same thing is happening here also the challenges page is slow to load / sometimes it times out and I have to retry ...not an issue I was having yesterday.

  • MunsterXIII
    7 posts

    @ubistorm Yes just started today (I'm on PC) but it seems to be across all platforms

  • Sir_Rudi
    10 posts

    @ubistorm Both time-limited and core are not progressing for me, since yesterday or more days.

  • JuuzouSuzuya01
    25 posts

    @sir_rudi yes core challenges too. Thanks didn't realize that at first

  • Moon.Hawk
    16 posts

    @ubistorm I don't know how to make video clips, nor am I fast enough to hit a button for a screen shot while fighting. I have enough of a hard time keeping my poor fingers hitting the right buttons to fight lol. I am administrator on the computer already; I'm not sure what you mean by running admin settings.

    I don't know when it started. I only noticed it today. But I also noticed just now that my assassinations challenge count stopped updating at 50. I have no idea when I got the 50... I'm the type who prefer stealth kills. But I just assassinated a guard from a roof in Leidescestre and it didn't add an assassination to my tally either. I'm still at 50/100.

  • MunsterXIII
    7 posts

    @juuzousuzuya01 Horrible timing I'm 5 Units away from buying Valravn's Claw which should also get me Basim's Challenge but I only have a day n a half to do so IF they fix this in time and don't act like its not happening.

  • Moon.Hawk
    16 posts

    @bielik01 Yeah, the count is still the same as of just now, too. Not updating anyone, it looks like...

  • MunsterXIII
    7 posts

    @moon-hawk I'm stuck at 80/100 on that one

Suggested Topics