ubisoft discussions

Quick Suggestions

  • Yamie13
    4 posts

    I am reporting back after benchmarking every single setting for everything.....


    So in my laptop RBS13 with 1080ti eGPU


    Petty much nothing did a thing, and the reported cpu usage is very wrong....
    But what helped with the stuttering was reducing textures to medium....

    The only explanation I can come up with, its a bus related problem, so the bottleneck is the pcie -> tb -> egpu connection.
    But still see cpu spikes in stutter situations.


    And now my desktop, where the stuttering just disapread without any changes, so I have no idea....


    Still the cpu monitoring is completely broken....
    I am pretty sure, before it was a cpu problem, now its gone without doing anything so, maybe it will be back next time.
    If so, I will report back.

  • Yamie13
    4 posts

    @ubi-froggard
    Also one of the first things I did, and I think VSYNC is also causing this

  • Ubi-Froggard
    Ubisoft Support Staff 3248 posts

    Hey @yamie13

    Thanks for those images and information. Why do you think VSYNC is the cause? Do you only notice it when turned on?

    Official Response
  • Yamie13
    4 posts

    @ubi-froggard
    No sorry, you missunderstood me.
    It was my reply to your suggestion of limiting the fps, what is already archived with vsyn.
    I guess you just wanted to prevent 1000+fps spikes with this, what would cause problems for the cpu, if the gpu is able to.

    So far my desktop system has been totaly fine, with and without SVM, so I can not recreate the stuttering on this system.

    With my laptop+eGPU it was very hard to only use the eGPU. I needed to disable the dedicated GPU (1650) and disable alsoe the iGPU in order to get the newest drivers installes for the 1080ti, but this is a problem on nvidias side.
    Still the game didn't recognize the eGPU, despite using it...
    But a system with 3 GPUs is a chaos anyway, so this is a very rare problem.

    Thanks for the support 🙂

  • Ubi-Thrupney
    Ubisoft Support Staff 3115 posts

    Hey @yamie13 , thanks very much for that clarification.

    We've just had a maintenance that has made some stability changes, so you may be less likely to see stuttering. If you do continue to have any issues, please let us know - we'll be able to help you investigate with the use of some system files in that case.

    Official Response
  • claud1u111
    14 posts

    @ubi-thrupney Nothing changed.

  • Ubi-Viral
    2366 posts

    @claud1u111 Sorry to hear that this issue is continuing. We would appreciate if you could send us your system files via a support case.

    You can find how to do this here.

    An agent will then respond to you directly over the case.

    Thank you.

  • Lyon-CZ
    13 posts

    I am on the same boat, massive stuttering. Running 9700k with RTX 3080, I have not this issue with any other game. There are also multiple reports on Reddit, definitely is something wrong with the game.

  • Ubi-SpaceCats
    Community Representative 940 posts

    @lyon-cz Sorry to hear that you're having difficulties with this. As Ubi-Viral stated, please reach out to our Support Team via one of the links below with copies of your MSINFO and DXDiag, as well as a description of the issue.

    Support Website
    Twitter DMs
    Facebook PMs

    Please make sure you include the username and email address associated with your account if you choose to contact us through social media.

    Official Response
  • Lyon-CZ
    13 posts

    For anyone having this issue too, I was able to fix it. I had to run diagnostic tool on background when playing the game to find the culprit. And it was my CPU. Its powerful enough, its not the issue, but I noticed that frequencies are dropping randomly. And not because of overhating, but it looks like the game was not able to fully utilize it and system just decided to drop frequencies.

    So I went to BIOS, disabled C-states, Intel Speedshift technology (it will prevent CPU from dropping frequencies so easily) and voila - no more random frequency drops and no more stuttering.




  • Soap_52395
    1 posts

    @lyon-cz
    I'm still having this issue on an i9-10900k@ 3.70 / Nvidia Geforce RTX 2070 Super / 64GB RAM
    No matter what how much I lower the setting or the resolution. (in fact it seems to even get worse the lower I go?)
    On my other set up it seems to work great but on this machine I can't get it stable... I really like the game but It's been dragging me through the mud to play it. I've tried to trouble shoot over and over... Only so much I can do myself. (It should work like all the rest of the games on this machine)
    I'm here for one final attempt to make it work.... No one should have to spend hours bending over backwards to play a game. No matter how good it is. It's simply asking too much.
    Any help anyone can provide will be greatly appreciated! Thank you!

  • Lyon-CZ
    13 posts
    @lyon-cz
    I'm still having this issue on an i9-10900k@ 3.70 / Nvidia Geforce RTX 2070 Super / 64GB RAM
    No matter what how much I lower the setting or the resolution. (in fact it seems to even get worse the lower I go?)
    On my other set up it seems to work great but on this machine I can't get it stable... I really like the game but It's been dragging me through the mud to play it. I've tried to trouble shoot over and over... Only so much I can do myself. (It should work like all the rest of the games on this machine)
    I'm here for one final attempt to make it work.... No one should have to spend hours bending over backwards to play a game. No matter how good it is. It's simply asking too much.
    Any help anyone can provide will be greatly appreciated! Thank you!

    Do you have HWinfo installed? Try to enabled logging, play the game and check the log. If you will notice any CPU frequency drops, just go to BIOS and disable Intel speedshift technology (NOT Intel speed step). I also disabled C-states, but I think the main issue was speedshit.

  • Ubi-Gizmo
    2297 posts

    Hey there @Lyon-CZ, thank you for taking the time to help out here. I am glad you found a solution to your situation. Players are welcome to try these steps, but we cannot promote this method. Players would be doing so at their own risk, and Ubisoft Support will be unable to assist regarding any issues that may result from using editing their BIOS.

    If anyone comes across this thread encountering in-game stutters, let me assure you that we will thoroughly troubleshoot the issue. If you encounter stutters on a system capable of running the game, could you please reach out through our Website and share your system files. If you have any questions or run into any other issues, please do not hesitate to let me know.

  • Shooter_Q.Veras
    4 posts

    @claud1u111

    I tried out this method, disabling SMT in BIOS for an AMD processor, after I've had stuttering for the past couple of weeks.

    In my case, system is 3950X, 2070 Super, 32GB DDR4.

    I can confirm that disabling SMT results in smooth gameplay, albeit at lower performance overall for this and other games as well as other programs I use (as expected). Enabling SMT again with a reboot reliably causes stuttering again, no matter the graphics settings.

    Other methods I tried previously without any benefit included lowering resolution from 1440p to 1080p, locking FPS at 144, 120, and 60 FPS, attempting to launch the game with administrator rights, and elevating the process scheduling priorities for the game.

    Just wanted to add a +1 to multithreading being an issue. Hope that is resolved in the future as I have to change the setting again for my usual workflow.

  • Ubi-Gizmo
    2297 posts

    Hey there @shooter_q-veras, thank you for getting back in touch and sharing these findings. I am glad to hear that you are no longer experiencing stuttering issues after modifying your BIOS. If anyone else has any questions or runs into any other issues, please do not hesitate to let me know.

Suggested Topics