ubisoft discussions

Quick Suggestions

  • Tarmorg
    10 posts

    @quadriflax I’ve been having the same problem. I did a bunch of testing and noticed that the error seems to have stopped when I use my ISP dns. For years I’ve used google but for some reason I change it to google dns or cloud flare I get the 0x0004 error. Change back to Verizon and error goes away. It makes no sense but has been working for the last 2 days now.

  • AutumnAlchemist
    1 posts

    Same problem for me. When I go to the store I keep getting the same error code whenever I try and look at items. Ironically if hit I left trigger (I'm on xbox) it'll take me to the page where I can buy helix credits lol, just not to anywhere that I could actually use the credits that have been purchased. Pretty silly, connection is great so idk.

    I've tried all troubleshooting suggestions including clearing cache and full shutdown 😢 so I don't think the problem is on my end.

    Hopefully it'll get solved in next patch I guess.

  • Sho23 0
    1 posts

    @tarmorg exactly the same issue here on series x..also tried the same without succes

  • TripleXxXMan1
    1 posts

    @guest-zejwss2o same issue on Series S. Wish I could play this game I bought.

  • Greybear_one
    12 posts

    .

    Like the Previous user, False Alarm.

    I took the 3 contract (after the last Game update) and I let them expire. But between talking to the Contract Giver and getting the contracts and going back after they expired, I shut down the XBOX for the night.

    Upon relogging in, the Errors were back.

    2 days ago, I decided to try again. The Contracts were available and the Store offers were there. I completed each contract 1 at a time and returned for the next. After all were completed, I still has the Store offers and the Contract Giver would tell me that there were no contracts available presently.

    I Shutdown the XBOX for Dinner. Upon relog in , the Errors had returned.

    What all this tells me is that it is NOT something to do with the NETWORK within my home. Its not the Wifi vs Hardline, its not some settings in my router.

    =============================

    Another User ( @lukasz100nx ) has noted that it is the QUICK START.

    I opened the game and checked the Contract Giver. The Errors were still there.

    Following this Guide: https://appuals.com/disable-quick-resume-xbox-series-x-s/#:~:text=And%20then%20in%20the%20highlighted,option%20Remove%20from%20Quick%20Resume: (https://appuals.com/disable-quick-resume-xbox-series-x-s#:~:text=And%20then%20in%20the%20highlighted,option%20Remove%20from%20Quick%20Resume)
    I disabled the Quick Start.

    Upon Restarting the Game. Yep had to sit through the Epilepsy warning AGAIN. (Please DISABLE THIS or click through-able)

    The Contract Giver was working!!!

    Ive completed 2 more contracts and Im so happy to be 2 away from completing this Quest.

    Ive turned off the XBOX and Ill check again tomorrow, but it appears it is due to the Quick start (which, BTW, Fast Startup in Windows can create similar problems with the OS)

  • Greybear_one
    12 posts

    @lukasz100nx AWESOME. Ill check again tomorrow, but Disabling and Restarting the GAME worked. I did not have to restart the XBOX. Since I now have all the contracts and generally note it after a shutdown to eat or sleep, Ill recheck tomorrow but Im stoked this worked right off.


    .

  • rhlldom1a1
    1 posts

    I was unable to get any achievements even though I finished Ragnarok and saw the credits roll by. No reda, clilck on store and get online-service-error-0x00000004.
    Here is my fix.

    Set xbox wireless to your 2.4ghz, then back to 5ghz, fully exit out of game, restart xbox.
    Now everything works, except I had to go back to a previous save. But Reda works, can view the store and was able to get an achievement.

    Hope this helps out someone else.

  • Greybear_one
    12 posts

    Update....after using @lukasz100nx suggestion yesterday and it worked, I tested it again today.


    So, after logging in today, I had the Same issue, BUTTTTTTT!!!!!!! Upon rechecking the Quick Start, I found that the Game had been RE-ADDED to the Quick Start Menu.

    After disabling it AGAIN. Re-Starting the Game again Fixed it.

    So, this is definitely connected to the Quick Start.

    Now, How to stop the XBOX App from constantly RE-adding this game: https://answers.microsoft.com/en-us/xbox/forum/all/xbox-series-x-how-to-stop-adding-games-to-the/fdd311b1-62a8-4d82-aaaf-be5b851a546d

    .

  • Quadriflax
    8 posts

    @greybear_one

    This used to work for me, but I just came back, quit the game and totally restarted and the problems/errors persist. The first telltale sign is that the "checking add on" screen takes FOREVER to get past. We're talking 3+ minutes. Then I can finally continue the game and the errors will come up as soon as I go to Reza to try and get a contract or buy something.

    Ubisoft support keeps asking about ports. It's not the ports! It's not the ISP! It's not the router! There's something going on at the Ubisoft side of things because literally everything else works. Heck, Reza's store/contracts seem to work sometimes too. If it was a port issue, wouldn't this be the same error every time? I'm not opening and closing my ports here. It's just sometimes it works, but sometimes it doesn't. Seems to be at least somewhat related to Quick Resume, but now I'm still getting the errors even after quitting and starting the game again. I changed absolutely nothing on my end. It's getting frustrating that they can't admit this is a problem with their game. I'm sure it'll start working again at some point (it always seems to start up again at some point), but it's so inconsistent that I'm finding it hard to believe it's my router. If it was, it would be much more consistent/all the time, no?

  • Phantom5827
    2 posts

    @ubi-viral I’ve been getting the 0x00000004 error for a week or two when trying access Ubisoft Connect and the Reda quests. I’ve deleted Ubisoft Connect from my Xbox S and reinstalled. I also unlinked and relinked my account for Xbox. I’ve restarted multiple times. I’m not always seeing the error code now but now Ubisoft connect won’t load via Valhalla. And, it is not updating my hours played or achievements. What do I need to do to fix this? Tried submitting to support but it says chat unavailable and won’t let me send as a message.

  • Greybear_one
    12 posts

    @phantom5827 Try removing the Game from the QUICK START and log back in. Reda should work again. This has worked both times Ive used it in 2 days, in 2 Logins. Problem is that the game RE-Adds itself to the QUICK START and you have to continually remove it each time.

    Word from Microsoft is that you CANNOT disable this feature or stop a game from being added to it.


    .https://appuals.com/disable-quick-resume-xbox-series-x-s/#:~:text=And%20then%20in%20the%20highlighted,option%20Remove%20from%20Quick%20Resume


    .

  • Ubi-Thrupney
    Ubisoft Support Staff 2659 posts

    Hey everyone! I really appreciate your continued discussions with this issue, and all the insights you've shared with each other on the 0x00000004 error.

    While I don't have a specific update at the moment, I can see our teams are continuing to investigate this error internally. In the meantime, please be sure to keep an eye on News & Announcements, where we'll be posting updates as soon as we have them.

    As always, let me know if there are any questions in the meantime.

    Official Response
  • kaiser-10
    1 posts

    I have the same problem, but in my case the game does not load.

    Ubisoft support tells me they're sorry they can't help me, but it is what it is...

    You are thieves.

  • VantyxX
    1 posts

    Hallo erst mal.....

    Ich habe ebenfalls das Problem x00000004

    Ubisof Cconnect funktioniert einwandfrei.
    Die Netzwerk Verbindung ist auch einwandfrei und nicht eingeschränkt.

    Doch ich kann nicht in den Reda Shop um meine Opale auszugeben oder Verträge anzunehmen.

    Ebenfalls kann ich auch nicht in den In-Game Store um Begleiter oder ähnliches zu kaufen. Ich kann nur auf das Feld mit den DLC oder add ons.

    Über Hilfe würde ich mich sehr freuen.

    Vielen Dank schon mal im voraus.

  • Phantom5827
    2 posts

    @greybear_one Thanks for the advice! It doesn’t give the error now but still won’t load connect in game, isn’t logging my game hours and the contract giver works but doesn’t show any contracts or any of my opals. Did you change any settings or anything?

  • Quadriflax
    8 posts

    @ubi-thrupney

    What really gets me is that your support team keeps insisting via my ticket that this is a port issue. If it was a port issue, a lot more things would be broken than just connecting to your servers after a quick resume. I'm not in the habit of opening and closing ports between playing sessions, so why would the game connect and everything work fine, then stop working after a quick resume, only to reconnect just fine after restarting the game? I'm not changing anything in the few minutes this takes, so it's clearly not a port issue, yet you keep insisting it is. There is some kind of connection that isn't re-establishing after a quick resume. So something must "sleep" or disconnect during quick resume down time, then not re-establish that connection (at least not consistently, sometimes it seems to be fine) upon being actively loaded again. How is that related to a port issue?

    I'm no network genius, but I bought a brand new router in January and only ever changed the SSID and the network password. Nothing else was configured differently from default. Literally everything else works. All checks on the Xbox itself say the network is fine. It's only your game here that gives a cycle of 3-4 different errors (maybe more, I stopped paying any attention) after a quick resume, then they magically go away after I restart the game and/or console. So, again, how is that a network/port configuration issue? Can anyone else shed light on this, or is Ubisoft just not able to admit something is wrong here and they are unable to fix it?

  • Whumeister
    3 posts

    What the actual hell is going on here? Absolutely no achievements are popping, key glitch in the mastery challenge still ongoing, no Ragnorak achievements popping? Can someone at Ubisoft acknowledge there is an issue here? I’m loathe to carry on playing until I know all achievements are tracking properly. Unreal!!

  • codeman87
    4 posts

    I was managing getting around this by quitting to title screen and then going into discovery tour. I would then quit back to title screen and it would trigger the epilepsy warning and reset everything. Now, it doesn't matter what I do, I can't access redas dailies or store. Also can't access the animus store as well.

  • Stuballs66 0
    1 posts

    I too am getting the error code 0x0000004. I am on Xbox series s and have tried all the unlinking, relinking, changing my password and checking my wired connection. This is not a playing side issue and it impacts gameplay.
    I tried going to Unisoft.support but that is apparently only doing web chat, however, that function was currently disabled. Meaning that you have a broken game and no access to any support for the players.

    This is my last resort. Please respond with an answer and not a bunch of questions like you have above.

  • Ubi-Keo
    Ubisoft Support Staff 4276 posts

    Hi Vikings!

    I'd like to reach out to you all with an update. The development team have confirmed that this issue when encountering 'Online Service Error 0x00000004' should be resolved with the release of Title Update 1.5.3! You can read the full patch notes here.

    The patch was deployed today, Tuesday, June 28, at 12 pm UTC/GMT, 2 pm CET, 8 am EDT, 5 am PDT, and 10 pm AEST.

    If you are still encountering the online service error after installing the new update then please go through the connectivity troubleshooting for your platform below:

    PC
    Xbox One
    Xbox Series X|S
    PlayStation 4
    PlayStation 5

    However, if the issue still persists then don't hesitate to share an update within this thread so we can notify the development team. When sharing a new report, please can you provide us with the a video which shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the main menu screen.
    • That you are encountering 'Online Service Error 0x00000004


    Additionally, please ensure that you have an up-to-date save file uploaded to the Cloud. The support article here can help you to do this.

    We can then use these reports to reopen the investigation should the issue persist following the 1.5.3 update. 

    Official Response

Suggested Topics