ubisoft discussions

Quick Suggestions

  • thombro911
    1 posts

    Hey, I had this same issue. It comes down to the game not continuing to jump to a cutscene while loading in between and gets stuck. What I did wasn't lowered graphics or any of the other suggestions cause they didn't work mixing and matching or anyway.

    What I did to fix the issue was left my graphics at the maximum(what I use) and put the game into Fullscreen mode but lowered the Refresh Rate/Hz to "24hhz" and it loaded into the next cutscene. (I also priotized the AcValhalla process cause this seems to be drive reading issues).This seems to be an issue with the game itself with how it loads cutscenes from HDD/SSD speed processing cause I used this fix from a suggestion of a cutsecene people had issue with for the very first big boss fight in the standalone Valhalla game's story.

    So anyone out there who runs into this issue and the other options don't work, lower your refresh rate to 24hz but need to be in fullscreen mode for that option to not be grayed out natively. And you can raise the AcValhalla process priority in task manager to High if that combo needs to be done.


    To the Ubisosft support team looking into to this I don't know how this issue would be fixable for the entire game with a quick hotfix update or a full blown update that recognizes there are multi parted cutscenes that should be loaded in full before started the first cutscene. I would guess that would be a bigger update changing code for entire cutscene segments but it seems the issue is the cutscenes that are loaded in multiple segments have a small chance of freezing out and sticking the game in limbo mode of not being able to progress or play until issue runs its course.

  • Ubi-TheBerry
    Ubisoft Support Staff 4838 posts

    Thank you for sharing this @thombro911 , appreciate it!

    The team hope to resolve this in a future patch, however we don't have a date for this just yet, so we appreciate your patience and understanding in the meantime and we'll keep you in the loop when there's news!

    Official Response
  • Ryusennin
    170 posts

    As of update 1.5.2, this game-breaking bug is still not fixed.

    However, as suggested by Thombro911, there is a workaround. You do not have to change your graphic settings or your monitor refresh rate. You need to cap your frame rate at 30 frames per second (console style). I personally use RivaTuner, but it might work with the ingame frame rate limiter. By limiting the frame rate to 30 fps, the cutscene properly ends and the boss fight can start.

    After the boss fight, you can change your fps limiter back to your prefered value.

  • juerau
    2 posts

    @ryusennin Thx. This simple hint was the solution for me as well. After limiting FPS to 30 the fight starts smoothly. Thx again.

  • Guerlot
    1 posts

    Limiting the FPS to 30 before talking to Ivaldi did the trick for me

    NOTE: Lmiting the FPS to 30 while the cutscene is stuck did not fix it. You need to load a game before the conversation with Ivaldi

  • Ubi-Thrupney
    Ubisoft Support Staff 3127 posts

    Hey there @ryusennin - thanks for your post about this! I understand you've found the issue not to be fixed in 1.5.2. Indeed, we hadn't yet managed to get a fix out for this issue, but it is still planned for a future patch. I really appreciate you highlighting the workaround for other players - that's very helpful indeed.

    Hey also to @juerau and @Guerlot , and thanks for letting us know the workaround worked for you. That's really great to hear. We're still pursuing a proper fix for this anyway, of course, but it's good that you've been able to get past this issue in the meantime already 🙂

    Official Response
  • onslaught_1337
    2 posts

    I'm having the same problem and even if i try the workaround of making the gfx low and hit spacebar to skip it's not happening. Can we know when can this be fixed? or is there any way to skip the whole quest and move on?

  • EREKE_kz 0
    1 posts

    I overcame the problem in this way - first I started another quest (Kara's Domain), then I saved near the Grenhellyr hideout. After that, I transferred the game to the SSD drive, updated it to 1.5.2, and ran my save. Walked into the shelter, launched the cut-scene and the bug disappeared, after that the battle with the boss began. If this helps someone, I'll be glad.

  • onslaught_1337
    2 posts

    @ereke_kz-0 mine is already in the ssd and i tried running with low graphics too but it didn't work at all...there are no more quests left for me except this. i'm doing the valkyrie arena now but i returned back and tried and it is stuck... @ubisoft should release a fix. it's hampering the user experience!

  • UbiSushiVamp
    Community Representative 1138 posts

    Hello, @onslaught_1337! I am sorry to hear that the workaround did not help. We do not have an exact date we can provide for when the fix will be implemented, however I recommend keeping an eye out on our News and Announcements section for more updates as we have them!

    @EREKE_kz Hello! Thanks for sharing the workaround you found for this. I am glad to hear that you were able to complete the quest!

    Official Response
  • Ypson110
    1 posts

    I have the same problem and nothing has helped that has been mentioned here. Since the bug is apparently known for months, I wonder why there is no fix yet.

  • ZiomekXD455
    1 posts

    I have solution for anyone who tried all workarounds mentioned here and it still doesn't work. Simply use Nvidia Geforce Now app and lauch game there, beat the boss, watch cutscene, save game and close it. Then launch game on your device and you can continue playing after the boss fight. I hope it will help someone.

  • UbiSushiVamp
    Community Representative 1138 posts

    Hi there, @Ypson110! I am sorry to hear that you are encountering this as well and that the workaround did not help. I appreciate your continued patience as this is being looked into.

    Greetings, @ziomekxd455! Thanks for sharing the workaround you found to complete this quest!

    Official Response
  • AtreidesDuke
    1 posts

    @ubi-borealis

    I lowered the frame rate. I entered from another location on foot. I loaded the save manually.
    Still getting stuck.

  • Ubi-Thrupney
    Ubisoft Support Staff 3127 posts

    Hey there @atreidesduke , welcome to the forums! Sorry to hear you've run into this same issue with Ivaldi.

    As you'll have noted from the previous posts, our team have a fix for this on the way in a future patch. We don't have any ETA for that quite yet, but please keep an eye on News & Announcements for updates. In the meantime, @Ryusennin very kindly shared a workaround that has worked for many players - you'll find it in their post, here.

    Let me know if I can clarify this at all. I hope you've otherwise been enjoying Dawn of Ragnarok 🙂

    Official Response
  • Ubi-Keo
    Ubisoft Support Staff 5305 posts

    Hi Vikings!

    The development team have confirmed that this issue where some players were unable to progress after talking to Ivaldi in Vault of the Ancients quest has been resolved with update 1.6.0.

    If you are still unable to progress after talking to Ivaldi after installing the new update, please don't hesitate to share an update within this thread so we can notify the development team. When sharing a new report, please can you provide us with the a video which shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the main menu screen.
    • That you are unable to progress in the quest 'Vault of the Ancients' after talking to Ivaldi.


    I would recommend uploading your video to a video sharing platform such as YouTube, you can then copy the URL link into this thread. 

    Can you also ensure that your latest save is uploaded to the cloud. If you are unsure how to do this there is a support article that you can check here

    Official Response
  • Ubi-Keo
    Ubisoft Support Staff 5305 posts

    Hi Vikings!

    I am currently doing a routine check-up on the megathreads and I can confirm that the issue where players were unable to progress after talking to Ivaldi in the quest 'Vault of the Ancients' was resolved in Title Update 1.6.0.

    As we have received no reports of this issue since June we will now lock this thread.

    Official Response

Suggested Topics