ubisoft discussions

Quick Suggestions

  • azullFR
    2431 posts


    assuming you are using a console :

    • for PS4 or PS5:

    there is no verification you can do, instead you can reconstruct the database (take care to make a save of all your game files before doing this, using an USB stick for example)
    link (PS5 and PS4 have the same troubleshooting steps) : https://www.ubisoft.com/en-gb/help/connectivity-and-performance/article/troubleshooting-technical-issues-on-playstation-5/000095486

    • for Xbox : as i'm not using one, I can't do better than just giving you these links, sorry :


    in case you are using a PC :

    • for PC (including links related to verifying games owned on Steam or Epic) :


    Good luck to you 🤞

  • pb0806
    1 posts

    I can't talk to Ake...

  • the4anoni
    4 posts

    Like in topic. When I start this mission targets to shoot don't appear.
    My game version is 1.5.1 PC, I have verified game files via Uplay, but issue is still there 😞
    Any way to fix this?

  • jadefairall
    4 posts

    I'm on PS5 with my console and game fully updated to newest versions and am a returning player to the festival - it's so broken :(. Had the same problem with the Yule festival being a returning player which makes no sense as all festivals worked perfectly fine the first year. Have reported to Ubisoft and they said it's under investigation but doubt anything will happen before the festival is over - also tried everything they told me to try and still no luck. They extended the Yule festival but looks like no mention of them extending this one. I love AC but this is getting ridiculous now considering it's happened twice.

  • Ubi-Orion
    Ubisoft Support Staff 1252 posts

    Hey there folks.

    Thanks for your reports on this and apologies that this issue still seems to be a problem for a number of you following 1.5.1.

    This issue is still under active investigation at the moment with the ACV team. As soon as we have an update we can share with you on this we'll return to the thread to let you all know.

    Official Response
  • Ubi-Froggard
    Ubisoft Support Staff 2774 posts

    Hey @jesso77

    I see an issue with it that should already be resolved from having the game updated, so please could you just try reloading your latest manual save/autosave then go to/explore Ravensthorpe until the Ostara Festival is triggered and see if this has resolved it for you? This was a workaround used before it should have been resolved already.

    Official Response
  • Ubi-Froggard
    Ubisoft Support Staff 2774 posts

    Hey @tsurijade

    The issue should have been resolved already but I saw another thread earlier mentioning this too, so I'll merge yours with that one. Please see my answer from that thread and let us know if it helped.

    Official Response
  • Tsurijade
    4 posts

    @ubi-froggard i explained it in my original post that i TRYED everything that the event works for me, but no reload from ANY of my files are working, i reload and explore Ravensthorpe ..... NOTHING happens.....ist really sad iam a player that collects everything from all events ...

  • IceBear1468
    5 posts

    @turtlesquadceo Did it get fixed for you?

  • Ubi-Froggard
    Ubisoft Support Staff 2774 posts

    Hey @the4anoni

    I'm sorry to hear this. I can't see it being a known issue at all, so would you be able to capture a video showing what you see please so I can get this reported to be looked into?

    Please also make sure to have your save uploaded to the cloud and we can pass on a copy of that to the dev team too.

    Official Response
  • Kingj1200
    5 posts

    @ak_amarantha no your not the only one. i check this twice a day and have been having this problem since the festival started. all i can get is the eggs and i only got 3-4 baskets. no festival, or the ability to finish quests for it either. i dont know if anyone else is having the issue with this and not being able to do the mastery quests either, but i havent been able to do anything regarding the updates after dawn of ragnarok. all i can do is the dlc's and thats about it ( i have completed everything else except the river raids).

  • Ubi-Borealis
    Ubisoft Support Staff 6078 posts

    Hello there,

    I've merged some similar threads about being unable to participate in Ostara due to floating/invisible items, and being unable to interact with NPCs and complete tasks into this ongoing Megathread. I apologise if any ongoing discussion has been disrupted by this merge. By creating a single thread regarding this issue, it helps us to keep all information and updates from an investigation in an easy-to-find place.

    I would like to reach out to you all with an update from the dedicated teams. You can read their full statement regarding the investigation into the Ostara Festival below:

    We are aware of ongoing issues affecting the load-in of the Ostara Festival for some players. Following a thorough investigation by our team, it will not be possible to resolve the issue for all impacted players. For some users, the Ostara Festival will function as intended after installing the game to the latest Title Update (TU 1.5.1) and reloading a save game dated from April 21 or prior.

    The next Title Update (TU 1.5.2) will return Ravensthorpe to a normal state for all impacted players experiencing ongoing issues with their settlements. This TU will be deployed in May.

    We thank you for your patience and understanding on this matter.

    As the dedicated teams have confirmed that it will not be possible to resolve the issue for all impacted players before the end of the Festival, we will now be marking this thread as "Resolved" as a resolution has been provided by the dedicated teams.

    I understand that this may not be the update some of you were hoping for, and I would like to apologise for any impact that this issue has had on your gaming experience. I'd like to reassure you that the Player Support team have forwarded all of the feedback that has been shared within this thread to the dedicated teams, so they have visibility on this.

    If you have any additional thoughts or feedback you'd like to share regarding Ostara and the ongoing investigation, please feel welcome to post them within this thread.

    Any updates regarding TU 1.5.2, including any confirmed ETAs for this update's release, will be posted within the News & Announcements forum, so I recommend keeping an eye out there for more information about this.

    Thank you 🙂

    Official Response
  • AntonioSc4
    5 posts

    @ubi-borealis Not even I was able to attend the Ostara festival due to the bug, even though I am in Ravensthorpe, it constantly asks me to return to Ravensthorpe and does not start the holiday. From what you wrote, the bug cannot be solved and therefore we will lose the opportunity to participate and win what was offered there (weapons, etc.) right? The festival will not be continued for another period of time, as happened with the previous one, due to the problems that have been there, am I right? Thanks.

  • the4anoni
    4 posts


    My save is uploaded to cloud too.

  • MisthiosKiller
    3 posts

    The entire event is bugged for me:
    1- there is an empty piece of land where the fighting ring is supposed to be. This means I don’t have access to the brawls, additionally, other quests like egg hunt is also bugged because one of the baskets is floating mid-air and I cannot reach it. I realized this is due to missing items from the brawl arena that the basket is supposed to be resting on.

    2- for the mission involving lighting fires for Ake, I lit all 8 and cannot speak to Ake to complete the mission. The quest marker is above his head but no matter what time of day I approach him, there is no “talk” prompt.

    3- twirling targets is useless as well, when I speak with Thyra to start the activity, it loads and there are no targets to shoot. I have to manually reset to the options menu to exit the mission.

    I tried resetting, checking for updates, reloading, changing time, doing other missions. Nothing works. The sad thing is that the little free tokens you get at the start aren’t enough to even get a piece of gear. So this entire festival was useless for me. I realize this is an issue for everyone since this festival launched and most people just stopped playing for its duration. This is really sad that players miss out on gear they would otherwise have to spend real money on, just because Ubisoft and their developers can’t release a working event.

  • jadefairall
    4 posts

    @ubi-borealis I understand they can’t fix it in time but that’s not fair for the people who haven’t been able to access the limited time raven and weapons as I would have completed enough quests to receive the items if I could access the festival so what are the team doing to resolve that part of the issue?

  • Mortuus_12
    1 posts

    I just want to post here to have it in writing that I am experiencing this issue as well. I am on PS5 and I have not been able to participate in the event and I also can't find the event vendor to spend the few event tokens I have. Is there a way that we can be compensated for this or receive the items from the event shop? I would have gotten everything if I could have participated.

  • MaLicious17
    1 posts

    I am not able to finish any actual Ostara Festival quests.

    • My festival is not loaded in the slightest.
    • Twirling Targets is ... not there, but Twyla is, and when I give it a go anyway, once the time runs out, it is just frozen and won't let me out.
    • I have located all 15 egg baskets, but basket 15 is on something I must climb. However, nothing in that spot is loaded at all for me, so it is just floating above where I can reach.
    • I completed the first part of Spiritual Defense (or whatever it is actually called) but now Anke is just sitting there, and won't take me into the forest to hunt bad spirits.

    With only 2 days left, I'm super sad I can't do anything else for this. I am in love with so much of the offerings in the festival shop. Yule went off without a hitch for me, so I was not expecting this much trouble.

  • the4anoni
    4 posts

    I'm really disappointed ubisoft, I found yet another bug which stops me from completing another misson on Yule festival.

  • the4anoni
    4 posts
    I have located all 15 egg baskets, but basket 15 is on something I must climb. However, nothing in that spot is loaded at all for me, so it is just floating above where I can reach.

    I have same bug. One egg is just floating above map, there is no way to reach it.

Suggested Topics