ubisoft discussions

Quick Suggestions

  • garethvk
    3 posts

    Reddit group is saying it unlocks with the second target.

  • Hannes9one
    2 posts

    Not a bug. You get the second key when you eliminate the second target. So you just have to wait 2 weeks, unfortunately.

  • JacksonKavon
    1 posts


  • Ubi-Viral
    Ubisoft Support Staff 2366 posts

    Hey folks!

    Thank you for getting in touch. At this time this is something we are aware of in regards to the confusion caused by the second key.

    It has been reported to the development team and is being looked into.

    Once there is an update we will reach back out.

    Thank you.

    Official Response
  • N3mB0t
    934 posts


    there is already an update , check the known issues thread , says its fixed for TU15.1.

  • Darren_Evans
    24 posts

    @hannes9one It must be a bug. When I first did Castillio manhunt and was then instructed to meet Kelso in the basement, when I spoke to her there was a cutscene, then Kelso spoke again and gave you an encrypted key to plug into the laptop on the desk next to you. You do that and discover why Lau turned rogue. Then when that ended my screen was clear and Castillio was crossed off in the manhunt screen.

    Then I accepted a call for backup later on and was helping players run the Castillio manhunt again. I then saw I had to go to Keslo again and speak to her. I was expecting the same cutscene sequence but all that happened is I now have this missing Faye Lau second key side mission description plastered across my screen all the time. If you're not able to do this until the next manhunt activates, why is the mission description constantly displayed?

    Also, those mission descriptions need to be a part of the UI that you can move and resize using the Customise UI feature. As it is this UI element is not editable in the customise UI section and it's far too large and obstructive.

  • GrimmReeper__
    1 posts

    there is already an update , check the known issues thread , says its fixed for TU15.1.

    If TU15.1 is currently live then unfortunately the issue is not resolved. Tried earlier today and Kelso was here. Came back after running around and the quest marker is here but Kelso is gone.

  • Aryotus
    9 posts

    @echolecter. I'm on series X and friends and I all have the same issues with this "key" and DCD going blue on us. One thing to add about the DCD mission is when sent there originally by Kelso after using 1st key, DCD was gray and after completion went to White House and no enter action possible with Kelso as you state however DCD, when I looked at my map had turned "blue" as you stated. I completed it as a "blue" mission and that is how I was able to complete "Castillo" the first Manhunt. I can't imagine how "jacked" it would have been if DCD was "Invaded" or part of unlocking a Stronghold. 🤞

  • GnarlyAtol1793
    430 posts

    sometimes I wonder why these things do not pop up in their own testing …

    considering the huge amounts of bugs over the years, partially still existing, and new bugs …

  • Dollar-Beale
    1 posts

    @grimmreeper__ Same thing here

  • N3mB0t
    934 posts


    "their own testing..."

    what testing? lmao , they dont do that.

  • Ubi-TheBerry
    Ubisoft Support Staff 2882 posts

    Hey guys,

    Just to share this is still under investigation at the moment.

    We'll keep you in the loop as and when we have anything more on this to share.

    Thank you!

    Official Response
  • echolecter
    279 posts

    @ubi-theberry This issues will most likely solve itself when the 2nd target becomes available. It will (as mentioned by others) hand us the next key so we can use it for the side mission. Already looking forward to 3rd key notifications that can't be used ...

  • echolecter
    279 posts

    2nd key issue solved, delivered but not after having to logout/login first. After retrieving the key in final bounty there was nobody at the White House to drop the key, no interaction possible. Only after going back into the game with the same character it was enabled and side mission progressed to next step.

    Current status: "Use Faye Lau's third decryption to unlock the data", so nothing was changed or even looked at to even stop this from happening, I bet 4th key will be just the same.

  • BadMojo4U
    Original poster 2 posts

    Faye Lau Decryption Key 2 still not available. Completed Castillo and never got the "Key 2" Do we have to reset again to get this ( #*^$&^$^). Someone already completed Daniels and its not given out there either. If we completed Castillo just put the bleeping key in our inventory

  • mslinks00
    2 posts

    @echolecter Agreed. I'm having the same issue. It's been a disappointing update as of late.

  • Charliefilpo79
    2 posts

    Hi All. Sergeant Daniels is eliminated but I have no second key! The game opened main mission for rescue president Ellis in bank headquaters.Its done. Do you have any idea whats happened? its bug or what? Is there same issue for somebody like me? Thanks for your help.

  • Aryotus
    9 posts

    @ubi-theberry Hi & thank you for taking interest. I have found that after the 2nd Manhunt and acquiring the 2nd key to wait 1 hour or 2 before entering the Whitehouse at all (for any reason) disregard the prompt to go in. After 1 and a half hours I went in and was able to complete the 2nd key mission, and like after the 1st key was immediately prompted for the next mission. (This was completely by happenstance as I was standing outside of Whitehouse chatting with clan mates about all experiences members were having at that moment going in attempting to complete the mission). We broke up the group so all were on their maps, each went did something else in game solo, then entered Whitehouse and all completed the mission. Why it worked this way, best guess is an unseen or background server que for content generation.

  • KraziAgent
    50 posts

    @charliefilpo79 workround is this..

    reset manhunt, dot even ddo the 2nd target,

    do the 2nd target 1st, CPs, Bounty, then bounty mission..

    do not go to kelso.
    exit game (PC or Console)

    shut down and or restart your PC/ and or game console.

    load up ubisoft connect / console Division 2
    start game.(PC)

    load into your agent

    slowly walk t kelso and get the 1st Decryption Key Audio log..../collectable..

    if you get it ? GOOD!!

    Repeet sam for the 1st target.....

    once you complete the mission.... reset PC/Console

    Load ubiconnect / Console

    Start Division 2 (Pc/console

    do the same, walk to kelso do not touch anything, sit for a sec, then talk to kelso

    this is why we need PTS testing, even with the Story/Seasonal stufff. Manhunts

    if dont want lore getting data mined, have blank/ or place holder/redacted audio logs/collectables. audio clip ( This clip is place holder) in audio no real recording in game yet but has same identifier to the games file? in PTS (even data miners cant get the details of teh story lore etc...

  • enm01yar
    1 posts

    Im having the same issue but with the 3rd key. it shows there is side mission and it requires a 3rd fay's key. Any advise?

Suggested Topics