ubisoft discussions

Quick Suggestions

  • kimochi312
    1 posts

    I got same problem in PS4, playing solo completed the manhunt bounty and back to WH, react to Kelso with 1 recording played, it asked to use the second key with Kelso but failed. I tried with my 2 characters in my account and got the same.

  • Televerse
    1 posts

    Same issue.

    Mission series accomplished with Castillo eliminated and narrative advising return to White House basement to meet Kelso to use 1st data encryption key. Upon arrival, no Kelso character present to continue mission series even though blue pentagon icon shows properly on map for Kelso location and notification clearly shown in upper left of screen. Please fix.

  • dannii01
    2 posts

    having the same issue, as above have tried to reset the hunt and do it again but that still didn't work, i hoping they can fix this soon as its not that much fun i wanna do it a 3rd time.

  • Ubi-Viral
    2366 posts

    Hey folks!

    Thank you for getting in touch. At this time this is something we are aware of in regards to the confusion caused by the second key.

    It has been reported to the development team and is being looked into.

    Once there is an update we will reach back out.

    Thank you.

  • N3mB0t
    1239 posts

    @ubi-viral

    there is already an update , check the known issues thread , says its fixed for TU15.1.

  • RichXHD
    1 posts

    @ubisushivamp hi i am also having this issue the key is missing so i cant hand it over on playstation 5, is it possible to add a key to accounts that have it missing?

  • Cogiun
    3 posts

    @ubisushivamp I have the same problem with the castillo quest except It shows, that its completed and I get back to WH, turn key in listen to message . But does not show complete

  • quinch1199
    55 posts

    @suschunga Thanks for the clarification! Guessing 15.1 will remove the annoying waypoint (and accompanying "dum-dum" music each time you enter the WH).

  • V4MPiR1
    353 posts

    @quinch1199

    Thanks for the clarification! Guessing 15.1 will remove the annoying waypoint (and accompanying "dum-dum" music each time you enter the WH).

    No. The waypoint will remain, and the music will be replaced by, "Dum-dum Agent, pilot Torres is clear for transpo to Kenly College!" 🤣

  • Neebanator
    3 posts

    Same happened to me first time round on pc I literally reset the manhunt and did it again thankfully it worked the second time.

  • Darren_Evans
    24 posts

    @hannes9one It must be a bug. When I first did Castillio manhunt and was then instructed to meet Kelso in the basement, when I spoke to her there was a cutscene, then Kelso spoke again and gave you an encrypted key to plug into the laptop on the desk next to you. You do that and discover why Lau turned rogue. Then when that ended my screen was clear and Castillio was crossed off in the manhunt screen.

    Then I accepted a call for backup later on and was helping players run the Castillio manhunt again. I then saw I had to go to Keslo again and speak to her. I was expecting the same cutscene sequence but all that happened is I now have this missing Faye Lau second key side mission description plastered across my screen all the time. If you're not able to do this until the next manhunt activates, why is the mission description constantly displayed?

    Also, those mission descriptions need to be a part of the UI that you can move and resize using the Customise UI feature. As it is this UI element is not editable in the customise UI section and it's far too large and obstructive.

  • GrimmReeper__
    1 posts
    @ubi-viral

    there is already an update , check the known issues thread , says its fixed for TU15.1.


    If TU15.1 is currently live then unfortunately the issue is not resolved. Tried earlier today and Kelso was here. Came back after running around and the quest marker is here but Kelso is gone.

  • Aryotus
    16 posts

    @echolecter. I'm on series X and friends and I all have the same issues with this "key" and DCD going blue on us. One thing to add about the DCD mission is when sent there originally by Kelso after using 1st key, DCD was gray and after completion went to White House and no enter action possible with Kelso as you state however DCD, when I looked at my map had turned "blue" as you stated. I completed it as a "blue" mission and that is how I was able to complete "Castillo" the first Manhunt. I can't imagine how "jacked" it would have been if DCD was "Invaded" or part of unlocking a Stronghold. 🤞

  • vm4M9Tz4pB
    140 posts

    @neebanator u do it solo? some ppl said it is happening on completed the hunt by MP, and some ppl said it didn't work even after reset.

  • GnarlyAtol1793
    733 posts

    @n3mb0t
    sometimes I wonder why these things do not pop up in their own testing …

    considering the huge amounts of bugs over the years, partially still existing, and new bugs …

  • Dollar-Beale
    1 posts

    @grimmreeper__ Same thing here

  • N3mB0t
    1239 posts

    @gnarlyatol1793

    "their own testing..."

    what testing? lmao , they dont do that.

  • Jessa246
    33 posts

    I had reset the manhunt and got first key, still the Faye Lau second description key is showing we need to use it but no second key was supplied.

    How can the Dev's make a mission and not test it to see if it works, and we have to reset the mission over and over to get a playable game if it works or not.

    WHY CAN'T THIS BUGGED MISSION BE FIXED NOW OR ARE THE DEV's SHOWING THEIR INCOMPETENCE AGAIN.

  • Ironcavalry
    1 posts

    @quinch1199 Problem, I did this on solo and finished with the polarity global active. So group or solo, there is an issue from the looks of other people completing the bounty. Finished the Castillo bounty, went to WH and interacted with Kelso, no problem and gotten the "collection" for the conversation of Natalya about Faye, not sure if this was supposed to be the data to be decrypted. Of course, then I get the request to decrypt data about Faye Lau from Kelso, nope, nada and no key to do so. It seems poorly laid out mission format combine with bad testing by the team.

  • vm4M9Tz4pB
    140 posts

    @jessa246 yes, reset it and get the key back from this bug. however i play it solo this time.



Suggested Topics