ubisoft discussions

Quick Suggestions

  • Randelia
    431 posts

    @hridoychowdhury That might work only if you do it while still in the game, and not touching Lost Saga until you have finished the fight and renamed the folder back while still in the game. As soon as you leave the game without the dlc_35 folder present it gets borked.

    I tried it out with:

    • renaming the folder
    • starting the game
    • defeating Balor
    • saving the game
    • leaving the game
    • naming the folder back to dlc_35
    • starting the game
    • then going to Ravensthorpe to check on Everold


    Result was: his house was gone, there was the tent again you get when you first meet him. He was outside, and the quest pointer to drink the potion was inside the tent, but I could not enter it. When talking to Everold he opened his shop, my currency items first showed, then quickly reset to 0.

    When the game loaded while the folder was renamed, it must have tried to load some stuff from the dlc_35 folder regarding progress on LostSaga. And since that folder was not there, it didn't load it. Then when I saved the game after the fight the stuff it usually would have had loaded about LostSaga didn't get stored back into the save.

    Then when I loaded the game again after naming the folder back the game put his house as a tent in the camp but it didn't restart the quests you get in the beginning of LostSaga to build his house etc.
    It was borked and I could no longer get to the pointer to drink the potion.

    There are 2 files within the dlc_35 folder named ...35_dlc_SharedGroup...forge I somehow have a feeling it's one of those files that prevent the Balor quest from finishing correctly. (@Ubisoft I don't know if that helps or not)
    The rest sounds like they just have to do with the Lost Saga alone.

  • lemmie88
    305 posts

    They definitely broke Balor with Forgotten Saga. The Hjalmgunnar boss is just Balor reskinned. I tried out Forgotten Saga today and Hjalmgunnar gets stuck exactly like Balor, except that the fight finishes and you can walk out while he stands like a mannequin. Ubisoft, if you recycle content pls don't break the original!

    They are like twin bros separated at birth.



  • efleming1
    3 posts

    Since the bug will not be fixed, why not offer Gae Bolg as a free reward for anyone that can't get it properly?

  • leighgf
    1 posts

    Unable defeat Balor in the quest 'Amber Sun'

    he glitches at the end of the fight once his health is at 0, help

  • social-phobia
    24 posts
    Since the bug will not be fixed, why not offer Gae Bolg as a free reward for anyone that can't get it properly?


    This seems like a reasonable idea.

    Been trying for days to complete this on xbox, playing normally or by trying to finish him with the 'Bow Finisher' but nothing seems to work. I haven't tried 'Forgotten Saga' yet but I fear as someone eariler posted with the boss being a re-skin that the issue will still be present.

    @Ubi-Keo still no news on the fix?

  • Randelia
    431 posts

    @Ubisoft 1.6.1 Announcement says:

    "WRATH OF THE DRUIDS


    Addressed:

    • Finishing Balor with a stun-attack can cause the encounter to get stuck."


    Does that mean you guys fixed the Balor fight bug? Because it does not matter if you use a stun attack or not, he will be stuck at the end of the fight. Please let us know. Thank you.

  • Netspook
    349 posts

    @Randelia

    The patch goes live tomorrow, I guess we'll have to wait and see.

    Personally, I doubt it's fixed, because the of the wording. I'm not able to finishing him with a stun attack. As I've said earlier, for me he goes down on his knee, then there's a prompt to press R for that stun attack, but pressing R doesn't work.
    In other words, according to the wording, their fix is for problems AFTER a point I can't get past.

  • Ubi-Keo
    Ubisoft Support Staff 5305 posts

    Hi Vikings!

    I'd like to reach out to you all with an update. The development team have confirmed that this issue wherein Balor cannot be defeated in the quest 'Amber Sun' should be resolved with the release of Title Update 1.6.1! You can read the full patch notes here.

    The patch will be deployed today, Tuesday, September 27 at 12 pm UTC/GMT, 2 pm CET, 8 am EDT, 5 am PDT, and 10 pm AEST.

    If you are still unable to defeat Balor after installing the new update, please don't hesitate to share an update within this thread so we can notify the development team. When sharing a new report, please can you provide us with the a video which shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the main menu screen.
    • That you are unable to defeat Balor


    I would recommend uploading your video to a video sharing platform such as YouTube, you can then copy the URL link into this thread. 

    Can you also ensure that your latest save is uploaded to the cloud. If you are unsure how to do this there is a support article that you can check here

    We can then use these reports to reopen the investigation should the issue persist following the 1.6.1 update. 

    Official Response
  • ragman1976
    2 posts

    IT IS FIXED!!!

  • Ubi-Keo
    Ubisoft Support Staff 5305 posts

    Hi @ragman1976 thanks for confirming that the update has resolved the issue for you 🙂

    Official Response

Suggested Topics