Welcome to discussions

Quick Suggestions

  • BobaFink83
    2 posts

    @pkpjohnboy538 it’s very glitchy. You can’t go to England because one of the starter missions won’t load. I’ll be the master of Norway before they get this fixed 😂

  • Noodlebasket
    1 posts

    @pkpjohnboy538 It runs alright thru the epic store so far. That being said I am experiencing some audio issues including muffled voices and annoyingly loud minor sound effects like rustling bushes and footsteps thru snow. I would recommend waiting a week or so for a few (hopefully planned) hotfixes and patches.

  • Mastemo523
    4 posts

    @pkpjohnboy538 Your best bet is to wait a while to play this. The game bugs out for a lot of people during the first story quest (after the whole tutorial bit, when you get to your village). The quest in question here is A Seer's Solace. Literally can't trigger the event to progress the story, and it's the first one. So you've suddenly dropped $60 for a glorified demo. I've consumed raw dough that was more baked than this mess.

    So far though, no skinless faces like Unity. Just choppy framerates, glitched main story and side quests. It's Ubisoft's version of Skyrim.

    I am on PS4 and so are my friends. Could be different for PC and XBO.

  • sford25
    2 posts

    Playing the ultimate digital edition ps4 and none of my dlc work, my settlement is now in england and still have no extra content. Is this a known issue?

  • dixiewolf061
    1 posts

    @bobafink83 THIS. I'm going back to sleep and hoping they have a patch for it when I wake up 😒 Like, I just dropped $130 on this, let me play the damn game!

  • zhead_
    31 posts

    Can we get a list of known issues and what fixes are being worked on? Maybe hotfix estimates? Otherwise I might ask for a refund since my audio is not really working

  • Omegageddon
    2 posts

    Yep. Same. They'd better fix this soon. I took the week off work to play this game and now I can't make any more progress. I was SO looking forward to this game and so far it's been the worst AC experience ever.

  • CrazyDonkey88
    100 posts

    @omegageddon
    True. I can't even start the game. Stuck on splash screen bo Ubi retards don't care. It was last game i get from them

  • Gezz97
    3 posts

    This game has so many bugs, needs to be fixed,
    *whole suit gets wet coming out of water even knee deep
    *hands grip onto basically nothing on certain cliffs
    *Items don’t appear in hand when eating at table etc...
    *Boat options come up even though you’re on foot
    *Audio stutters a lot
    *Graphic textures don’t load up for a while
    list can go on to be honest but these things will take so much annoyance away if fixed

  • TheJamvilleYeti
    2 posts

    @mastemo523 Xb1X is the same as far as frame rate drops for me.

  • LowLife_J.shrt
    4 posts

    @ubimeesherbeans
    WHHHHYYY?!?!?! There is not a single 1h Sword in the game. Who made this decision?!?!?!? Da F****

    I am sooooooo, sooooooooo Disappointed.

    For real.

    Odyssey -> no spartan shield
    Valhalla -> no 1h swords

    Is this some kinda fun thing u guys do ?

  • Devils_1977
    1 posts

    When will they fix this bug with
    ”A Seer’s Solace” I’m not going to delete my 18h play save to fix this😡😡😡
    This is Ubisoft problem!
    I hope heads gonna roll amongs the programmers 😡

  • ForAllTheLADS
    1 posts

    @real-pluimpje

    You are correct. Those of us that preordered can’t operate the Ubisoft Connect menu so we can’t benefit in early-game from the add ons that we purchased. They’re giving us the “working on it” treatment.

  • uCuNextTuZday
    1 posts

    I'm stuck on Ragnorsons quest. I talk to Ubba got the cutscene but keeps saying speak to Ubba won't let me talk to him again and won't let me do the fortress part game is broken. I've tried restarted and everything nothing works. Would very much to enjoy a game I preorder awhile ago. Why is it they spend so much time on games but somehow still manage to release unfinished glitch trash. They give streamers free games early for favorable reviews but not to the average person to field test it honestly so game can be correct when official released.

  • kayceekambie
    13 posts

    REFUND OR FULL GAME.

  • CrazyDonkey88
    100 posts

    @kayceekambie yeah

    [censored] u ubisoft for having this for two days now. I bought ult version and what? i will never buy game from u since now

    undefined

  • CValentino
    5 posts

    @pkpjohnboy538

    this game is soo glitchy, that it will make you angry, im at a point on the game that the game literally freezes everytime im in that area.

    its a fantastic game storyline etcc.. but a game unfinished like this. The yt streamers are like “omg so few glitches and bugs”... untill you get the game.

  • DaveMell
    2 posts

    @real-pluimpje
    Assassin's Creed Valhalla- Got Gold edition loaded it everything was fine playing 20 odd hrs and Quest marker disappeared stopping me moving forward deleted game reinstalled then it would let me fully reinstall - Should have waited for them to iron out more gliquiches before purchasing

  • sydneyblue
    15 posts

    @pkpjohnboy538 Sound glitches on both my PCs running the game. The AI is dumb [censored] nails. Today i was hanging like i was hanging from a ledge but there was no ledge

  • STREETY14
    6 posts

    @ucunexttuzday mines doing the same hate it as i carnt play the game with this happening Ubba won’t talk to me ahha

Suggested Topics

Community Details

159
Online
193.4k
Users
32.6k
Topics
163.2k
Posts