Welcome to discussions

Quick Suggestions

  • uCuNextTuZday
    1 posts

    I'm stuck on Ragnorsons quest. I talk to Ubba got the cutscene but keeps saying speak to Ubba won't let me talk to him again and won't let me do the fortress part game is broken. I've tried restarted and everything nothing works. Would very much to enjoy a game I preorder awhile ago. Why is it they spend so much time on games but somehow still manage to release unfinished glitch trash. They give streamers free games early for favorable reviews but not to the average person to field test it honestly so game can be correct when official released.

  • kayceekambie
    13 posts

    REFUND OR FULL GAME.

  • CrazyDonkey88
    100 posts

    @kayceekambie yeah

    [censored] u ubisoft for having this for two days now. I bought ult version and what? i will never buy game from u since now

    undefined

  • CValentino
    5 posts

    @pkpjohnboy538

    this game is soo glitchy, that it will make you angry, im at a point on the game that the game literally freezes everytime im in that area.

    its a fantastic game storyline etcc.. but a game unfinished like this. The yt streamers are like “omg so few glitches and bugs”... untill you get the game.

  • DaveMell
    2 posts

    @real-pluimpje
    Assassin's Creed Valhalla- Got Gold edition loaded it everything was fine playing 20 odd hrs and Quest marker disappeared stopping me moving forward deleted game reinstalled then it would let me fully reinstall - Should have waited for them to iron out more gliquiches before purchasing

  • sydneyblue
    15 posts

    @pkpjohnboy538 Sound glitches on both my PCs running the game. The AI is dumb [censored] nails. Today i was hanging like i was hanging from a ledge but there was no ledge

  • STREETY14
    6 posts

    @ucunexttuzday mines doing the same hate it as i carnt play the game with this happening Ubba won’t talk to me ahha

  • RadicalBlowfish
    6 posts

    Why did all my equipment gear and weapons just disappear? I had to close the game and restart it and it gave it all back but it took away all the upgrade that were done. I spent money to get a helix pack and now all of that was literally just stolen from me. This is B.S.....what am I just supposed to do it again and hope it doesn't get reset yet again.

  • sydneyblue
    15 posts

    @radicalblowfish Some of my saves got wiped all manual also

  • RadicalBlowfish
    6 posts

    @sydneyblue wasn't a save but that sucks. I mean while in game I was in my menu and when I left my menu my gear was gone. And after restart it all came back but lost the upgrades.

  • sydneyblue
    15 posts

    @radicalblowfish I was trying to play the game as a male and a female character to see if there was a different experience my male character got erased so wasnt all bad but still [censored]

  • guest-Yer49JWF
    1 posts

    @bobafink83 you say you can’t go to England?? Is this why I thought I was going to England on my boat and then ended up as some character called Layla in the future!? Can you help please? Really [censored] me off this has....was fully getting into it as well.

  • lzjunior.007
    3 posts

    I'm also having a hard time, where I live the internet crashes all the time, and I can't play on xbox one, say I need to be online to play, please fix this.

  • marcusanthony25
    13 posts

    Stuck on the sons of ragnar quest I've spoken to ubba, but then he still stands there, I've tried exciting the aminus and back, went to Norway pledged to grantersbridge and lunden but can't do anymore the power is to strong everywhere else, hurry and fix this ubisoft I think we all have waited long enough you should never bring a game out with this many problems very poorly done for the price I was really looking forward to this game and yeah its great when you can play it without bugs and freezing or when your fighting just shoots you in the bloody sky its ridiculous get it sorted we all have WAITIED LONG ENOUGH

  • dvsdados1
    2 posts

    Any news on patch? Restarting isn't an option for me after all the hours i put in prior to even going to the settlement. You would think it would be a priority being it's a new high profile release to make sure the immense amount of fans who preordered it want to even preorder a game again.

  • marcusanthony25
    13 posts

    @dvsdados1 you would of thought it was there priority mate 👍

  • wukone2016
    4 posts

    note to Ubisoft

    It is with dismay I write to you regarding the well know bug preventing players to move on in the main quest early on in the game. The Valka issue is well known worldwide. I am an owner of a physical copy of Valhalla which has been patched to 1.02. but nevertheless the main quest will not set forth. wasting time reinstalling the game, not connecting it to the internet, jumping straight to the main mission to make sure one can move on seems to me a hassle and an affront to my money invested or lost in this game.
    Therefore, I am requesting a compensation or a full refund support towards local PS4 online game dealer in order to send the game back.
    As per your somehow abusive T&C, I consider this bug, in MAJOR REALEASE, to be FATAL to the gameplay. The game has been released for 5 days and this has not been yet solved and I strongly believe UBISOFT realizes its humble users/buyers/participants to the fat revenue are not their game testers.

    Excerpt from T&C.
    You are entitled to a replacement or refund for a major failure and compensation for any other reasonably foreseeable loss or damage. You are also entitled to have the products repaired or replaced if the products fail to be of acceptable quality and the failure does not amount to a major failure.

  • BoredCreature22
    1 posts

    Has lots of glitches half the mission don't work have spent £92 on a game I can't progress on if it doesn't get fixed I want my money back have put over 48 hours into the game that doesn't work

  • GIOCATIVO
    2 posts

    Unfinished game, embarrassing. Frustrating. Disappointing.
    Disgraceful releasing a game that doesn't work and charging people for it!
    Seers solace the first real quest! CRAP

  • Arianapaquette
    1 posts

    I bought the game for Xbox one on November 10th and I still haven’t gotten it yet. 😕 anyone else having this problem?

Suggested Topics

Community Details

29
Online
138.8k
Users
24.3k
Topics
125.8k
Posts