Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • guest-Yer49JWF
    1 posts

    @bobafink83 you say you can’t go to England?? Is this why I thought I was going to England on my boat and then ended up as some character called Layla in the future!? Can you help please? Really [censored] me off this has....was fully getting into it as well.

  • lzjunior.007
    3 posts

    I'm also having a hard time, where I live the internet crashes all the time, and I can't play on xbox one, say I need to be online to play, please fix this.

  • marcusanthony25
    13 posts

    Stuck on the sons of ragnar quest I've spoken to ubba, but then he still stands there, I've tried exciting the aminus and back, went to Norway pledged to grantersbridge and lunden but can't do anymore the power is to strong everywhere else, hurry and fix this ubisoft I think we all have waited long enough you should never bring a game out with this many problems very poorly done for the price I was really looking forward to this game and yeah its great when you can play it without bugs and freezing or when your fighting just shoots you in the bloody sky its ridiculous get it sorted we all have WAITIED LONG ENOUGH

  • dvsdados1
    2 posts

    Any news on patch? Restarting isn't an option for me after all the hours i put in prior to even going to the settlement. You would think it would be a priority being it's a new high profile release to make sure the immense amount of fans who preordered it want to even preorder a game again.

  • marcusanthony25
    13 posts

    @dvsdados1 you would of thought it was there priority mate 👍

  • wukone2016
    4 posts

    note to Ubisoft

    It is with dismay I write to you regarding the well know bug preventing players to move on in the main quest early on in the game. The Valka issue is well known worldwide. I am an owner of a physical copy of Valhalla which has been patched to 1.02. but nevertheless the main quest will not set forth. wasting time reinstalling the game, not connecting it to the internet, jumping straight to the main mission to make sure one can move on seems to me a hassle and an affront to my money invested or lost in this game.
    Therefore, I am requesting a compensation or a full refund support towards local PS4 online game dealer in order to send the game back.
    As per your somehow abusive T&C, I consider this bug, in MAJOR REALEASE, to be FATAL to the gameplay. The game has been released for 5 days and this has not been yet solved and I strongly believe UBISOFT realizes its humble users/buyers/participants to the fat revenue are not their game testers.

    Excerpt from T&C.
    You are entitled to a replacement or refund for a major failure and compensation for any other reasonably foreseeable loss or damage. You are also entitled to have the products repaired or replaced if the products fail to be of acceptable quality and the failure does not amount to a major failure.

  • BoredCreature22
    1 posts

    Has lots of glitches half the mission don't work have spent £92 on a game I can't progress on if it doesn't get fixed I want my money back have put over 48 hours into the game that doesn't work

  • GIOCATIVO
    2 posts

    Unfinished game, embarrassing. Frustrating. Disappointing.
    Disgraceful releasing a game that doesn't work and charging people for it!
    Seers solace the first real quest! CRAP

  • Arianapaquette
    1 posts

    I bought the game for Xbox one on November 10th and I still haven’t gotten it yet. 😕 anyone else having this problem?

  • sydneyblue
    15 posts

    @arianapaquette What are you talking about man. " you bout the game on november 10th" from where some guy behind the ally ?

  • Koolkarl117
    3 posts

    Please fix a seer’s solace ASAP I spent many hours into the game just to be stopped by a bug. Also can you make the mystery missions be in the quest book because I was in the middle of one then got distracted, which then made me search up where to go as there is no directions really.

  • Koolkarl117
    3 posts

    I was playing the intro before the Vikings crash the party and the kid sounds like a AI is that on purpose?

    Also half the dialogue is cut out or not in time with when it’s meant to be said. That was after choosing the gender and Evior is about to be sold. This really breaks immersion and luckily I had subtitles otherwise would have not known what was happening.

  • AVDOLLI98
    4 posts

    I am currently 35 hours into this game and I have had many issues with this game. I am playing on Xbox one S and purchased a physical copy of the game.

    So far It has frozen on me multiple times where the game eventually crashed or needed to be restarted. I have experienced have been numerous texture issues in free roam as mentioned by others. While I have not had many issues with quests. I have noticed that I've had some dialogues just skip in the middle of when an NPC is talking as well some missions just not progressing through as I've played (to where I have had to restart my game in order to make the missions work).

    I am currently dealing with a bug in the Quest "Taken For-Granted"

    :::

    where I made the decision to tell Randvi "Now is not The right Time" as I wanted to romance her later once things got better with Sigurd so I wont [censored] him off near the end. When I talked to her by the map table after completing the quest the romance dialogue would appear. however since I have reloaded my game those dialogues have just vanished.

    This issue as well as all the other mentioned by other have really been a real disappointment as I don't not feel as if I have control over the outcomes in the game and am now stuck where I am worried about progressing further. As an avid player of Assassins Creed playing since AC1 this is incredibly disappointing and honestly ridiculous, Please fix these problems Ubisoft, people are unable to progress further and enjoy this game which has so much potential.

  • gero9591
    1 posts

    Good game but need more weapons and power

  • MadRabbitDK
    1 posts

    I have a problem with my Assasins creed Valhalla game :
    At Nov 10th or 11Th i brought the Bow from Ubisoft Reward store for 120 points.
    I also got the bird from rewards, but not sure about it yet, as i need to upgrade a stable or what
    it called on engilsh (Icon is a horse)
    Should show up in inventory. .... No bow ???

    I aslo brought a Matrial pack The Big pack and a small pack (Small pack 14Th nov)
    I havent got any og my items.
    I have taken the first main quest.
    The pack of game is the medium pack Valhalla

  • MATHEWTYB
    1 posts

    Please fix the infant store so i can throw my money at you‼️(PS5NA servers)

  • lamanticora
    2 posts

    PLEASE UBISOFT:

    This is a bug or the game is broken?
    Be serious and fix this immediately, a lot of people is having this issue!
    You are killing the game

    https://discussions.ubisoft.com/topic/81157/sons-of-ragnar-quest-bug?_=1605537893281

  • tomcolliflower
    3 posts

    Please fix the issue with the Pilgrimage to St. Albanes quest. I am unable to get the cutscene to play where Fulke is rescued and its completely halted my progression through the story.

  • stroe01
    3 posts

    A huge bug... in the quest a cruel destiny. It’s just frozen after the first part, I can’t do anything and I’m really [censored] about it.... So please fix this bug...

  • louismockler75
    14 posts

    A brothers keeper after Odin cut scene. Can’t get out of room with machine. No quest to follow. Just old lady hanging on her own n blue orb

Suggested Topics

Community Details

45
Online
130.2k
Users
22.5k
Topics
116.9k
Posts