ubisoft discussions

Quick Suggestions

  • corcubiones
    1 posts

    Got the game on launch date. It is an OPEN WORLD GAME, so, guess what? As soon as I could, I started EXPLORING!!! I even followed the game's prompts and RAIDED!! 5 hours into it, went to follow main quest only to find out it's broken and I cannot continue. WHAT A JOKE!!!
    Checked this forum and issue has been known since pre-launch...nothing done about it yet!
    Delete saves & re-start as solution? What an insult!! Do your job & fix it!! I paid money for a product...product doesn't work...not my fault...your responsability...OWN IT, LIKE YOU DO WITH MY MONEY. Lack of communication adds even more embarrassment to you UBISOFT.

  • DLanaDHZ
    1 posts

    I have never knowingly upgraded my game at all. I put the game in and it downloaded and did it's thing. I have not noticed any updates since then, so I have to assume that even uninstalling the game and starting over won't work. I don't want to erase 10 hours of exploration and gameplay just to find out it auto-downloads the update anyway. Do we have an ETA on a patch?

  • FapSackMcGee17
    1 posts

    Cannot see map marker on hud and can’t start quest “storming the walls” bought the digital copy what is the fix?

  • F150ford2009
    1 posts

    I have the same problem I can not go to the seer, so I found everything in the first part of the game, You all have several glitches in this part of the game, the first one and I am not sure where this is except it on the island at the start of the game I was walking in the snow and sank under the snow and out of the game on the back side of the playing field. The second glitch was I was killing the legendary elk when it got stuck in the far west corner easy kill. and several times I was fighting wolves or pigs and I would die without them attacking me this happen at several locations on the map. I am playing on PS4.

  • Mandy21807943
    1 posts

    I am really upset and disappointed at all the bugs in this game. I mean, some glitchy stuff is to be expected when the game is first released, but not being able to move forward through a required part of THE MAIN QUEST is completely insane. I've put hours into exploration and figuring out mechanics, etc. So in order to get past A Seer's Solace, Ubisoft expects me to uninstall, reinstall, prevent the game from updating, rush through the first quests to complete A Seer's Solace without doing any exploration, item collection or interaction with other parts of the game. This is complete BS.

    I was so excited for this game and now I am just left with a sour taste in my mouth. I can't believe I spent over $100 for a game (+ season pass) that cannot even be played properly! I also purchased the map set, what happens to my purchased maps if I follow this "workaround"?

    This has been a horrible experience. I have grown to expect some really awesome gameplay, scenery, story lines, and mechanics from playing the previous Assassin's Creed games and this issue is causing me to lose any loyalty or excitement I had for this installment.

  • Itslileloke
    10 posts
    This post is deleted!
  • Schibetta
    1 posts

    Played this game almost 9 hours and your “fix” is to delete and start over? How is this not resolved yet? As a longtime fan of these games I could not be more disappointed. This is complete BS!

  • Nik19652020
    1 posts
    Good morning I bought a CD of the Assassin Creed Valhalla ps4 game for a couple of days, but after playing and reaching the mission to talk to the visionary he does not let me proceed as once in the house where the woman is, a movie should start automatic and instead entering the house the woman remains near the table. This does not allow me to continue in the history of the game. I ask you to provide as soon as possible

  • thysdk
    5 posts

    Same thing here

  • thysdk
    5 posts

    @ubi-spud Regarding the bug. The chain of events that happens up and until you reach that is.

    When you get to Fornburg, you speak to Randvi an a small cinematic appears. Then she tells you to go and speak to the Blacksmith Gunnar and at the same time a few people at the settlement will appear that you need to talk to. When Gunnar is done with the axe and you spoke to all the people, you are suppose to go back to Randvi to speak Styrbjorn (This part of the quest does not happen). It is as if the quest jumps to a 'A Seer Solance' before completing the quest ' Family Matters'

  • guest-PYHPElWJ
    1 posts

    im so [censored] i just got the game but it doesnt work ubisoft FIX!!! ASAPPP

  • Jagonma
    4 posts

    I am now +20 hours down the game. I have done everything i could and explored all Norway availiable. Killed all living animal and upgraded my gear.... but the question remains, wehen will we get a patch for the Seer´s Solace mission so we can pregress in to the story line. I have started as well a new game where i did that the first thing, and it worked fine withouth having to delete anything from my other game, but i am still hoìng that a patch 1.03 will be released soon so i do not have to go through all what i have done againg .... anyone knows about any communication from ubisooft in this regards?, when will they be releasing a new patch?.... a few days, weeks?.... anything?.


  • Screamliciouss
    6 posts

    @jagonma As I wrote yesterday.
    One of the users just got in contact with ubisoft. They wanna fix this at the beginning of this week. So maybe tomorrow or wednesday.

  • Vlad-Drac97
    1 posts

    i have bugs by the seer can not get ahead in this game so pls behave this bug for what i pay money and you know i am not the only one with this problem my brother and friends have the same problem like i i never seen a bug where you can not play anymore

  • TonyH9292
    6 posts

    I have the same issue after installing the 1.0.2 patch. 15 hrs in and i cannot complete the quest "Seers Solace", it does'nt even track on my hud. Playing on PS4. How long before we get a fix for this and other known issues!.

  • SerVonHo
    2 posts

    @screamliciouss Thank you

  • dejvi955
    6 posts

    Is there any official info when Ubisoft is going to release pach/update?

  • Ksi0pea182
    1 posts

    Same here on PS4. Game version 1.0.2 I refuse to delete and restart the game. Just 10 hours playing...but this is not a solution.

    Similar problem had on Odissey and it was the same solution...even when we had played 100 hours to this game.

    It is not a serious solution. And this is not a game it´s a joke...bugs and more bugs...

  • mrweed4000
    2 posts

    It’s the 16th of November and the bug is still not fixed. [censored]?

  • Vissenkom1107
    3 posts

    @screamliciouss How do you know that? And why isn't there an official reaction from Ubisoft on their massive failure?

Suggested Topics