ubisoft discussions

Quick Suggestions

  • slim5485
    5 posts

    Same here, totally completed all side quests in Norway and can’t progress the story.

    shocking come on Ubisoft sort it out

  • abcghi123789
    12 posts

    Glad it works, but I still don't see why we have to waste all our time on reinstalling and playing everything again, when it is not our fault. They should have given out a patch with a workaround long ago.

  • Andrearoselli60
    16 posts

    @abcghi123789 we know that, but I'd like to play and this is the only way without the patch

  • Andrearoselli60
    16 posts

    @mr_tinka I don't know, I have 1.0.2

  • dejvi955
    6 posts

    @slim5485 but you completed them after seers solace?
    Or before?
    Is there something else that is not working?

  • slim5485
    5 posts

    @guest-0zyza26f no basically did everything else in Norway and now cannot get the seer mission to activate

  • Mr_Tinka
    3 posts

    Did u update after that mission?

  • Dr-ross
    1 posts

    Just had this issue happen to myself as well. Absolutely disgusted that this has been flagged to then 3 days in advance and wasn’t fixed for launch. I had the game crash on me (playing on PS4) when changing weapons and figured that updating would solve the issue then i get this rubbish! Appalling!

  • Odgarot
    1 posts

    Can we get any official response from Ubisoft regarding how soon we can expect a solution to this issue? At this point, an answer in the line of "we have informed team x,y,z. We are sorry for the inconvenience..." - is not enough! I am most certainly not starting from the beginning after a few hours of playing.

  • L2k97
    3 posts

    @ubi-swaggins Hey I have not I have tried to follow the main story and still no luck I have done side missions and quests in the meantime until the bug is fixed...

  • MEB-2009
    1 posts

    @ubi-spud Same issue here. I am also playing on PS4. It is very disappointing!! I have played all previous assassins games (all were collectors editions incl this one) and I have never experienced this. These editions are far too expensive to have these bugs which prevent you from advancing in the game.
    I have already deleted the 1.02 version and I am now trying to install the 1.00 without it being updated automatically to 1.02 again, so unfortunately I cannot provide a video of the issue. Hope others can and that this major bug will be fixed very soon since I cannot progress.

  • glennsmith1992
    1 posts

    Had the same happen to me... absolutely rediculous for a game to be bugging already not a good sign for the rest of the game! So gutted!

  • liberdean
    3 posts

    @abcghi123789 they really should. It's been a ball ache trying to get everything again

  • NielsKampen1979
    1 posts

    I’m happy the re-install works, but what about the ultimate edition redeem codes? Will everything be there whennI re-install? I already redeemed the codes... I’m afraid I can’t download them again when I delete the game...

  • marc5916
    54 posts


    You don't need to redeem them a second time.

    Once you have redeemed those codes they are tied (linked) to your account and can always be re-downloaded again!

    To re-download the game and add-ons, go to [Library] > [Purchased], and then select [Download] to reinstall your game. To make sure you have all the add-ons, highlight and select the [PlayStation Store] to find and download any additional content. Click [Download].

  • Laerervad
    1 posts

    @ubi-spud i have two videos showing the problem. But im not sure i can post it om YouTube.
    I can try. If its doesnt Work is there another way?

  • SirPisehx
    1 posts

    I got the same problem, Can't trigger the A seer's solace, it keeps saying to me that the people have missed me even If I've talked to everyone. I go o the seer and the coversation or shorcut dosn't trigger, she stays there grinding her herbs in the table.

  • camaradon
    5 posts

    For me it was fixed by reinstalling the game and then loading a save file I knew was from before the update.
    That way I lost a little bit of progression

  • Blue_Moon_1986
    3 posts

    Well, that's £50 and 5 hours wasted until this gets fixed. Will any future update allow me to continue from where I am? Don't know whether I should keep exploring or if it's a waste of time.
    This was flagged days ago so releasing the game in this state is criminal. Big mistake Ubisoft.

  • El_Mattiaso
    55 posts

    I also cannot progress. I am stuck at "A seer's solace". Valka doesn't react or anything when I show up at her hut. There seems to be a vast amount of problems with this launch, or so I gather from scanning these forums. Maybe you should've waited a few more months before releasing this game? I mean, come on, the main quest is broken. Not nice!

Suggested Topics