Welcome to discussions

Quick Suggestions

  • TyranusVader
    121 posts

    @soberstone999 I can confirm it as well. Going to have to use the Special K mod indefinitely.

    Is there any way we can get an Ubi moderator to look into this? It's not a good look when one has to use third-party mods to enjoy the game fully. It's becoming a disturbing trend as CP2077 requires some mods as well to get it working right.

  • TyranusVader
    121 posts
    This post is deleted!
  • TyranusVader
    121 posts

    undefined
    Attention Ubisoft mods, these frame time spikes have been happening since launch. I previously played on a RX 5700 XT 8GB and had the same issues, however the frame time spikes made the game unplayable. It's playable on my newly acquired RX 6800 when the frame time spikes occur but you will still notice a lack of smoothness. My graphic settings are set to the Ultra High preset. Looking through other threads, this happens on Nvidia GPUs as well. Can you please have your technicians investigate this? I could alleviate the issue by using a third-party mod [REMOVED] but I would much prefer not to. Many thanks!

  • TyranusVader
    121 posts
    This post is deleted!
  • Teinzus
    15 posts

    Hello Ubi-Soft,

    I don't know where to complain first, but Assassin's Creed Valhalla produces massive frame drops on my new Gaming Laptop
    Lenovo Legion Y740-17IRHg (1UJ001VGE) with
    i7-9750H, 16 GB RAM, 1 TB Samsung NVMe (where it is installed),
    GeForce RTX 2080 Max-q 8GB RAM on Nvidia Geforce Driver 460.89 (also tested on Lenovo Drivers 457.20)
    newest Win 10 Home 20H2, Build 19042.685

    This rig should do Valhalla fine with constant 50-60 Frames on graphics preset "high".
    But my stuttering reality looks always like this screenshot with massive framedrops down to 22 or somtines 10 in a row:
    undefined

    Things I read on the internet and already tried:
    Borderless window mode, changing with "alt+enter" from game to desktop back and forth, disabling "fullscreen optimization" in the executable ACValhalla.exe
    setting nvidia energy modus to "maximum performance" using older nvidia drivers,
    I am out of my wits and cannot decide wether my laptop hardware or software sucks or Valhalla is poorly optimized for my not so exotic gaming rig...


    Funny enough I tested the game on my 3 years old gaming laptop HP OMEN by HP 17-w106ng with
    i7-6700HQ, 16 GB RAM, 512 GB NVMe and 1 TB SSD (where it is installed)
    GeForce GTX 1070, 8 GB RAM on Nvidia Geforce Driver 457.30
    Win 10 home 1909,
    where it only drops to 24 seldom and is constantly about 50 frames on preset "high" and delivers a much more smooth gameplay:
    undefined

  • AndyPDD5
    13 posts

    Still no update from Ubisoft on this issue? Bravo on the tech support....

  • Teinzus
    15 posts
    This post is deleted!
  • Teinzus
    15 posts
    This post is deleted!
  • Teinzus
    15 posts

    @teinzus Here a screenshot from the smooth gameplay like it should have been delivered by ubisoft and not the creator of the mod Special K
    undefined

  • Ubi-Woofer
    Ubisoft Support Staff 1034 posts

    Hello everyone,

    Thank you all for continuing to share your reports of performance issues in Assassin's Creed Vahalla on PC here on the forums. I've merged a few different threads discussing similar topics into this one in order to try and keep as much relevant information together as possible, and would ask that you all continue to post here regarding these issues from now on.

    If still encountering poor performance in Valhalla, such as low FPS, stuttering, or lag, I would ask that you first complete our PC troubleshooting, ensure that both your GPU drivers and OS are fully up-to-date, and that the game itself is fully updated as well. Running the game in a clean boot environment with no unnecessary background applications running is also my recommendation, to ensure the best possible performance.

    Should issues persist, I'd like you to provide the following details in the same bullet-point format as I've listed them, so that I can compile a set of formal reports to submit to the developers for their consideration. They are already looking into optimisation issues, so the information I am requesting would help them in looking into this:

    • Specifications of your PC in brief (CPU, GPU, RAM, Storage)
    • Version of the game you own (Standard, Gold, Ultimate)
    • OS version number
    • GPU driver number


    If possible, I would appreciate it if you could submit your MSINFO and DXDIAG files to us in a support case or via Live Chat so that we can take a closer look into those as well.

    I would also like to ask that the discussion of unauthorised game modifications in this thread ceases, as this is not something we condone and is not permitted under the forum rules. I have removed all content that breaches these rules, and would like to reiterate that, as we have no control or influence over such modifications, and cannot verify their safety, it is not recommended that you download and/or use one for Assassin's Creed Valhalla.

    Thank you in advance for your help and any information provided, and I will try to keep you all updated as best I can! 🙂

    Official Response
  • Kormac67
    657 posts

    @ubi-woofer Have you seen the thread about PC performance loss with 1.1.0 with over 450 posts?
    https://discussions.ubisoft.com/topic/88876/ac-valhalla-update-1-1-0-frames-drop

  • Slevexz
    79 posts

    @ubi-woofer This must be some joke
    You have all the information you need here: https://discussions.ubisoft.com/topic/88876/ac-valhalla-update-1-1-0-frames-drop
    We asked for help there and post pretty much everything and you gave us no answer and ignored the thread with over 400 posts, now after a month you ask if we still have fps problems? Of course we have, nothing was made.

  • Zarael1721
    96 posts

    @Ubi-Woofer

    Hello sir,

    I wanna mention there is a one biggest thread since 1.1.0 patch is out causing the most serious issue to many of us and the game is literally unplayable for us ... many of us didnt play the Yule fest because its not that awesome play it on 25 FPS and people affected by this issue who played it are not happy at all too.. We realize you maybe as a support team dont have enough info from dev team but what you could do for us at least as a SUPPORT team is add the thread between megathreads and between KNOWN ISSUES adressed with 1.1.0 because its honestly most known and significant issue caused by 1.1.0 patch and you still didnt add it there and basicly almost dont react to that thread... Maybe we dont undestand what all your work contain and maybe you are busy with many other things, but just from what appears to me when i think about meaning of support team is definitly trying to support us especialy if there is issue serious like this one causing unplayability of the game...

    https://discussions.ubisoft.com/topic/88876/ac-valhalla-update-1-1-0-frames-drop/450

    Thank you for response

  • Inu86
    2 posts

    Hello!

    I'd like to report the same as other people have been reporting: After update 1.1.0 the performance has degradated A LOT. I can't even get a stable, constant 30fps gameplay session.
    As requested, below follow a brief description of the environment where the game is executed:

    • AMD Ryzen 7 3700x (not overclocked), RTX 3080, 16GB of RAM, Samsung EV 970 480GB
    • Assassin's Creed Valhalla Ultimate Edition
    • Windows 10 (18363.1256)
    • NVIDIA Geforce 461.09



    Other than this post, i've submitted a case 13830605 along with my DXDiag and MSInfo, as requested.

  • Scrottington
    3 posts

    This is a comment I just put up on the forum post over at: https://discussions.ubisoft.com/topic/88876/pc-after-tu-1-1-0-i-am-experiencing-fps-drops-low-cpu-and-gpu-utilisation/3?lang=en-US&sort=newest_to_oldest
    They are having similar issues, I'm not sure which post my comment fits best under, and who it most applies to, so I thought I'd put it up on both just to be sure.

    Hey so I had this issue ever since I got the game. At first I was running the game at low with under 20fps. I tried everything I could find on the forums and got no further. One day though, the issue seemed to resolve itself- maybe. on a whim I disabled windows search and sysmain in the windows command prompt and after that the game seemed to run fine- I was able to run it at medium at 60fps. I also uninstalled the program Overwolf. Feel free to try this everyone and see if it makes a difference for you. HOWEVER, and I cannot stress this enough- these were just the things I HAPPENED to do before my fps got better- I don't know whether these changes were what fixed the issue this is all just pure speculation.

    In fact, I don't think these were what fixed the issue- because I have continued disabling windows search and sysmain before I launch the game but yesterday, the issue reverted back to before. I did not change anything about my pc, hardware or software, this was before the 1.1.1; I can't think of a single reason as to why my performance would suddenly drop overnight. I have tried all the fixes again to no avail and since last I checked the game is running worse than it did when I first got it. I don't want to understate this so I'm going to give exact numbers again, I ran the game at 20fps on low, tried some things, then one day I was able to push the graphics up to medium AND hit a frame rate of 60 (this was after maybe 5 hours of play time), I then enjoyed the game for over 90 hours at this higher frame rate before one day, with seemingly no rhyme or reason, my performance dropped to around 10 fps.

    I made a case today with my msinfo and dxdiag attached. The case number is: 13852473.

    Sorry for the long read, I hope the things I tried work for you guys even if they didn't pan out for me. I also hope this info can help the guys working hard to fix it for everyone, I can provide plenty of other info if anyone needs.

    Love to all staff and other people struggling with this issue, be patient and kind with each other, this is frustrating for everyone involved I am sure.

    Stay safe- Scrottington

  • PeacefulGhost
    2 posts

    We work in the dark to serve the light . . .

    My thanks to the Ubisoft dev team who by the way did a great job making this game. But every good thing has a downside to it, and that's the reason I am here for.

    My game runs at 30-32 FPS Constant as I lock it in 30, where as my setup supports up to 40-50 on the same settings, but that's not what I am here to talk about.

    My game begins to lag/Hang/Stutter for eternity, once I get into any kind of conversation. For example, Starting a quest and speaking with the Quest giver, and after that game becomes unplayable. I mean literally unplayable. I am talking about 10-15 FPS at most. The only way to get out of it is to restart the game. And the way to recreate is to Start a story or any thing that has a conversation.

    This is something that has been going on since I purchased this game, but was waiting to write this to you , as there was an update on the way and I had my hopes on that, but it let me down.

    Now, I want to write this to you, I have a vide proof of the same as well, but I don't think that is acceptable. If you accept it, I will be willing to upload it to YouTube or send it to you guys to figure it out.

    May the creed guide you in the dark ~

  • JeppeND
    1 posts

    Hello Ubisoft support.
    I'm still, even after update 1.1.1, experiencing the same performance and optimisation issues that all happen at once when they happen.
    The issues that all happen at the same time are:

    • Eivor and all objects in the game freezes, but you are still able to move the camera and then the save icon in the lower right corner spins around until the freeze is over (how long the freeze lasts is very different from time to time).
    • Background of all sub menus (inventory, skills, main map, abillities, the order etc.) in game menu becomes black but you can still see all icons on the main map.
    • All icons in HUD wheel for calling mount, viking ship etc. becomes invisible.


    The time these issues last are as mentioned different for each time.

    My PC specs are:
    Intel(R) Core(TM) i7-8086K CPU @ 4.00GHz  4.01 GHz
    16,0 GB DDR4 RAM
    GTX 1080 Ti
    GIGABYTE 1TB 2.5" SSD

    Apart from the mentioned issues my PC runs the game perfectly with a high frame rate on ultra settings all the time which should be expected from the mentioned specs.
    I do have the latest NVIDIA driver update and also the latest Windows 10 update. I have also tried to disable my firewall and antivirus. And I also did memory optimization on my SSD in advanced system settings on Windows. But no luck fixing these issues. Any suggestions or work arounds? Or will you please look into these problems for a future patch?

  • Ares_SE
    1 posts

    So bought the game yesterday. Spent 2 hours troubleshooting according to the normal text book procedures.

    • It takes 1-2 minutes to even load up the game. Then another 45 seconds "checking for add-ons".
    • The game is laggy in the main menu.
    • When I start a new game, it's just not playable in any way as it's so slow.
    • I tried to do a benchmark test but that makes the game crash or stop responding.
    • I tried to lower graphic settings to medium then low without any result.
    • Tried all the steps in your troubleshooting guide /deleted temp files, updated all drivers (of course), ran msconfig to turn off all non essential processes etc, etc Even turned off all network connections, disconnected all Bluetooth and other troubleshooting stuff one might think of).
    • Running from an SSD hd


    I can run Cyberpunk and Farcry 5 without any issues at high graphical settings. Have had no issues ever with this rig at any point, ever. 

    Specs below.

    ------------------
    System Information
    ------------------
       Time of this report: 1/23/2021, 00:49:52
           Machine name: DESKTOP-920KIK9
            Machine Id: {134CF811-667A-4A80-A3B5-A0C713566537}
         Operating System: Windows 10 Pro 64-bit (10.0, Build 19041) (19041.vb_release.191206-1406)
             Language: Swedish (Regional Setting: Swedish)
       System Manufacturer: Alienware
           System Model: Alienware Aurora R6
               BIOS: 1.0.23 (type: UEFI)
            Processor: Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz (8 CPUs), ~3.6GHz
              Memory: 32768MB RAM
       Available OS Memory: 32672MB RAM
            Page File: 11449MB used, 26085MB available
           Windows Dir: C:\WINDOWS
         DirectX Version: DirectX 12
       DX Setup Parameters: Not found
         User DPI Setting: 96 DPI (100 percent)
        System DPI Setting: 96 DPI (100 percent)
         DWM DPI Scaling: Disabled
             Miracast: Available, with HDCP
    Microsoft Graphics Hybrid: Not Supported
     DirectX Database Version: 1.0.8
          DxDiag Version: 10.00.19041.0546 64bit Unicode

    ------------
    DxDiag Notes
    ------------
       Display Tab 1: No problems found.
       Display Tab 2: No problems found.
        Sound Tab 1: No problems found.
        Sound Tab 2: No problems found.
        Sound Tab 3: No problems found.
         Input Tab: No problems found.

    --------------------
    DirectX Debug Levels
    --------------------
    Direct3D:  0/4 (retail)
    DirectDraw: 0/4 (retail)
    DirectInput: 0/5 (retail)
    DirectMusic: 0/5 (retail)
    DirectPlay: 0/9 (retail)
    DirectSound: 0/5 (retail)
    DirectShow: 0/6 (retail)

  • Back4Breakfast
    1 posts

    I just re-signed up for Uplay+ because I wanted to play Valhalla, and it would appear this was a grave error of judgement. The game looks amazing, shame it doesn't perform anywhere near where previous AC titles did. I've read about 100 Reddit posts, people with worse specs than me and much better specs than me, all saying the same thing. It starts well, then you get dips and freezing, and nothing seems to fix it. I've completed the following tasks:

    - Latest Nvidia Driver installed with clean install option
    - The install is fresh from yesterday (29/01), so verifying files seemed a bit pointless, but it is done
    - Running the game at High, very slow
    - Running the game at Medium, still slow
    - Running the game at Low, still slow and practically insulting to the spec of the machine
    - Turned off all background services that I could
    - Turned off all startup applications that I could except the essential services to Windows
    - OS is up-to-date
    - Ubisoft Connect is up-to-date 
    - Benchmark ran at High, Medium and all report drops when moving through sprite filled areas. Low has the odd drop, but the game just looks poor.
    - Capped the framerate to 60 FPS
    - Field of View reduced to 90%
    - Resolution reduced to 90% (this made the game blurry so I put it back up, can't play it thinking my eyesight is at fault)
    - Run the executables as Administrator (this doesn't actually work as when you say yes to the elevation, it just hangs so I turned it off)
    - Installed a secondary page file on the same disk as the game

    I've also tried some of the more advanced items people posted, such as disabling exploitation on the Vahalla executables. I've also explicitly told the Nvidia driver and Windows to always use the Nvidia card at full power consumption whenever the Vahalla or Vahalla Plus executables are running.

    I've run all sorts of combos, even down to LOW and it still isn't great. I'm running an i9 9900 with a 2080 RTX on an SSD. It really isn't my hardware as none of the other Ubi titles I've played have ever had this problem. If anyone has any other blinding ideas on how to fix this problem, I'm all ears!

    Many thanks

  • Yesin069
    554 posts

    Since I updated to Title Update 1.1.2, I started having frequent crashes. I didn't play that much before (currently I am at 25% progress), but I never had any crashes (just one which was related to NVIDIA drivers and fixed by NVIDIA). Those NVIDIA crashed were also hard crashes which let my whole PC restart, so I stopped playing until NVIDIA fixed this with new drivers.

    Since the new update I get crashes in every play session and they are just random. Sometimes I play for hours with no crashes and sometimes they happen all 20 minutes or so until I stop playing because of the lost progress.

    Those crashes just crash the game and don't restart the whole PC. It seems really likely that the new update is the reason behind those crashes.

    Does anybody here also experience those crashes - especially since the new update?

Suggested Topics

Community Details

91
Online
192.8k
Users
32.5k
Topics
162.7k
Posts