Welcome to discussions

Quick Suggestions

  • Zangato1988
    38 posts

    @tyranusvader Sadly even with this after 1h it still starts to micro stutter. Guess patch is only solution 😞

  • vindytr
    11 posts

    I made 2 or 3 post about the same issue like you but ubisoft never answer. Mine is Ryzen 5 3600 and RTX 2060 Super. It should be stable 60 fps ultra in 1080p but like yours after 1-2 hours play the game stuttering at all states (entering town, cutscene conversation, raiding, etc). I think the problem is just ubisoft game is not optimized. I always have to restart the game every 1-2 hours play

  • TyranusVader
    121 posts

    @zangato1988 I experimented with a few settings. The one setting that seems to help stabilize frame times is "Adaptive Quality". Turning it off and adjusting anti-aliasing causes frame times to be all over the place. "Volumetric Clouds" doesn't have as big of impact on performance like it did in Odyssey and changing the quality of that setting had no impact on mitigating the stuttering. I would just leave "Volumetric Clouds" on "Very High" unless you have a potato PC.

    TL;DR Fiddle with the "Adaptive Quality" setting.

    I also heard that running the game in "Borderless Window" mode helps. That's how I'm running the game right now.

    Hint: Press F1 to turn on the performance graph. If your frame times look like an EKG having a heart attack, that means your frame times are erratic and will make the game unplayable. The idea is to make as flat as possible.

    I'll give you guys an update after my next playing session to see if the stuttering re-occurs and how long it took to show up.

  • kamasutek
    17 posts

    In my case i just needed to set FPS to 65-70 and it helped with those fps drops (i had them becouse game was jumping from 150fps to 12fps after a few minutes of playing)

  • TyranusVader
    121 posts

    After playing for about 30 minutes or so, the stuttering reared it's ugly head again. Funny enough, I've seen this happen in Odyssey but it wasn't as prevalent as it is with Valhalla. Really annoying. We'll have to live with it for the time being I suppose.

  • gel214th
    9 posts

    I installed a third party fix called SpecialK. It seems to have solved all my performance issues. https://www.reddit.com/r/pcmasterrace/comments/ju33he/ac_valhalla_specialk_for_better_frametimes_and/

    At any rate, whatever is wrong can be fixed and hopefully will be in a future patch.

  • myrddinson
    2 posts

    same for me: had some huge stuttering and frame drops. Tried everything too and finally i looked at Windows game settings and noted that audio recording was enabled. I disabled it so and game is running well since: no frames drops anymore. So try to disable Game audio recording if it is enabled as actually it worked for me.


  • Kary_Tan
    3 posts

    @gel214th It doesn't work for me. The reddit direct to the site https://discourse.differentk.fyi/t/assassins-creed-valhalla/1124 and we are supposed to download the SK_ACV and then extract to the game folder directory. Tried it and after less than 3hrs, it stutter again in Lunder city. Im on borderless window as well.

    AMD Ryzen 2700x
    2080TI
    32GB ram

  • Ganossa_
    58 posts

    I would strongly advice NOT to download 3rd party programs.

    STUTTERING FIX BELOW:

    The first couple of days after launch I also had this exact same problem with the game stuttering after prolonged playtime, especially after a couple of loading screens.
    At first I also suspected a memory leak. However, I was running the game on an older NVIDIA driver (456) -which I suspect you do too-. Yesterday I decided to download and install the latest driver 457 but didn't expect it to fix the stuttering, since I still thought its a memory leak.
    Anyhow, installing the latest NVIDIA driver entirely fixed the problem for me. So please, that is all you need to do ))

  • RastafUrius
    2 posts

    MAYBE I GOT THE "SOLUTION"

    FOR ALL THOSE HOW HAVE THE DRIVERS UPGRADED AND ALL THAT

    im having the same problem, play games like the witcher in ultra, 60 fps stable and resolution 1080p. And this valhall even in lower its freezing. So..
    I tried this:
    enter in the options if the game
    make sure ur playing in fullscreen,
    put ur fps limit in 60 ( ive benn playing in no limit when the freezes)
    put ur resolution on 1600x900 ( yeah i now, its a mess but dont looks so bad and the game don't freezes!)

    Then i put all in normal, everythings perfect, no freezes in raids, no freezes with the drakar, even the menus are smoother.
    Later ill try upgrade the graphics on high slooooowly i want to make sure this still going smooth.

    like i said its a "SOLUTION" till buggisoft does his work

    i hope this help for u and sorry my bad english!!!!!!


  • Ganossa_
    58 posts

    @rastafurius do you know anyone that has the latest drivers installed and still the issue?

  • petebaldwin
    15 posts

    @gcc1984 Me. I'm getting stuttering after 30 mins - 1 hour with the latest drivers.

    Performance in general improved quite a lot once I updated and the period before it starts stuttering is now smooth. I've got a relatively weak setup - i5 6402p and 1660 Super but I can get a stable 60fps at 1080 and since upgrading the drivers and trying the other fixes suggested (disabling full screen optimization, running in borderless mode etc), the game runs really well until around an hour into it when it starts to stutter and then gets worse and worse until I restart it.

    I generally save and re-start before a raid and have no issues at all during it so there's clearly an issue which builds up until it effects performance.

  • shawn_dougherty
    3 posts

    So, I seem to have corrected my stuttering issue. I had read that if you are using an xbox one controller via blue tooth, to change the controller settings in AC from Hybrid to Xbox. I did that and to my surprise it seems to have eliminated the stuttering! Not a place I would have thought to look for a graphics problem, but it did the trick. I was even able to crank up most of my settings to very high and stay around 60 fps, with an occasional drop in the mid/high 40's. Now to figure out whats going on with the blooming HDR in this game. Hope this helps some folks.

  • Ganossa_
    58 posts

    @petebaldwin do you run the game in fullscreen or windowed mode?

  • petebaldwin
    15 posts

    @gcc1984 Borderless. Full screen cost me around 10fps but that may have been before I updated the drivers. I’ll test it out tonight.

  • TyranusVader
    121 posts

    I tested out the Special K mod and so far, no more stuttering! Just finished a two-hour session. I suggest that you give it a shot! No harm in trying!

  • petebaldwin
    15 posts

    @petebaldwin Full-screen is now working fine (no FPS drop compared to borderless) but I'm still getting issues after an hour of playing. All of the different ideas have an impact on performance generally and make the stuttering worse or better but they aren't addressing the actual issue. Something is causing the game to start struggling after an amount of time.

    If there was stuttering from the moment the game started, it would be something that could be fixed with settings, but as the game runs perfectly and then consistently starts stuttering after an hour, it suggests something needs fixing within the game.

  • NetQvist
    37 posts

    Well I have no clue about this anymore, visited my parents this weekend where I keep my old 4790k and 1080 GTX desktop.....

    • So I ran that computer at 1080p high details, low shadows, lowest clouds. Result for a 10 hours session... No major slowdown over time. Of course the top end performance and graphics weren't as good.
    • Got home again on Sunday and then I replaced my drivers with the same old ones on this 3800x 2080 Ti desktop. Also set the graphics to the same. End result... same darned slow down at 1h+ making the game a slideshow.


    This is a joke, I haven't had an issue yet with this computer on any game. Even HZD ran perfectly on release which is not something that can be said for a lot of computers. There has to be some setting I'm still missing or it's a specific piece of hardware causing this because the software I run on these computers are literally identical.

  • Pilopo
    2 posts

    Yeah i have the same issue on a i7 8700k, 16gb ram, 2080 Ti. The game runs fine for about an 1hour give or take without any stutter at all, then it starts to stutter non stop when moving. Only restarting the game fixes it until 1hour or so has passed and the issue appears again.

    At first i thought the raids were triggering it but it does happen even just running around after the enough time has passed. Memory usage seems fine, 6gb ram free left, lots of vram free left as well.



  • NetQvist
    37 posts

    @pilopo Well I actually got mine fixed now, saw a video linked somewhere that said manually setting the virtual memory in windows made the game run better for him. While my old computer is set to automatic I decided to try it on this new one.

    Set the OS drive to 5-32 GB or thereabouts and the same to the game drive, it's running 2x M2 drives. Game is running great maxed out now.... smoothness of my old one and horsepower of the new. I'm not sure if it's manual virtual memory setting on the OS drive or the Game drive that fixed it or maybe even both is required but the difference is night and day. First game I had to do this on though for this computer and it's not exactly a unknown fix for PC games, but I'd be darned if Ubi didn't manage to screw something up that made windows do some aggressive memory handling.

Suggested Topics