ubisoft discussions

Quick Suggestions

  • Pemy_
    7 posts

    I don't know if everyone is playing this with a wireless controller, but I've found that the cause for my massive stuttering, even after patch, was playing with the controller in wireless mode. After I plugged it in with a cable it never stuttered again. Hope this helps someone 🙂

  • TyranusVader
    121 posts

    @pemy_ Hmm... that's interesting. Good to know. I'm going to give that a try. Thanks.

  • Cazora
    3 posts

    I think this has been fixed in the latest 1.05 patch without it being specifically mentioned. I'm no longer having any stuttering issues. FYI, I've been using a wireless Xbox Elite 2 controller the whole time.

  • TyranusVader
    121 posts

    @cazora Patch has been released?

  • Sapphire908
    10 posts

    @tyranusvader Well it was, today. Which means depending to your region it might be a week before you can download it.

  • TyranusVader
    121 posts

    @sapphire908 No official news announcements as of now (it's still Sunday where I am). I guess I should expect some news tomorrow then. Thanks.

  • Sapphire908
    10 posts

    @tyranusvader I just hope it will fix it. Having same issue (among plethora of others) and it is driving me crazy.

  • TyranusVader
    121 posts

    @sapphire908 I've been using the Special K fix, but it's kind of pathetic that I have to rely on a third-party to fix a glaring performance issue.

  • shyam3010
    84 posts

    @cazora what patch? on my PS4 it says the current patch is the latest one available, plus there's been no announcement from ubi about a 1.0.5 patch as far as I can tell

  • FreakzHS
    13 posts

    Good afternoon to everyone,

    I have been following this thread for quite a while now (and I'm happy to see that I'm definitely not the only one who has this problem)
    and I just wanted to know if it could be related to the config I'm using.
    I have a GTX 1050 3GB VRAM, Ryzen 5 3550H, 8GB RAM, I'm also using the Special K patch (which doesn't resolve the FPS drops problem) and I have like 75-80 FPS the first minutes I run the game at low setting and 720p.

    I'm asking this as I've contacted the Ubisoft Support and they told me it could be my VRAM which is too low.
    I've given them more details about it and told them that people with a much better config than me also have this prob, they didn't answer me since (It's been a week now).

    Looking forward to an answer,

    (Sorry if you see mistakes regarding my grammar, English isn't my mother language)

  • TyranusVader
    121 posts

    @freakzhs I have a Ryzen 7 3700X, 16 GB of DDR4 3600 and a Radeon RX 5700 XT 8GB. The special K mod for me resolves the stuttering and frame time issues. In your case, your GPU no matter is going to be holding you back. Hopefully, Ubisoft can optimize the game further to allow users such as you to have at least an enjoyable experience. If I may make a suggestion, I recommend that you upgrade your RAM capacity. It's probably the only thing that you can do as you have a laptop and it could certainly help with performance.

  • kvsh88
    49 posts

    No patch as of now. It's 8th Dec now.

  • kvsh88
    49 posts
    This post is deleted!
  • TyranusVader
    121 posts
    This post is deleted!
  • FreakzHS
    13 posts

    @tyranusvader
    Hello and thank you for your answer.

    I am desperately looking for a fix to my problem but I guess I'll just wait for a patch (and hope that 1.0.5 will fix it as mentioned before).
    Do you mean VRAM or RAM ? Because I also found out that my graphics card has a total memory of approx. 7GB, a display memory (VRAM) of 3GB and a shared memory of 4GB. What does it mean ? Could I increase my VRAM to slightly increase the performances, or is it too risky ?

    Sorry for those questions tho aha

  • TyranusVader
    121 posts

    @freakzhs From what I understand in your post, the GPU in you laptop has 3 GB of dedicated VRAM and shares up to an additional 4 GB with your system RAM. This nets you with only 4 GB of system RAM which isn't a lot. So I recommend that you upgrade your system RAM to at least 16 GB and lower the amount of shared video memory in your bios. Origins, Odyssey and Valhalla run much smoother with 16 GB of system RAM. If I had your laptop, I would set the game to 1080p and use the medium preset. Hope that helps?

  • FreakzHS
    13 posts

    @tyranusvader

    Okay, clear !

    Thank you for your help !

  • FreakzHS
    13 posts

    Good evening,

    Alright, so I upgraded my RAM to 16GB BUT after contacted NVIDIA, it is impossible for me to lower my shared memory.
    I've tried to play as you said: 1080p with medium preset. I've got 40 FPS average which is not bad but it drops after like 5 minutes of gameplay.
    In low preset, I have 100 FPS peaks with an average of ~57 FPS which is perfect but again, drops after a few minutes.

    I guess I'll just stick to the older Assassin's Creeds and wait for a patch then.

    Anyway thank you for your help still.

  • TyranusVader
    121 posts

    @freakzhs The RAM upgrade is a good investment. You won't regret it. Did you try playing the game with the Special K mod? Make sure that you set the game to "borderless".

  • FreakzHS
    13 posts

    @tyranusvader
    I did not change my game at all after I've installed the Special K mod.
    Well I'm just wondering, I've installed it before the 1.0.4 update, did it the update remove the mod ?

Suggested Topics