ubisoft discussions

Quick Suggestions

  • 1 Likes/370 Replies/4146 Views
    4 posts

    So I buy the full pack $120 and don't get to use 2hat i bought. No berserker stuff in my inventory and when I go to the store it tells me I dont own anything. This [censored] is ridiculous man. Ubisoft blew this one for sure. Fix this game...

  • Attilahunhan
    2 posts

    When i have to reach Valka's hut, the following mission is invisible on the screen so even when i reach Valka's it doesn't interact, i don't see any cutscene or something so nothing happens. Can someone help me pls? It's on ps4

  • Zalarod1976
    2 posts

    After some research on the forum, i found out that turning off "Hold Alternative" under "Interface" would help. Worked like a charm and made it past the avatar choice 🙂

  • Ubi-Ginge
    257 posts

    We've received reports from players unable to proceed further in the game as they cannot interact with the gender selection menu for Eivor once the opening sequence finishes.
    The development team has been made aware of this issue and they are currently investigating it.

    As a workaround, we would recommend applying the following workaround:
    Go to Options -> Interface -> Set Hold Alternative option to OFF

    We apologize for any inconvenience this may have caused you.

  • Efred420forlife
    1 posts

    I can't get seen to be able to choose a character.

  • Ubi-Ginge
    257 posts
    This post is deleted!
  • The_Wet_Bandit
    4 posts

    I went into the options menu and changed the "hold to select" timer down to the lowest possible value, and was then able to progress. Before this holding down the left mouse button did nothing

  • Tropikiss
    2 posts

    Não estou conseguindo fazer a escolha do personagem que eu quero jogar, ja fiz de tudo que sei e quando chego na parte de fazer a escolha pra continuar o jogo não vai.
    alguem sabe uma solução?

  • Ubi-Raziel
    197 posts
    Ich kann kein Geschlecht wählen.


    Please be aware that we are only able to offer English support on this platform. To confirm, are you unable to choose a gender?

    We are working on a fix for this issue. In the meantime, the following workaround should help you - Go to Options -> Interface -> Set Hold Alternative option to Off.

    All the best!

  • XxMaximoxX6691
    3 posts

    @quegoo you have the solution? ( i have the same problem)

  • King_Potat
    1 posts

    I can't even get past the first cutscene and my game just stops working, but still responds according to task manager. The one time I got passed it the screen was flashing, I was getting Lower than 1fps and my PC is actually good.

  • wiseguy__
    2 posts

    Game gets stuck on gender selection screen, playing on Stadia.

    1 posts

    I’m unable to select a character female/male after the first cutscene. PC had this issue and it was recently patched. I haven’t seen this being an issue on Xbox One until lucky me. I’ve uninstalled the game, deleted its content, reinstalled, hard reset my Xbox, restarted..I’m out of ideas. Anyone else having this issue or can think of any other way to get around it?

  • Ubi-Swaggins
    Community Manager 438 posts

    I am afraid that our Forum Support team currently only speak English, and French and German via their own language page.
    If you are having an issue, and cannot speak the above languages, please contact us via ticket on our website https://support.ubi.com
    An agent will get back to you in your native language.

    Official Response
  • LeGueiz
    4 posts

    what a joke

  • Tropikiss
    2 posts

    @ubi-swaggins I had said that, I am not able to make the choice of the character (gender) that I want to play, I have done everything I know and when I arrive at the part of making the choice to continue the game it will not.
    does anyone know a solution?

  • AmPxZ
    1 posts

    So I have searched everywhere for fixes for this, but none work. When I get to the first character selection page in the opening part of the game I cannot select any of the options. I have tried everything, my pc is definitely good enough for it, I let the cpu go down before doing it, I’ve verified game files, updated drivers and my OS system, set the vsync and anti analyzing to adaptive and I just reinstalled for the 2nd time, as I had problems with just launching it and had to reinstall, and it is still not working.
    Also now you cant submit a support ticket on this for some reason. Hope this is fixed soon and open to more suggestions.
    (I have an I5, Gtx 1060, 8 GB ram)

  • Ubi-Baron
    Ubisoft Support Staff 798 posts

    @AmPxZ Thank you for reporting this to us.

    If you are using a controller, then this will be due to the Hold Alternative option in the menu.

    Please try turning that off and then it should allow you to make a selection.

    Official Response
  • PTStJames
    6 posts

    @bfua turn off hold alternative under interface in options menu

Suggested Topics