Welcome to discussions

Quick Suggestions

  • ALHITCH87
    19 posts

    @shieldrys Same here, actually qute annoyed with Ubisoft for another botched release.

  • Gravelmead
    62 posts

    @luzi88alkor $I waited for about 3minites and it eventually went beyond the logo window. I think it was loading shaders.

    What was worrying was when I first launched and it was loading the Dx files. It rebooted my PC.

  • ALHITCH87
    19 posts

    @gravelmead It rebooted mine as well the other night. Very freaking as I wasn't expecting it, but everytime I load it now I get "Assassins Creed Valhalla has crashed" - then I send a crash report.

    Unsure what steps to take.

    Considering a refund.
    undefined

  • Luzi88Alkor
    Original poster 12 posts

    @grundged One of the most intelligent post ever. Thumbs up, not everyone has the same time zone.

  • Luzi88Alkor
    Original poster 12 posts

    I just had a mini update. But it still doesn't work. I'm now installing the game again on C :

  • Luzi88Alkor
    Original poster 12 posts

    Does anyone have news from Ubi-Scrap ?

  • ALHITCH87
    19 posts

    @luzi88alkor no news sadly. Just got the same update - now not even booting. Same as you trying again on C

  • Luzi88Alkor
    Original poster 12 posts

    The Ubisoft support ticket page does not let me log in. I guess overloaded? 

  • ALHITCH87
    19 posts

    @luzi88alkor Its insane, the new patch doesn't even boot up the game now.

    What in Valhallas' name have they done!

  • Luzi88Alkor
    Original poster 12 posts

    Okay, it's on. I reinstalled it on C, run it as administrator but it still wouldn't start, then I closed G-Hub and I could start it. I closed the game again and tried again with G-Hub active, still running. No idea why. 

  • Clump63
    4 posts

    I had the same problem with Watch Dogs Legion. To get it to run I have to shut down protection in my anti-virus. Both games start and run fine with protection shut down, but never get past the splash screen with it active.

    FWIW I use Emsisoft Anti-Malware. Right click it in system tray, select "Shut down protection", enter 6 digit code (PITA!) and the game runs fine.



  • ALHITCH87
    19 posts

    @luzi88alkor What is G-Hub?

  • ALHITCH87
    19 posts
    Okay, it's on. I reinstalled it on C, run it as administrator but it still wouldn't start, then I closed G-Hub and I could start it. I closed the game again and tried again with G-Hub active, still running. No idea why. 

    Can you go a bit more indepth as I haven't got a clue how to make this bloody game work.

  • Volter666
    1 posts

    @luzi88alkor
    its work

  • ALHITCH87
    19 posts

    @volter666 sorry but no, tried it, doesn't work - copied it verbatum

  • ALHITCH87
    19 posts
    The Ubisoft support ticket page does not let me log in. I guess overloaded? 

    undefined

  • ALHITCH87
    19 posts
    I have the same problem. My drivers are up to date 457.30, I'm on direct x 12. I uninstalled the game and the launcher twice. But I only get to the first window on the desktop with the Assasins logo!!!

    That is where I get to, then it closes down.

    Tried the video that @Volter666 put up - but no joy

  • caleb10011001
    1 posts

    @luzi88alkor Is your game on the C drive? All the Ubisoft games are dumb and have to be on the C drive. I had mine on the D drive and had the same issue. Switched to the C drive and it fixed the issue.

  • Chay_mo
    3 posts

    I have the same issues as some of the ones mentioned here. Initially, the game would stay on the launch screen with the logo. I uninstalled and then reinstalled the game onto my C drive (it was previously on a different ssd drive). It worked and I was able to play maybe 15 minutes of it before it started to freeze. The only option was to ctrl+alt+del and end task. After that I couldn't even get passed the menu screen. After freezing, any audio inputs to my pc were disabled and could only be enabled by restarting the system. I have once again uninstalled and reinstalled the game and have just tested it. I'm back to square one, game is freezing on menu screen and disabling my pc's audio 🤷

    My drivers are up to date, I've tried verifying the game before uninstalling and reinstalling, I've tried playin offline and nothing works. It is not hardware related.

    So annoyed that the game can't be refunded considering it doesn't work and I have barely played it.

  • HotYogii
    8 posts

    @luzi88alkor Same here - the game crashes at the start and it's very laggy - which is a massive shock given that I am using a state of the art laptop (a relatively brand new M17 R2 laptop). Not a great start to my experience.

    I've had to force quit twice already. Trying for the third time...

Suggested Topics

Community Details

196
Online
218.9k
Users
37.0k
Topics
183.3k
Posts