Welcome to discussions

Quick Suggestions

  • JayMP-
    1 posts

    @liquidm3th69 Are you certain of that, that Epic store doesn't launch the game until the 11th? Why is that.

  • HotYogii
    8 posts

    UPDATE: Surprise, surprise - it's crashed AGAIN.

    I believe it keeps crashing on the "character creation screen". But I can't be too sure because the screen doesn't load properly, it just shows a little boy fighting in the dark.



  • ALHITCH87
    19 posts

    Anyone got anything, spent most of my day trying to get this to work.

    Thank f*** im on lockdown

  • task73
    1 posts

    @alhitch87 mine doesnt even let me click it on epic games. I preinstalled and just says it will be available 11/10 um....doesnt let me click it to make anything happen and has a do not enter symbol next to the date. odd.

  • Luzi88Alkor
    Original poster 12 posts

    @alhitch87 As described above, I reinstalled it on drive C. 
    Afterwards switch off G-Hub (Logitech software). Maybe other third party manufacturers are playing into this. 
    As someone has described above, XBox controllers probably also cause problems.

  • Luzi88Alkor
    Original poster 12 posts

    @hotyogii This is the first scene

  • ALHITCH87
    19 posts

    @luzi88alkor
    Have reinstalled on C Drive - no luck.
    No controllers are turned on or linked whilst trying to get the game running.
    No crashing now, but when I boot it up it immediately closes itself down.
    Have made exceptions in protection software for it - no luck

  • Clump63
    4 posts
    Have made exceptions in protection software for it - no luck


    Exceptions don't work for me. I have to shut protection down.

    With protection on I don't get any alerts, just splash screen, black screen, back to desktop.

    With protection shut down the game starts and runs fine.

  • Luzi88Alkor
    Original poster 12 posts

    Yesterday the game could be started, today this message: 

    "The execution of the code cannot be continued because msvcp140.dll was not found." 

    (Literally translated from German.)

    It's getting better and better 😕 The solution is to download the file in question and reinstall it in the system. I have never had such problems with any game. Thanks Ubi for the great work!

  • Luzi88Alkor
    Original poster 12 posts

    So it runs again after I fixed "Microsoft Software Visual C++ Redistributable for Visual Studio 2015".

  • Chay_mo
    3 posts

    @luzi88alkor thats good news! I ended up doing this as well but it didn't seem to work for me. I did end up solving the problem by swapping out my gpu (was using a 5700xt, swapped for rx580), but I am guessing a lot of people don't have that option.

  • ALHITCH87
    19 posts

    @chay_mo I dont have that option sadly.

    Ill try what @Luzi88Alkor did with the redistributable - tried everything else other than a reinstall of Windows. I can't even get it to stay open

  • ALHITCH87
    19 posts

    @luzi88alkor Didn't work for me sadly

  • WoodyDaOcas
    3 posts

    @volter666 thanks a ton, This vid helped me run it.. once 😞 Once closes I am back to not being able to .. run it 🙂

  • ALHITCH87
    19 posts
    @volter666 thanks a ton, This vid helped me run it.. once 😞 Once closes I am back to not being able to .. run it 🙂

    Same boat my friend - its loads the ac valhalla logo and then immediately closes down

  • Clump63
    4 posts

    This is what has it working for me:

    1. Set Ubisoft Connect to run as administrator. (Right click shortcut, properties, compatibility tab)
    2. Set both ACValhalla.exe and ACValhalla_Plus.exe to run as administrator.
    3. Added entire Ubisoft folder to exceptions in anti-malware.
    4. Separately added Assassins' Creed Valhalla folder to exceptions in anti-malware.

    I no longer have to shut down protection.

    FWIW my folders are all on C:.

  • Honchocheefa
    1 posts

    @luzi88alkor i contacted the support and told them the visual c++ was the cause of my issues and they told me to reinstall the game so, kinda sucks still same issue for me even now.

  • dbgager
    158 posts

    @clump63 SO that would make your AV software the issue..not Ubisoft or the game.

  • Clump63
    4 posts

    @dbgager

    Sort of. I only have the problem with the 2 very new Ubisoft titles. Also have to run them as administrator.

  • FelixHopp
    2 posts

    @luzi88alkor I actually reinstalled windows and it didnt work. It is sooo sad ...

Suggested Topics