Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • vahndaar
    14 posts

    Yeah, and for reference In Athens in Odyssey which is arguably the most complex the game get visually the frame rate hovers around 70fps. In Valhalla in the first town in Norway, can't remember the name of it but it consists of a longhouse, a few structures and mountains I'm getting 40fps for the same settings. The game is spending a lot of GPU time doing not a whole lot. I don't know if it's scene management, occlusion culling, or wonky fire and smoke code but it's just not right.

    You're absolutely right that instead of fixing the problem they'll likely just increase the hardware requirements. This needs vulkan because the DX12 implementation here is dreck. RDR2 runs way better for massively superior visual fidelity so this is absolutely coding and optimisation related.

  • vahndaar
    14 posts

    I've exhaustively tried tinkering with all settings but nothing makes any difference, between ultra and low settings the difference is about 10 fps.

    Here is an example - all settings on their lowest possible and the GPU is pegged at 90%+ utilisation for virtually no graphical complexity.

    Basically one of the simplest scenes in AC Valhalla is running worse on low settings than one of the most complex in AC Odyssey on Ultra settings. This needs sorted!!

    Yes, it's 3440 x 1440 and yes it's running at 75 fps but I've pasted in an equivalent image from AC Odyssey for comparison:

    undefined

    For reference, in AC Odyssey, on max settings, 75fps @ 3440 x 1440 for 92% utilisation:

    undefined

  • vahndaar
    14 posts

    Just adding AC Origins as well for reference. Max settings, 3440 x 1440. Again, runs perfectly at 75fps for 90% utilisation in one of the most complex scenes.

    undefined

  • Thanhvu96
    7 posts

    Still no fix after update, should I just give up hope on them ever going to fix this bs bug....

  • Calebe_Farias
    3 posts


    Estou com este mesmo problema também

  • Nikishkin200
    1 posts

    25.12.2020
    i7-7700
    1080 GTX
    Windows updated - didnt work for me

  • Liverpaul90
    1 posts

    Hello, so is there any fix now apart from updating Windows? Because I just bought the game and it is 1,5 months after release, and I am also having this bug because though I have the latest version of windows and my graphic drivers ...

  • RedRevil
    1 posts

    Still no fix. Issue persists in all 3 games: Origins, Odyssey and now same crap with Valhalla. Embarrasing

  • Dreddmartyr
    1 posts

    Having the issue on GTX 1060, driver 460.89.
    After reinstalling windows and updating everything, including game ready drivers, I'm suddenly getting this issue. Played over 20 hours so far and all of a sudden, getting this problem. I would assume this is a priority issue that should be addressed in the next update.....?

  • Thanhvu96
    7 posts

    I caved and update windows. It works but really not worth the time (takes me 2 days to do the update and fix everything).

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone,

    The development team tried to reproduce these issues on multiple accounts and PC configurations, and did not encounter the issues described here in this thread on the latest game build. As such, they are recommending that any players experiencing this behaviour ensure that both their graphics drivers and operating system are up-to-date, and that the graphics settings in-game are appropriately adjusted to suit the specifications of the system the game is being played on.

    If you continue to see graphical artefacts of this nature, they would like you to specify the exact location you encounter these artefacts, as well as the ongoing quest / World Event you are completing. A brief list of your PC's specifications as well as the GPU driver number you are running would also be needed.

    Thank you all for your reports, and I hope that this issue has been resolved for many of you already. I'm around to assist further if not!

    @Kanjozoku_96 @refan7 I'm afraid updating to the latest OS version is part of our troubleshooting - if we cannot see this done, we're unable to investigate further effectively. I understand circumstances beyond your control may prevent you from updating your OS, however I regret to say that we cannot assist further unless this is done. I'm sorry. 😞

    @Starcadian If you're still unable to launch the game, please reply to a more appropriate thread for this issue and we can look further into this with you there.

    @vahndaar Please do not derail this thread by discussing performance-based issues here; this thread is just for the graphical artefacts. Please post on a more appropriate thread for game performance or create your own. Thank you!

    @Thanhvu96 Thank you for confirming that updating your OS resolved the issue for you. I hope that you'll enjoy playing Valhalla!

    Official Response
  • altair_31186
    1 posts

    @ubi-baron
    Hi Currently using Geforce 1070 with latest driver installed and experiencing light flicker in AC Valhalla whenever there is a cinematic scene..
    undefined

    i saw some forums in 1080series and 1050ti's are fixed.. hope you can solve also in 1070's series

  • Sparhawk122
    21 posts

    For me even at 3440x1440p (resolution scale 100%) and some anti-aliasing applied. The fire effects are very pixelated. Like really pixelated....

  • Arhtym
    1 posts

    still having it even update to the latest nvdia driver : 461.09
    Im using 1060 6gb graphic card and using OS : Window 10 Enterprise N 2016 LTSB version, already up to date too
    undefined

  • An_unperson
    3 posts

    Same problem still exists after multiple graphic driver/windows/game update.

    My specs:
    windows 10 pro
    Intel® Core™ i7-8650U @1.90GHz
    GeForce GTX 1060
    16Gb RAM

    undefined

  • Braunitta
    5 posts

    Hey guys.



    Please see the video which shows the subject matter issue. I have tried ALMOST everything: (i) updating windows; (ii) updating drivers and also backing up previous/pre-previous versions; (iii) reinstalling the game; (iv) checking the game files; (v) contacting the support and going through all the recommended solutions (i.e. win+R commands like disk checking, DISM, etc); (vi) manipulating ALL of the nvidia 3D settings; (vii) playing also with ingame settings; (viii) working with the ACValhalla file; (ix) going through all the forums ever existed regarding this problem; (x) going through all youtube comments where any solutions have been noted. Nothing helped and now I am here to ask for solution from the game developer.

    Please.

    Thanks.

  • Ubi-Wan
    Ubisoft Support Staff 630 posts

    @braunitta Hey there! Thanks for reaching out with this. I'd like to have you create a new ticket with our dedicated support team. Please ensure you've completed all the steps found in this FAQ, and feel free to attach your MSinfo file to the ticket, as well! This would be greatly helpful to our team.

    Official Response
  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Please accept my apologies for the delayed reply everyone. 🙂

    @altair_31186 - Hey there, are you still having this issue on driver version 461.40 for your 1070, which released in late January? If you haven't yet done so, please update to this version, and make sure that you are running the latest version of Windows as well. Should issues persist, please reply to me here if issues persist, and let me know where in the game you are, either by way of an image or short video clip. Thank you!

    @Sparhawk122 - The issue you are describing does not seem to fit in with the topic of this thread, as this thread is for graphical artefacts in the game. Please reply to a more appropriate thread or create your own for pixelated graphics. Thank you.

    @Arhtym - Could you please ensure that you are running the latest driver version for your GPU (461.40, released in late January) and also the latest version of Windows, and then see if these graphical artefacts persist in-game for you? If they do, as above, please let me know, and include an image / video clip to demonstrate. Thank you!

    @An_unperson - Hey there! Just as it isn't quite clear from your image - are the artefacts you are seeing appearing in any specific places? Where are you in your image? Can you confirm if these issues are still ongoing after updating to the latest driver version for your GPU (461.40, released in late January) and the latest version of Windows? Thanks!

    Official Response
  • Braunitta
    5 posts

    @ubiwan everything indicated in FAQ had already been done.

  • Braunitta
    5 posts

    @ubiwan would you please suggest a fix or a patch or anything besides casual "create-a-ticket-we-will-not-reply"

Suggested Topics

Community Details

35
Online
129.0k
Users
22.2k
Topics
115.1k
Posts