Welcome to discussions

Quick Suggestions

  • SOLVED [RESOLVED] [PC] Fire / Smoke / Dust effects causing multicoloured graphical artefacts | POST HERE

    26 Likes/262 Replies/7432 Views
    TyberiusKurk
    5 posts

    Third day, still not able te use the product i pay for. i tried all the possible solution ( again, but an error could have come from me, who know ? ) and still have the acid trip smoke. I don't even want a refund, i just want to play the goddam game and i'm sick of waiting for it.





  • gmantis78
    2 posts

    Is Ubisoft support even going to reply further than the Win 10 update non solution?.Come on Ubisoft a lot of paying enthusiasts left in limbo unable to play their game properly...knowing if there is going to be a fix at least would be nice playing like this is not the experience I got excited about...

  • TheSasKun
    5 posts

    @ubi-baron when will our problem be added to the list of known issues at least? Will we get a fix in the next patch?

  • Starcadian
    7 posts

    Any news or acknowledgement of this from the dev team?

  • heksbr
    1 posts

    @Ubi-Baron many people here are demanding an answer since we spend money for a broken game. at least a reply will be polite.

  • Pierogi.Warrior
    1 posts

    Same here. I have very bright flashes occuring randomly where shadows or light reflections on water are supposed to be. It varies in the flashing speed. Also it seems all the spider webs are glowing with this very bright white light.

  • vahndaar
    43 posts

    So after much frustration I can confirm that fire and smoke effects are destroying framerates. Pulling out a torch alone drops fps by around 5, so when in settlements with lots of torches, smoke, fire or other particle effects then the framerate absolutely tanks. I have a sneaking suspicion cloth physics for flags and banners might be an issue as well. Basically anything with physics. Performance is worse at night than during the day for this very reason. This is the same problem that existed in Origins, Odyssey never had this issue. In Origins torches would tank framerate and it was fixed in a patch I think. This framerate drop is exponentially higher when antialiasing is turned up, again exactly the same behaviour from Origins. I have no idea what the game is doing with particle effects but it is simply eating GPUs and processing power on PC. In areas with no particle effects, everything runs fine. We're talking about going from 80-85 fps in areas with lots of particle effects down to about 45 - half frame rate almost. The GPU is spending huge amounts of time doing nothing but chewing cycles on this stuff.

    For those struggling with performance, turning down antialiasing is the biggest benefit until this is fixed as it currently just compounds the problem.

    Also for those having issues with flickering and just wierd graphical corruption and stuttering try a clean driver install and/or resetting nvidia control panel to default settings. I was getting massive graphical issues and conflicts which turned out to be a conflict with nvidia control panel settings. Personally, forcing sharpening through nVidia control panel definitely caused graphical corruption. Might not solve all problems but definitely helped on my setup.



  • OlafsOsh
    10 posts

    @vahndaar so, are you saying, that tinkering with Nvidia setup you got eid of those fog and smoke glitches?

  • nafninja23
    1 posts

    Yep I am still getting this a lot - see here for examples: https://imgur.com/gallery/mrMbM92

    Restarting the game seems to sometimes fix it for a whole session. Sometimes the "glitches" get worse as the game continues.

    I believe I have the latest windows updates.

    I am playing of widescreen. GPU: RTX 2070 Super.


  • need4mirrors
    3 posts

    I'm getting similar lighting/graphics glitches on Xbox Series X, I made a post here with a quick screencapture: https://discussions.ubisoft.com/topic/78931/very-distracting-lighting-shadow-bugs-on-xbox-series-x?lang=en-US

  • Nagru87
    16 posts


    oh boy even on console? 0_0




  • vahndaar
    43 posts

    Fiddling with Nvidia control panel got rid of the massive flickering I was getting, don't know if it is exactly the same I was getting huge flashes of black and white and a wierd border around the screen. Shadows were glitching and everything would just go really bright then dark. Really wierd.

  • Cyctemshock
    1 posts

    Same bug happened on my PC,
    with nvidia newest driver 457.30,windows10 updated to newest version and no corrupted files.
    Graphics card :Titan X (same generations as GTX 980).

    Should we just ask for the refund now?

  • Trickyishh
    1 posts

    Experiencing the same issue. Windows is fully updated, running on the latest playable Nvidia driver, 457.09 (game won't run on 457.30 for me, rolled it back). Hardware is an i9-9900K and an RTX 2060. Validated game files multiple times and tried adjusting graphics settings in game and in Nvidia settings to no avail.

    Hope a patch comes out soon, I haven't even made it past the child phase with the graphics going nuts. It's pretty hilariously unplayable right now, not sure how this made it past alpha, beta, and the day 1 patch. Guess close doesn't cut it except for in horseshoes, hand grenades, and AAA games.

  • makeo7
    2 posts

    Personally I have already requested a refund via the epic platform. Maybe I'll buy it again later.

  • JIeMypylllka
    21 posts

    Dear, dev. When this bug will be fixed? I wanna play this game. JUST ADD BUTTON IN OPTIONS: «turn off fog ». Im ready to play with glitch on the snow.))) xDDDD
    (1080ti, 32, i7-8700, win 10 last upd, driver last, dxdiag and ms... was been sent to you 10.11.2020) Go go go fire in a hole!)))))

  • OlafsOsh
    10 posts

    And the acid trip continues... Gosh.

  • TheLittleTomato
    13 posts

    I am actually not willing to play with the glitch on the snow. And if the torches, the smoke and possibly the banners are as bad for the FPS as @vahndaar says, it is also up to Ubisoft to fix this.
    What is even worse than the bug itself is that Ubisoft has not replied yesterday and does not seem to reply today since @Ubi-Baron is offline. We don't even know if they are still working on it or if they just assume that updating Windows must fix it.
    I will probably ask for a refund if they don't fix it during the weekend. I'm pretty annoyed tbh.

  • Schnitevlug
    1 posts

    Same problem here, i tried everything but nothing works.

  • Josua54
    3 posts

    @ubi-spud
    Kindly follow up on the thread entitled "Bug with fire and smoke" if you can. The same problem is highlighted there, with numerous users having complained in this regard. The URL is: https://discussions.ubisoft.com/topic/77171/bug-with-fire-and-smoke?lang=en-US
    Ubi-Baron did reply there a few times, but has been quiet for a while and the latest comments will show that users are getting rather frustrated. Whatever the cause of this anomaly, it makes the game unplayable.

Suggested Topics

Community Details

161
Online
220.4k
Users
37.3k
Topics
184.9k
Posts