Welcome to discussions

Quick Suggestions

  • TyberiusKurk
    5 posts

    @Ubi-Baron

    I did exactly as you said and it didn't do anything. not gonna lie, i'm pretty bothered to have payed 60 Euro for a game i can't even play with a computer that can make him turn easily. Please, do you have any other possible solution ?

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hello there,

    Following the release of TU 1.2.2, this issue has been marked as resolved.

    If you are still encountering these multicoloured artefacts in-game, please don't hesitate to update this thread so we can take a closer look. When sharing your report, please include all of the following information:

    • Was the behavior encountered after you just launched the game for the first time? Or did it begin mid-playthrough?
    • Where have you encountered this behaviour? Please specify the location/mission where you noticed these graphical issues.
    • Please can you provide us with a video that shows the issue happening in-game?


    Additionally, could you open a support ticket and submit your MSinfo and DxDiag, as these will be helpful for further investigation. Once you've opened a ticket, please share your ticket number with us so we can ensure these files are passed on to the development team.

    Thank you 😊

    Official Response
  • lesvannes
    4 posts

    I was having this same problem. It began during the "child Eivor" sequence and continued all the way up to establishing the settlement. It seems to occur on particle effects like breath, scuff, fog, smoke, etc. Based on the system requirements, my PC should be capable of supporting the graphics.

  • Starcadian
    7 posts

    Same, on a 980 GTX, latest Windows 10. It's pretty clear it's a sprite transparency issue and there's no setting for this, please fix!!

  • TheLittleTomato
    13 posts

    @Ubi-Baron
    I followed the guide and the scan showed no corrupted files. I restarted Valhalla and the bug was still there.
    So even a fully-functioning updated version of Windows still shows the bug ... it's been 2 days, we've spent 60€ and we can't play the game ..

  • lefthorse
    6 posts

    @ubi-baron As is the case with others, updating Windows isn't an option for me (conflicting software necessary for work). When might we expect to see a fix for those of us in this predicament? Thanks.

  • DZNUTS.Thecollo
    2 posts

    I also cannot upgrade for work purposes, Windows 64 bit are the specs, I have this 90£ on a game I cannot play -- Odessy works so it cant be that hard to fix can it @Ubi-Baron

  • sparda1012
    5 posts

    @ubi-baron

    GPU: GTX 1080
    Drivers tried: 399.24 - 441.37 - 457.09

    The issue started with child Eivor, haven't played further than that, waiting for a fix

  • OlafsOsh
    10 posts

    This should be in Known Issues thread by now...

  • TheLittleTomato
    13 posts

    @OlafsOsh
    I checked about two hours ago and it wasn't there yet ...

  • TheSasKun
    5 posts

    I have up to date windows version, and i did the system scan, no errors showed up. And the bug is still there. Is it gonna get fixed if possible?

  • Vadaa87
    5 posts

    @ubi-baron It makes no difference, this need to be fix asap

  • capcorj
    2 posts

    @capcorj solved by installing all the latest windows updates

  • Nagru87
    16 posts

    nah im not going for update got a stable win 10 version everything else runs great. and Im not 100% sure that updating windows 10 will help not worth

  • UncleOleg97
    3 posts

    Cannot proceed Kjotve fight in the 2nd half of it (see Attachment).

    undefined
    Have some graphic bugs, artefacts (see Attachments).
    I have the latest version of Windows x64 and graph. driver for GTX 1060.undefinedundefinedundefined

  • OlafsOsh
    10 posts

    @nagru87 Plenty /majority/ of people did not found it successful, so fingers crossed.

  • Patsthlm
    7 posts

    Updating windows 10 solved it for me, I had an old version of windows 10 because updating always made my audio drivers stop working

    Now the game works at least

  • SK1CROW69
    4 posts

    My Windows 10 is fully updated. Microsoft and game files were all verified. The problem still exists. Why is this bug/issue still not posted under Known Issues??

  • sparda1012
    5 posts

    Why is this not on the Known Issues section? several people is having this same issue

  • sparda1012
    5 posts

    @ubi-baron

    Why is this not on the Known Issues section? several people is having this same issue

  • aerkfeed
    6 posts

    If the only way to fix this is to update or reinstall Windows then I am doomed. I don't understand I don't have this problem in Odyssey then how come I have this in Valhalla? Isn't it the same game engine?

Suggested Topics

Community Details

48
Online
141.7k
Users
25.0k
Topics
129.7k
Posts