Welcome to discussions

Quick Suggestions

  • SOLVED [RESOLVED] [PC] Fire / Smoke / Dust effects causing multicoloured graphical artefacts | POST HERE

    26 Likes/262 Replies/7344 Views
    Ubisoft Support Staff 1091 posts

    Hello everyone,

    The development team tried to reproduce these issues on multiple accounts and PC configurations, and did not encounter the issues described here in this thread on the latest game build. As such, they are recommending that any players experiencing this behaviour ensure that both their graphics drivers and operating system are up-to-date, and that the graphics settings in-game are appropriately adjusted to suit the specifications of the system the game is being played on.

    If you continue to see graphical artefacts of this nature, they would like you to specify the exact location you encounter these artefacts, as well as the ongoing quest / World Event you are completing. A brief list of your PC's specifications as well as the GPU driver number you are running would also be needed.

    Thank you all for your reports, and I hope that this issue has been resolved for many of you already. I'm around to assist further if not!

    @Kanjozoku_96 @refan7 I'm afraid updating to the latest OS version is part of our troubleshooting - if we cannot see this done, we're unable to investigate further effectively. I understand circumstances beyond your control may prevent you from updating your OS, however I regret to say that we cannot assist further unless this is done. I'm sorry. 😞

    @Starcadian If you're still unable to launch the game, please reply to a more appropriate thread for this issue and we can look further into this with you there.

    @vahndaar Please do not derail this thread by discussing performance-based issues here; this thread is just for the graphical artefacts. Please post on a more appropriate thread for game performance or create your own. Thank you!

    @Thanhvu96 Thank you for confirming that updating your OS resolved the issue for you. I hope that you'll enjoy playing Valhalla!

    Official Response
  • altair_31186
    1 posts

    Hi Currently using Geforce 1070 with latest driver installed and experiencing light flicker in AC Valhalla whenever there is a cinematic scene..

    i saw some forums in 1080series and 1050ti's are fixed.. hope you can solve also in 1070's series

  • Sparhawk122
    21 posts

    For me even at 3440x1440p (resolution scale 100%) and some anti-aliasing applied. The fire effects are very pixelated. Like really pixelated....

  • Arhtym
    1 posts

    still having it even update to the latest nvdia driver : 461.09
    Im using 1060 6gb graphic card and using OS : Window 10 Enterprise N 2016 LTSB version, already up to date too

  • An_unperson
    3 posts

    Same problem still exists after multiple graphic driver/windows/game update.

    My specs:
    windows 10 pro
    Intel® Core™ i7-8650U @1.90GHz
    GeForce GTX 1060
    16Gb RAM


  • Braunitta
    5 posts

    Hey guys.

    Please see the video which shows the subject matter issue. I have tried ALMOST everything: (i) updating windows; (ii) updating drivers and also backing up previous/pre-previous versions; (iii) reinstalling the game; (iv) checking the game files; (v) contacting the support and going through all the recommended solutions (i.e. win+R commands like disk checking, DISM, etc); (vi) manipulating ALL of the nvidia 3D settings; (vii) playing also with ingame settings; (viii) working with the ACValhalla file; (ix) going through all the forums ever existed regarding this problem; (x) going through all youtube comments where any solutions have been noted. Nothing helped and now I am here to ask for solution from the game developer.



  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @braunitta Hey there! Thanks for reaching out with this. I'd like to have you create a new ticket with our dedicated support team. Please ensure you've completed all the steps found in this FAQ, and feel free to attach your MSinfo file to the ticket, as well! This would be greatly helpful to our team.

    Official Response
  • Ubi-Woofer
    Ubisoft Support Staff 1091 posts

    Please accept my apologies for the delayed reply everyone. 🙂

    @altair_31186 - Hey there, are you still having this issue on driver version 461.40 for your 1070, which released in late January? If you haven't yet done so, please update to this version, and make sure that you are running the latest version of Windows as well. Should issues persist, please reply to me here if issues persist, and let me know where in the game you are, either by way of an image or short video clip. Thank you!

    @Sparhawk122 - The issue you are describing does not seem to fit in with the topic of this thread, as this thread is for graphical artefacts in the game. Please reply to a more appropriate thread or create your own for pixelated graphics. Thank you.

    @Arhtym - Could you please ensure that you are running the latest driver version for your GPU (461.40, released in late January) and also the latest version of Windows, and then see if these graphical artefacts persist in-game for you? If they do, as above, please let me know, and include an image / video clip to demonstrate. Thank you!

    @An_unperson - Hey there! Just as it isn't quite clear from your image - are the artefacts you are seeing appearing in any specific places? Where are you in your image? Can you confirm if these issues are still ongoing after updating to the latest driver version for your GPU (461.40, released in late January) and the latest version of Windows? Thanks!

    Official Response
  • Braunitta
    5 posts

    @ubiwan everything indicated in FAQ had already been done.

  • Braunitta
    5 posts

    @ubiwan would you please suggest a fix or a patch or anything besides casual "create-a-ticket-we-will-not-reply"

  • Braunitta
    5 posts

    @ubi-woofer nothing helped. Lates drivers, latest version of windows. AC Odissey works PERFECT, AC Valhalla is hell bugged.

  • Braunitta
    5 posts


    Ubisoft support just ignores my issue, well done folks! I was waiting 2 MONTHS HELLO!

  • An_unperson
    3 posts

    @ubi-woofer Hi. Thanks for the reply. I just installed the game update and the problem still occurs. I have the OS and graphic card driver updated to the newest version. The artefacts always occur for smoke pillars, fire effect or the snow/dirt particles when the character/horse is sprinting. The screenshot was during the "an uncommon proposition" quest, I believe in some longhouse, but the same problems occur and are extremely bad in every indoor environment with many torches/fire.

    The same problem will also occur during the benchmarking video. The fire and smoke pillars always phase in and out and shine in bright colors. One interesting observation is that although I have Windows 10 pro installed on my computer, the benchmark tells me that I have the windows 10 business version installed. Maybe it is a part of the reason why the problem is occurring? Hopefully this problem can be fixed soon.

  • An_unperson
    3 posts

    I seemed to have fixed the problem by manually installing the newest windows update from windows 10 update assistant ( which you can download from here https://www.microsoft.com/en-au/software-download/windows10). There was quite a huge update despite my check for updates in the system setting>>update& security told me my windows was already the newest version.

  • Wh0C4res19
    5 posts

    @vahndaar still not fixed fyi

  • Wh0C4res19
    5 posts

    can we get straight answers?
    1) If DevOps working on fixing it or not? If yes, what is the priority and due date?
    2) Also could you state the minimum OS version which helps to aid this glitch?
    3) Can I demand refund for this? EGS Ultimate version

    Regarding troubleshooting and raising the ticket - I am sorry but I don’t believe it will help, but rather waste even more of my time. I bought game back in January, waited up until late March, spent two days researching and updating my OS, drivers etc. That is not experience that I want to continue. 
    I might play later if it will be fixed, but if not - I will give up on a game and would like to get my money back since I was not able to play. Store only stated that I need windows 10 (x 64 bit).

  • Calebe_Farias
    3 posts

    Eu resolvi o problema no meu laptop!
    Aparentemente o driver do meu laptop estava causando este defeito, e devido a outros problemas não pude atualizar para a versão mais recente, entretanto, instalei outra versão (451.48) que funcionou perfeitamente, não apareceu mais estes artefatos multicoloridos. peço que vocês tentem instalar esta versão que falei.

  • Ubi-Borealis
    Ubisoft Support Staff 3626 posts

    Hello there!

    I apologise for the delayed response. Thank you for continuing to update this thread with your experiences with multicoloured graphics in-game. I'm sorry to hear that this issue has persisted for some of you.

    The development team has had trouble reproducing this issue whilst investigating further. If you are encountering this issue in-game, please can you first try running through these PC troubleshooting steps to see if this helps to resolve the issue. In particular, please ensure that you have fully updated Windows. The team have found that having Windows update 2004 installed should resolve the issue for you.

    If the issue persists after trying these steps, please can you provide us with the following information:

    • Was the behavior encountered after you just launched the game for the first time? Or did it begin mid-playthrough?
    • Where have you encountered this behaviour? Please specify the location/mission where you noticed these graphical issues.
    • Please can you provide us with a video that shows the issue happening in-game?

    We can then pass this along to the development team as they investigate this further.

    @Braunitta - Thank you for sending us a video! Does this issue still persist for you? If so, please can you try the troubleshooting steps provided above?

    @An_unperson - Thanks for updating us, and for letting us know that manually updating Windows resolved the issue for you.

    @Wh0C4res19 - I'm sorry to hear you're encountering this issue in-game. If the above troubleshooting steps have not helped to resolve the issue for you, please would you be able to provide us with the additional information for us?

    @Calebe_Farias - I'm afraid we're only able to offer support in English within these forums. Would you be able to provide a translation of your post? Alternatively, if you'd like to speak to a member of your regional team, you're welcome to open a support ticket or start a live chat!

    Thanks! 😊

    Official Response
  • Hyagodk
    1 posts

    Still no fix for that ? seems like updating windows not working for everyone sad

  • Calebe_Farias
    3 posts

    @ubi-borealis I solved the problem on my laptop!
    Apparently my laptop's driver was causing this defect, and due to other problems I couldn't update to the latest version, however, I installed another version (451.48) that worked perfectly, these multicolored artifacts didn't appear anymore. I ask that you try to install this version that I talked about.

Suggested Topics

Community Details