Welcome to discussions

Quick Suggestions

  • Tankan8er1
    Original poster 17 posts

    Well everyone i cant figure out what to do nothing seems to work all I can do is just sleep and wait to see what they do later today bye all hope someone can figure it out. Ill check the post when I wake up

  • Swifty__
    13 posts

    @Tankan8er1

    Yeh mate, ill keep a lookout and report back here if I see anything that might help. enjoy the rest

  • sp1991sterling
    2 posts

    @sp1991sterling I updated my driver. Fixed the issue.

  • Swifty__
    13 posts

    @sp1991sterling

    Your graphics card driver through Nvidia? Mine is up to date and still wont work for me

  • GTECreedSans
    3 posts

    @swifty__

    i would try to update your driver anyway. I've just loaded in. after the cutscene of ymir all i get its a white screen and laughter but my driver is out of date and i didn't even realise so im updating now and im waiting to see if anything happens.

  • S-T-R-l-K-E-R
    6 posts

    had the same problem.
    closed AFTERBURNER then it ran on my next attempt

  • Swifty__
    13 posts

    @s-t-r-l-k-e-r

    Whats Afterburner, I got nothing running by the name of that. I tried looking it up



    @GTECreedSans - Yeh i have everything updated that I could possibly update haha. been trying to tweak this for like atleast 8 hours now

  • Captain-Vigo
    4 posts

    I had the white loading screen bug after the first cutscene but i Hard closed my game, changed my setting to fullscreen instead of borderless and turned V-sync on with adaptive. I managed to get past the loading screen into some gameplay as the child Eivor. But when you reach the moment after it to select Male or Female route. the game breaks. i can move my cursor around hover over each gender choice but it doesnt actually let me select anything. Both Mouse and controller just do nothing.

  • GTECreedSans
    3 posts

    just a side note, it doesn't make a difference if you launch it from nivada or ubisoft it doesn't load regardless. the white/black loading screen after the ymir cutscene still appears and doesn't go away.

  • Captain-Vigo
    4 posts

    ok update .. was able to get past the gender selection screen. There was an option under Interface for "alternate hold for menu" . turn that off and it let me choose the gender ok.

  • Xekilon
    1 posts
    when I press play I have the square logo in the middle of the screen but nothing happens the games do not consume any resources apart from 94mb of ram


  • GTECreedSans
    3 posts

    @captain-vigo

    this actually worked? idk how but i did this but my game started and i'm playing as young evior

  • Swifty__
    13 posts

    @Tankan8er1

    This worked for me

    Finally found a working solution!

    1. Open NVidia Control Panel
    2. Manage 3D Settings
    3. Program Settings
    4. Select "ACValhalla.exe"
    5. Select "High-perfomance NVidia processor"
    6. Press "Apply"
    7. Restart Game


  • drdeath12-uk
    7 posts

    seems to be a running problem with ubisoft lately games crashing constant updates needed friends pc restarted itself yesterday after playing the division with no temp problems or part problems they need to sort things out

  • Tankan8er1
    Original poster 17 posts

    @swifty__

    Thank you ill defiantly try this

  • HotYogii
    8 posts

    @tankan8er1 I have the same issue!

  • HotYogii
    8 posts

    @swifty__ thanks - fixed it for me. Thank you!

  • Tankan8er1
    Original poster 17 posts

    @hotyogii
    I cant find where to manage 3D settings when I open the control panel I don't even have the option to change settings.

  • Tankan8er1
    Original poster 17 posts

    @swifty__

    My computer uses GForce drivers and not Nvidia control panel. Can anyone help me figure out what to do?

  • Sunrise_uk
    5 posts

    Faced this problem too. After the story of Ymir - a white screen and the Animus logo. Voices are heard but nothing happens. CPU load 100% The game is installed in the "default U.Con. folder" on the C:. GeForse Driver 457.30. Any help would be welcome. Including help from Ubisoft 🙂

Suggested Topics

Community Details

91
Online
192.9k
Users
32.5k
Topics
162.8k
Posts