Welcome to discussions

Quick Suggestions

  • JeffMorgan1983
    32 posts

    OMG!!! FINALLY! Two months later and I can start playing now. I reall don't know what this was all about. Like, how did this mess-up even happen in the first place?

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    I apologise for the delayed update. Following TU 1.2.0.1, the development team has marked this issue as resolved.

    If you are still having trouble unlocking achievements on PC following this update, please can you provide us with the following information:

    • Which achievements are you unable to unlock?
    • Have you tried repeating actions, if able to (such as in "Silent Viking" and "Seahorse")?
    • Have you been able to try completing additional quests? Some players have reported that completing settlement quests, such as Petra's archery challenge, has allowed them to trigger story achievements to unlock.
    • If you're able to provide any images/video that shows you have met the criteria but the achievement hasn't unlocked, this would be helpful. This could be an image that shows your completed quest log and missing achievement, or a video that shows you completing an action and the achievement not unlocking.


    We can then pass these reports to the development team for further investigation.

    @Jackov15 & @Lidi_Melo - Are you still missing achievements in-game after meeting the requirements following TU 1.2.0.1? If so, please can you provide us with the information requested above.

    @RedIndianRobin - We don't yet have any new information to share regarding the missing achievement pop-up in-game. We've reached out to the team to see if we can get any new updates to share with you all.

    @Arthefran - We don't yet have any new updates to share about making a public API for achievements. I've reached out to the team to see if we can find out any additional information.

    Thanks! 😊

    Official Response
  • erico360
    16 posts

    Take my Hand
    The Enemy of My Enemy
    Disorder of the Ancients

    Didn't unlock for me and I retried Disorder of the Ancients but I think that one is fully bugged.

  • TimotheusFlavii
    4 posts
    @ubi-woofer Most achievements did indeed retroactively unlock, however, some inexplicably, did not, including:

    - "Take My Hand" - Complete the Cent Arc
    - "The Enemy of My Enemy" - Complete the Wincestre Arc
    - "Disorder of the Ancients" - Eliminate all targets of the Order of Ancients
    - "Completionist All the Way!" - Complete all territories

    I completed all arcs, I eliminated all targets, and completed all territories, so why did these achievements not unlock?

    I can now confirm that "Completionist All the Way!" did ultimately unlock - apparently, there was one wealth location in East Anglia which had become bugged out, and I thus had to redo.
    I have now unlocked all achievements except for the three listed in my previous message.

    Furthermore, the challenge "The Saxon Slayer", for which you have to raid five monasteries, is still bugged out - although I completed all the raids, it still shows 3/5 in the Ubisoft Connect client. Do you know whether this will be addressed in a future update, @Ubi-Woofer ?
    The challenge "Hall of the Slain" also remains impossible to complete, due to the fact that in more than 100 hours of gameplay, I never saw any prompt to avenge the death of another player.


  • Ubi-Woofer
    Ubisoft Support Staff 1029 posts

    @JeffMorgan1983 Enjoy the game! Let me know if you encounter any issues with unlocking achievements as you complete their requirements.

    @erico360 Thanks for your report, I'll add it to the discussion I've started with the developers regarding these three achievements.

    @TimotheusFlavii Thanks for confirming it's just the same three achievements now missing for you. With regard to the "Saxon Slayer" Connect Challenge, there's an investigation open for this and the issue was already successfully reproduced. Similarly, there's one in progress for "Hall of the Slain", as several players have mentioned finding a defeated player to avenge has been difficult. I personally didn't come across a single one during my 220+ hours of playtime, so I'm personally invested in seeing how that investigation goes too!

    Official Response
  • hroozenbeek
    1024 posts

    @timotheusflavii As to the 'Hall of the Slain'-challenge: Same here. Not a single opportunity in 200-odd hours of gameplay.

    (I had no problems completing the 'Saxon Slayer'-challenge, however.)

  • Kormac67
    656 posts

    @ubi-woofer Update:
    Patch notes are there ingame now.

    Did the Reda quests, no achievements.

    Tried "assassinate an enemy from your horse" (pretty sure never had tried that).
    Game showed an Ubisoft connect popup - and crashed. 😄
    Now achievements are there (all as achieved today sadly).
    11 are missing though: Cent, Winchestre, all Order, all territories (should be), all flytings, Excalibur, first Anomaly, all Alpha animals, 10 curse symbols, Thor's helmet, Mjolnir.

  • hroozenbeek
    1024 posts

    @ubi-woofer The same three achievements (Take My Hand, The Enemy of My Enemy, and Disorder of the Ancients) did not unlock for me too. By the way, the other achievements did not unlock immediately after completing one of Reda's daily quests, but several minutes later at the exact moment when I killed the target of the next daily quest, thus before this quest was actually completed by confirming the kill (I saw them unlocking on my second screen with Ubisoft Connect open). Was that a coincidence?

    And I guess I have some fun activities yet to do. Sliding in the snow, swimming with my horse, getting thrown 30 meters away... How is it possible I missed those? 😉 (And I thought I had lit all braziers on Hadrian's Wall just for the fun of it, but apparently I missed some.)

  • Kormac67
    656 posts

    @ubi-woofer Got "wielding Mjolnir" by just doing that (killing a patrol, wielding alone is not enough).
    Game did not crash this time.
    It said it sent a screenshot to Ubisoft connect, but I can't view it there.

    And it has fulfilled more achievements, now only Cent, Winchestre, All Orders, all territories (maybe) are missing.

    "It's not a bug, it's a feature" is now there (Valhalla in a nutshell).

  • Vilemos
    58 posts

    @ubi-woofer
    60 hours in (46%) and so far every achievment I should have completed seems to be in order. (hopefully those 3 achievments still not unlocking for others will get fixed soon)
    Sorry for the harsh word in the past, but it's been long 2 months.

    Thank you and have a good one

  • Chottodare
    3 posts

    What about, pc notification, pop up when achievement is completed? I thought its obvious for this system. It is not fun checking if it's completed again and again. 😢

  • cavveman
    84 posts

    @chottodare
    I'm somewhat thankful I'm not receiving like 20 popups in a row when everything is awarded at the same time.

  • RivereyesGR
    12 posts

    Cent Story Arc achievement did not unlock for me, either.

  • Chottodare
    3 posts
    This post is deleted!
  • kwasowsky
    5 posts

    @chottodare It's a Connect issue. In New Dawn (new overlay) had the same thing. I had to check everytime if achievement is unlocked or not.
    Old uPlay overlay (Far Cry 5 and older) doesn't have same issue. We have to wait until it'll be fixed.

    I'm glad that Valhalla finally got the achievements tab. 😇 Although I waited so long that hype already passed so I'm gonna wait a little longer to be sure that everything is fixed with achievements meanwhile focusing on other games.

  • Chottodare
    3 posts

    @cavveman It would be only at first startup after the update? Achievement usually are not that common? I don't think you understood me.

  • auridulis
    48 posts

    @ubi-woofer Thanks a lot for mentioning that the "Hall of the Slain" challenge is being looked at too 🙂

  • hroozenbeek
    1024 posts

    @chottodare Yes, absolutely. Popups for achievements would be both helpful and more fun / rewarding.

  • Athanasius
    14 posts

    Whilst today's 1.1.1 patch has added Achievements on PC/Connect, and I even have some Unlocked due to playing today, there's also a whole bunch *not* Unlocked that should be for me.

    e.g. "Take My Hand" - Complete the Cent Arc. "Disorder of the Ancients" - Eliminate all targets of the Order of Ancients.

    I'm so far along in the game (just a single bugged Mustery to go, plus finishing off the Fishing hand-ins) that there *aren't* any quests for me to complete if that's necessary to trigger the checks for associated Achievements. If the daily Reda quests do count for that then I guess completing them only triggered some of them.

    The "Complete the X Arc" ones are particularly perplexing as it's unlocked some (e.g. Hamtunscire), but not others (Cent, Wincestre).

  • hroozenbeek
    1024 posts

    @athanasius Many players have already reported that Take My Hand (Cent), The Enemy of My Enemy (Wincestre), and Disorder of the Ancients have not been unlocked for them, as you can read in the posts in this thread since the patch was released. I think it will be helpful for the developers to indicate all of the achievements that have not been unlocked for you even though you have fulfilled the requirements.

  • Kormac67
    656 posts

    @hroozenbeek These three are on the Known Issues List.

Suggested Topics

Community Details

110
Online
192.5k
Users
32.4k
Topics
162.4k
Posts