Welcome to discussions

Quick Suggestions

  • Kormac67
    656 posts

    @ubi-woofer Update:
    Patch notes are there ingame now.

    Did the Reda quests, no achievements.

    Tried "assassinate an enemy from your horse" (pretty sure never had tried that).
    Game showed an Ubisoft connect popup - and crashed. 😄
    Now achievements are there (all as achieved today sadly).
    11 are missing though: Cent, Winchestre, all Order, all territories (should be), all flytings, Excalibur, first Anomaly, all Alpha animals, 10 curse symbols, Thor's helmet, Mjolnir.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    I apologise for the delayed update. Following TU, the development team has marked this issue as resolved.

    If you are still having trouble unlocking achievements on PC following this update, please can you provide us with the following information:

    • Which achievements are you unable to unlock?
    • Have you tried repeating actions, if able to (such as in "Silent Viking" and "Seahorse")?
    • Have you been able to try completing additional quests? Some players have reported that completing settlement quests, such as Petra's archery challenge, has allowed them to trigger story achievements to unlock.
    • If you're able to provide any images/video that shows you have met the criteria but the achievement hasn't unlocked, this would be helpful. This could be an image that shows your completed quest log and missing achievement, or a video that shows you completing an action and the achievement not unlocking.

    We can then pass these reports to the development team for further investigation.

    @Jackov15 & @Lidi_Melo - Are you still missing achievements in-game after meeting the requirements following TU If so, please can you provide us with the information requested above.

    @RedIndianRobin - We don't yet have any new information to share regarding the missing achievement pop-up in-game. We've reached out to the team to see if we can get any new updates to share with you all.

    @Arthefran - We don't yet have any new updates to share about making a public API for achievements. I've reached out to the team to see if we can find out any additional information.

    Thanks! 😊

    Official Response
  • hroozenbeek
    1024 posts

    @ubi-woofer The same three achievements (Take My Hand, The Enemy of My Enemy, and Disorder of the Ancients) did not unlock for me too. By the way, the other achievements did not unlock immediately after completing one of Reda's daily quests, but several minutes later at the exact moment when I killed the target of the next daily quest, thus before this quest was actually completed by confirming the kill (I saw them unlocking on my second screen with Ubisoft Connect open). Was that a coincidence?

    And I guess I have some fun activities yet to do. Sliding in the snow, swimming with my horse, getting thrown 30 meters away... How is it possible I missed those? 😉 (And I thought I had lit all braziers on Hadrian's Wall just for the fun of it, but apparently I missed some.)

  • Kormac67
    656 posts

    @ubi-woofer Got "wielding Mjolnir" by just doing that (killing a patrol, wielding alone is not enough).
    Game did not crash this time.
    It said it sent a screenshot to Ubisoft connect, but I can't view it there.

    And it has fulfilled more achievements, now only Cent, Winchestre, All Orders, all territories (maybe) are missing.

    "It's not a bug, it's a feature" is now there (Valhalla in a nutshell).

  • Vilemos
    58 posts

    60 hours in (46%) and so far every achievment I should have completed seems to be in order. (hopefully those 3 achievments still not unlocking for others will get fixed soon)
    Sorry for the harsh word in the past, but it's been long 2 months.

    Thank you and have a good one

  • Chottodare
    3 posts

    What about, pc notification, pop up when achievement is completed? I thought its obvious for this system. It is not fun checking if it's completed again and again. 😢

  • cavveman
    84 posts

    I'm somewhat thankful I'm not receiving like 20 popups in a row when everything is awarded at the same time.

  • RivereyesGR
    12 posts

    Cent Story Arc achievement did not unlock for me, either.

  • Chottodare
    3 posts
    This post is deleted!
  • kwasowsky
    5 posts

    @chottodare It's a Connect issue. In New Dawn (new overlay) had the same thing. I had to check everytime if achievement is unlocked or not.
    Old uPlay overlay (Far Cry 5 and older) doesn't have same issue. We have to wait until it'll be fixed.

    I'm glad that Valhalla finally got the achievements tab. 😇 Although I waited so long that hype already passed so I'm gonna wait a little longer to be sure that everything is fixed with achievements meanwhile focusing on other games.

  • Chottodare
    3 posts

    @cavveman It would be only at first startup after the update? Achievement usually are not that common? I don't think you understood me.

  • auridulis
    48 posts

    @ubi-woofer Thanks a lot for mentioning that the "Hall of the Slain" challenge is being looked at too 🙂

  • hroozenbeek
    1024 posts

    @chottodare Yes, absolutely. Popups for achievements would be both helpful and more fun / rewarding.

  • Athanasius
    14 posts

    Whilst today's 1.1.1 patch has added Achievements on PC/Connect, and I even have some Unlocked due to playing today, there's also a whole bunch *not* Unlocked that should be for me.

    e.g. "Take My Hand" - Complete the Cent Arc. "Disorder of the Ancients" - Eliminate all targets of the Order of Ancients.

    I'm so far along in the game (just a single bugged Mustery to go, plus finishing off the Fishing hand-ins) that there *aren't* any quests for me to complete if that's necessary to trigger the checks for associated Achievements. If the daily Reda quests do count for that then I guess completing them only triggered some of them.

    The "Complete the X Arc" ones are particularly perplexing as it's unlocked some (e.g. Hamtunscire), but not others (Cent, Wincestre).

  • hroozenbeek
    1024 posts

    @athanasius Many players have already reported that Take My Hand (Cent), The Enemy of My Enemy (Wincestre), and Disorder of the Ancients have not been unlocked for them, as you can read in the posts in this thread since the patch was released. I think it will be helpful for the developers to indicate all of the achievements that have not been unlocked for you even though you have fulfilled the requirements.

  • Kormac67
    656 posts

    @hroozenbeek These three are on the Known Issues List.

  • robthebob11
    8 posts

    So here's a weird one. I just started a new game and during the tutorial mission assassinating a regular enemy unlocked the "Equine Attack" achievement for assassinating an enemy from your horse. I haven't even seen a horse yet, much less ridden one or fulfilled the intended achievement conditions.

  • RedIndianRobin
    186 posts

    None of the achievements unlocked for me. I have already completed the game and I have nothing left to do. [REMOVED]

  • eguy_4
    5 posts

    Completed game and a lot of the achievements aren't working. Also none of my stats are tracking properly. And the newly added challenges I'm not able to participate or complete.

  • Ruxleyford514
    1 posts

    @robthebob11 Exact same thing for me. On the first mission after the intro, killed an enemy with an arrow and unlocked “Equine Attack”. It was the first enemy I killed.

  • hroozenbeek
    1024 posts

    @kormac67 Just in case you misunderstood the point I was trying to make: I reacted on another post, where it was suggested (without reference to earlier posts about the same subject in this thread) that other quests than the three mentioned did not unlock. This player mentioned "a whole bunch". I don't regard three as "a whole bunch", so I was merely pointing out that the problem regarding these three achievements was already known, and that he should provide specific details regarding other issues he might have.

Suggested Topics

Community Details