Welcome to discussions

Quick Suggestions

  • Fireseed
    12 posts

    @Ubi-Woofer I encountering the exact same issue as @eguy_4 
    You requested a screenshot, don´t know how this really helps, but here it is, fresh taken from today shortly after playing the game:

    undefined

    For me also all statistics does not update properly, maybe these issues are connected. 🤔

  • Ubi-Borealis
    Ubisoft Support Staff 3529 posts
    Best Answer

    Hello there!

    I apologise for the delayed update. Following TU 1.2.0.1, the development team has marked this issue as resolved.

    If you are still having trouble unlocking achievements on PC following this update, please can you provide us with the following information:

    • Which achievements are you unable to unlock?
    • Have you tried repeating actions, if able to (such as in "Silent Viking" and "Seahorse")?
    • Have you been able to try completing additional quests? Some players have reported that completing settlement quests, such as Petra's archery challenge, has allowed them to trigger story achievements to unlock.
    • If you're able to provide any images/video that shows you have met the criteria but the achievement hasn't unlocked, this would be helpful. This could be an image that shows your completed quest log and missing achievement, or a video that shows you completing an action and the achievement not unlocking.


    We can then pass these reports to the development team for further investigation.

    @Jackov15 & @Lidi_Melo - Are you still missing achievements in-game after meeting the requirements following TU 1.2.0.1? If so, please can you provide us with the information requested above.

    @RedIndianRobin - We don't yet have any new information to share regarding the missing achievement pop-up in-game. We've reached out to the team to see if we can get any new updates to share with you all.

    @Arthefran - We don't yet have any new updates to share about making a public API for achievements. I've reached out to the team to see if we can find out any additional information.

    Thanks! 😊

    Official Response
  • xcodex94
    1 posts

    @ubi-woofer I also have a problem with the same three achievements on pc: Disorder of the Ancients, The Enemy of My Enemy, Take My Hand

  • Ubi-Woofer
    Ubisoft Support Staff 1009 posts

    Thanks for the image, @Fireseed! I've sent it across to the developers for them to review. Out of curiosity, if you view your progress in the challenges on the Ubisoft Connect website, does your contribution still show as 0? If so, this is possibly a larger issue with Ubisoft Connect and its tracking as a whole, but I cannot be sure, so if requested by them I'll also be forwarding the information to the Ubisoft Connect team. I haven't encountered this issue myself, as you can see below, but I'll be happy to forward any additional reports. Creating a separate thread for the limited-time challenges would probably be best however, so that we can ensure this thread doesn't stray too far off-topic.

    undefined
    @xcodex94 Thanks for your report! I've sent the details you've provided to the developers now. 🙂

    Official Response
  • EpicHobo69
    5 posts

    Hi! Appreciate the addition of achievements, just gotta say that im also having the issue where Cent and Wincestre arc trophies arent unlocking even though i have done them a long time ago. Also my Uplay these days keeps saying it "failed to synchronise achievements with cloud", is that an issue on client or server side?

  • Kormac67
    653 posts

    @ubi-woofer There was no error message.
    There just was a message telling the game had sent a screenshot to Ubi Connect, then it froze for a moment and crashed. It did send a crash report you possibly can link to the devs.
    I still have no idea what the screenshot should do in Ubi Connect - there is no function "show screenshot of achievement" there.

  • Gonzalez_1984
    3 posts

    Hi, I'm missing following achievements:
    'Take My Hand'
    'Disorder of the Ancients'
    'Old School Treasure Hunt'
    'Completionist All The Way!'

  • andreserrano77
    8 posts

    i think the only missing achievements from my side are the well known:

    • "Take My Hand" - Complete the Cent Arc
    • "The Enemy of My Enemy" - Complete the Wincestre Arc
    • "Disorder of the Ancients" - Eliminate all targets of the Order of Ancients


    Already reported by other users

    All the others are allready unlocked and the remaining missing ones are really missing (not done)

  • VasilyZaitsev42
    16 posts

    Now that achievements are added to pc, it seems not all are working. I have 3 still locked after completing the game. Cent arc, wincestre arc, and kill all order people. Those should have unlocked during the story but didn't.

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @vasilyzaitsev42 Hello there! Sorry to hear about this. I suggest reaching out to our dedicated support team so this can be looked into more closely.

    Official Response
  • kreutzgang
    635 posts

    Are the achievements bugged in this game? I'm missing some, like "complete x arc", or "eliminate all order of the ancients", which I've done. While the latter may refer to DLC (shouldn't though ...), the former def makes no sense, as I completed all arcs.

  • Cheva1ier.
    3 posts

    @Ubi-Woofer

    I downloaded the patch on the 14th of January but today i was available to logged-in and see if the achievements can be unlocked.
    I read all the posts from that day also because i didn't want to miss any important answer.
    But unfortunately my achievements remained locked.
    I have succeeded at least 33 of them cause i am at 92% of the main story with 150 hours in the game.
    Tried to travel to Norway and Vinland but nothing changed.
    Also i made a quest from Reeda without any luck.

    So how should i proceed ?

  • Tolkyyn
    76 posts

    I've done every Reda quest available since my Eivor got to England, yet the "Viking for Hire" challenge is just blank, nothing. Yet another bug. At least those of us on PC can see the challenges. To have done the required quests and not get credit for them is a bit infuriating.

  • FlavioSSA
    11 posts

    I´ve already ended the game and all the side quests. (Before this was fixed in Ubi Connect) How do i manage to make the achievments pop up?
    Thanks in advance.

  • Dan_Gabriel
    4 posts
    This post is deleted!
  • hroozenbeek
    1024 posts

    @flaviossa You should still be able to unlock the achievements by completing a quest from Reda.

  • Dan_Gabriel
    4 posts
    This post is deleted!
  • Dan_Gabriel
    4 posts

    I did a quest from Reda and i got all the achievents made till now, about 20.

    @hroozenbeek it worked. Thank you!!!

  • Dan_Gabriel
    4 posts
    This post is deleted!
  • FlavioSSA
    11 posts

    @hroozenbeek Thank you!! That did the trick 👍

Suggested Topics

Community Details

82
Online
191.2k
Users
32.0k
Topics
160.8k
Posts